Forum Clubic

Problème créa serveur DNS

Bonjour tout le monde :slight_smile:

J’ai installé une Ubuntu 7.04 server dans une machine virtuelle (VMware)

Après installation, j’suis passé en IP fixe (en modifiant /etc/network/interfaces)
J’ai configuré Bind, checkconf est OK et checkzone OK pour la zone directe et la zone reverse.

Problème quand je fais un nslookup : server can’t find test.lan: NXDOMAIN.

Une idée ?

Merci d’avance :wink:

Ca venait de mon resolv.conf… mais j’ai encore des problèmes :frowning:

  • J’accède à www.test.lan mais pas à test.lan :frowning:
  • Quand je fais un nslookup sur mon PC Windows XP (sur lequel tourne la machine virtuelle avec le serveur DNS) ca me retourne une erreur (impossible de trouver le nom de serveur pour l’adresse 172.16.140.37) (172.16.140.37 est bien en DNS sur mon PC Windows)

Fichier zone directe :

ns IN A 172.16.140.37
www IN A 172.16.140.37
serveurweb IN CNAME www
voisin IN A 172.16.140.31

Fichier zone reverse

37 IN PTR ns.test.lan.
37 IN PTR www.test.lan.
37 IN PTR serveurweb.test.lan.
31 IN PTR voisin.test.lan.

Merci d’avance :wink:

Donne l’intégralité de tes fichiers de conf ainsi que le name.conf

J’ai modifié le fichier zone reverse car un pote m’a dit un PTR par IP. Vrai ?

test.lan.directe :
$TTL 1D
@ IN SOA ns.test.lan. hostmaster.test.lan. (
2007071200
8H
2H
1W
1D )

@ IN NS ns.test.lan.

ns IN A 172.16.140.37
www IN A 172.16.140.37
serveurweb IN CNAME www
voisin IN A 172.16.140.31

test.lan.reverse :
$TTL 1D
@ IN SOA ns.test.lan. hostmaster.test.lan. (
2007071200
8H
2H
1W
1D )

@ IN NS ns.test.lan.

37 IN PTR test.lan.

named.conf :
// This is the primary configuration file for the BIND DNS server named.
//
// Please read /usr/share/doc/bind9/README.Debian.gz for information on the
// structure of BIND configuration files in Debian, BEFORE you customize
// this configuration file.
//
// If you are just adding zones, please do that in /etc/bind/named.conf.local

include “/etc/bind/named.conf.options”;

// prime the server with knowledge of the root servers
zone “.” {
type hint;
file “/etc/bind/db.root”;
};

// be authoritative for the localhost forward and reverse zones, and for
// broadcast zones as per RFC 1912

zone “localhost” {
type master;
file “/etc/bind/db.local”;
};

zone “127.in-addr.arpa” {
type master;
file “/etc/bind/db.127”;
};

zone “0.in-addr.arpa” {
type master;
file “/etc/bind/db.0”;
};

zone “255.in-addr.arpa” {
type master;
file “/etc/bind/db.255”;
};

// zone “com” { type delegation-only; };
// zone “net” { type delegation-only; };

// From the release notes:
// Because many of our users are uncomfortable receiving undelegated answers
// from root or top level domains, other than a few for whom that behaviour
// has been trusted and expected for quite some length of time, we have now
// introduced the “root-delegations-only” feature which applies delegation-only
// logic to all top level domains, and to the root domain. An exception list
// should be specified, including “MUSEUM” and “DE”, and any other top level
// domains from whom undelegated responses are expected and trusted.
// root-delegation-only exclude { “DE”; “MUSEUM”; };

include “/etc/bind/named.conf.local”;

zone “test.lan” {
type master;
file “/etc/bind/test.lan.directe”;
};

zone “140.16.172.in-addr.arpa” {
type master;
file “/etc/bind/test.lan.inverse”;
};

Merci d’avance :wink:

Bonjour,
A première vue cela semble correct, mais faudrait que j’ai la visu sur l’ensemble des fichiers…

pour t’aider voici mon blog et notemment la section qui porte sur la construction d’un DNS

www.info16.fr…