Forum Clubic

Probleme connection mandriva 2007 spring

Voila Mandriva recunais bien ma carte ethernet mais quand je branche le cable rien ne se passe. Je configure le réseau toujours rien.
Quand je fait clic droit, j’ai connecter eth0, je clique dessus et rien ne se passe : j’ai l’impression que ethà n’est jamais connecté.
Quelqu’un a til une idée ??

voici les caractéristique de ma carte (portable toshiba)
Identification
Fabricant: ?Realtek Semiconductor Co., Ltd.

Description: ?RTL8101E PCI Express Fast Ethernet controller

Classe de matériel: ?Ethernet controller

Connexion
Bus: ?PCI

Bus PCI n°: ?5

Périphérique PCI n°: ?0

Fonction PCI n°: ?0

Identifiant du fabricant: ?0x10ec

Identifiant du périphérique: ?0x8136

Identifiant secondaire du fabricant: ?0x1179

Identifiant secondaire du périphérique: ?0xff00

Divers
Module: ?r8169
Identification
Fabricant: ?Realtek Semiconductor Co., Ltd.

Description: ?RTL8101E PCI Express Fast Ethernet controller

Classe de matériel: ?Ethernet controller

Connexion
Bus: ?PCI

Bus PCI n°: ?5

Périphérique PCI n°: ?0

Fonction PCI n°: ?0

Identifiant du fabricant: ?0x10ec

Identifiant du périphérique: ?0x8136

Identifiant secondaire du fabricant: ?0x1179

Identifiant secondaire du périphérique: ?0xff00

Divers
Module: ?r8169

Bonsoir,

Avant toute chose il faut vérifier si ta carte réseau fonctionne correctement. Pour cela je te propose de lancer un terminal (Konsole sous KDE ou Terminal sous GNOME) et tu tapes dans l’ordre, je met en () à quoi sert la manipulation :

[julien@mandristation Desktop]$ su (cette commande demande le changement de login utilisateur vers le super-utilisateur “root”) tu fais entrée pour taper le mot de passe ‘root’ le curseur ne bouge pas c’est normal) et tu dois avoir cela :
[root@mandristation Desktop]# (remarque le # qui indique que tu es en root)
puis tapes la commande suivante :
[root@mandristation Desktop]#ethtool eth0 (logiciel pour obtenir des infos sur ta carte réseau 0)
Settings for eth0:
Supported ports: [ MII ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Full
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Full
Advertised auto-negotiation: Yes
Speed: 100Mb/s
Duplex: Full
Port: MII
PHYAD: 1
Transceiver: external
Auto-negotiation: on
Supports Wake-on: g
Wake-on: d
Link detected: yes
Voilà par exemple le mien pour comprendre l’ensemble de ces informations essentielles :
{10baseT/Half 10baseT/Full 100baseT/Half 100baseT/Full 1000baseT/Full } les différentes vitesses que ma carte réseau accepte c’est une 10/100/1000 MBits
{ Advertised auto-negotiation: Yes } Ma carte est capable de régler toute seule la vitesse où elle doit fonctionner par rapport au matériel à laquelle elle est branchée, dans mon cas sur une Freebox V5, la grise, qui est un switch 100MBits le paramètre { Auto-negotiation: ON } on sait que ce paramètre est activé et en fonction.
{ Link detected: yes } La carte réseau est branchée et communique bien avec l’appareil à l’autre bout du cable (ma Freebox)
Je fais volontairement l’impasse sur les autres paramètres. Vérifie deja tout cela, ensuite vérifie aussi si ton réseau est en DHCP ou en adresse IP statique.
DHCP tu as un routeur (Freebox, Livebox ou matériel Linksys qui attribue une adresse IP à ta machine)
IP statique : tu renseignes toi meme les paramètres réseaux dans le gestionnaire de configuration réseau de Mandriva Control Center (MCC)

Si tout ok! à ce niveau, on pourra continuer les manipulations.

++

voila ce qui est écrit quand je fait la commande ethtool :
Settings for eth0:
Supported ports: [ TP ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Full
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
Advertised auto-negotiation: Yes
Speed: Unknown! (0)
Duplex: Half
Port: Twisted Pair
PHYAD: 0
Transceiver: internal
Auto-negotiation: on
Supports Wake-on: pumbg
Wake-on: g
Current message level: 0x00000033 (51)
Link detected: no

Sachant que le cable été connecté, et que je me connecte a la fac a laide d’un proxy (nom domaine + port) avec id et mot de passe.
Commment doit je configurer la connection ?
Sous ubuntu il me suffit de changé les paramètre avancé de connection dans firefox et c bon, mais sous mandriva il me met tj que le reseau est déconnecté.
Edité le 02/10/2007 à 11:59

Salut,

Peut-être que c’est l’ipv6 qui pose problème :idee:

tu peux le désactiver complètement (si tu n’en a pas l’utilité) en éditant /etc/modprobe.conf en y rajoutant à la fin install ipv6 /bin/true

Salut,

Dans le mandriva control center ou mcc tu as dans la meme rubrique que la gestion de la carte réseau un bouton “Configurer un serveur proxy pour les fichiers et la navigation internet”, il te suffit de le remplir et ca devrait marcher. Par contre je pense que tu as un soucis malgré tout avec le paramètre :
“Link detected: no & Speed: Unknown! (0)” change de cable aussi au passage car il semble que ta carte soit pas connecté comme il faut sur ton modem/routeur.

Bon courage.

Voila le modprobe.conf :
lias eth0 r8169
alias sound-slot-0 snd-hda-intel
install scsi_hostadapter /sbin/modprobe ata_piix; /sbin/modprobe ahci; /sbin/modprobe sbp2; /bin/true
remove snd-hda-intel /sbin/modprobe -r snd-pcm-oss; /sbin/modprobe --first-time -r --ignore-remove snd-hda-intel
install snd-hda-intel /sbin/modprobe --first-time --ignore-install snd-hda-intel && { /sbin/modprobe snd-pcm-oss; /bin/true; }
remove tifm_7xx1 /sbin/modprobe -r mmc_block; /sbin/modprobe --first-time -r --ignore-remove tifm_7xx1
install tifm_7xx1 /sbin/modprobe --first-time --ignore-install tifm_7xx1 && { /sbin/modprobe mmc_block; /bin/true; }
install usb-interface /sbin/modprobe uhci-hcd; /sbin/modprobe ehci-hcd; /bin/true
alias eth1 eth1394
alias ieee1394-controller ohci1394
install ipv6 /bin/true

ça ne change strictement rien !!! la connection n’est pas reconnu, mème en changeant de cable.

Tu es en double boot avec windows ?
Si oui ça pourrait être ce problème : gentoo-wiki.com… , il faudrait activer Wake-on-lan after shutdown dans l’utilitaire sous windows.

heu je galère trop pour arriver a trouver la fonction wake on lan after shutdown dans windows vista (je galère trop avec vista) !