Forum Clubic

Problème carte graphique carte Asus Xonar DS Windows 7

Bonjour à tous, je poste ici dans l’espoir de trouver un peu d’aide concernant un problème que je rencontre actuellement avec ma nouvelle carte son Asus Xonar DS sur windows 7 64Bit.
La carte est bien installée avec les pilotes à jour, simplement je rencontre un problème avec mon panneau audio windows qui reconnait bien la carte en tant que périphérique de lecture par défaut mais n’affiche aucune activité externe dessus.
Je vais tenter d’être le plus clair possible grâce à quelques screenshot.

Voici ce que donne le panneau audio en lecture quand une musique est lancée dans foobar par exemple : la barre d’activité reste inactive, pourtant j’ai bel et bien du son.

[http://img41.imageshack.us/img41/4804/panneau1y.jpg

Uploaded with ImageShack.us

Vous allez me demander ou se trouve le son alors, et bien la barre d’activité est associée au panneau enregistrement aux sons wave comme le montre cette capture.

http://img683.imageshack.us/img683/9725/panneau2p.jpg

Uploaded with ImageShack.us

http://img860.imageshack.us/img860/1721/panneau3.jpg

Uploaded with ImageShack.us

Or, si je désactive le son wave, le son ne se coupe pas, rien ne se passe. Normal il n’est affiché que pour être enregistré au final.

Seulement voilà, le fait de ne pas avoir l’activité sonore associée au panneau lecture m’empêche de réaliser plusieurs choses essentielles :

Diminuer le son ou le monter dans Foobar 2000 (malgré le fait que le périphérique soit bien spécifié dans les options), le son reste le même que je le monte ou le descende avec le curseur

Capturer des vidéos avec Fraps comprenant un enregistrement du micro et de la voix en simultané, en gros, c’est soit je met le micro en principal et je capture ma voix, soit je met wave et je capture le son du jeu, mais pas les deux en mm temps.

Bref, c’est assez pénible et je n’aimerai pas avoir à repasser à mon ancienne carte son pour un problème qui, je suis sûr, est tout bête.

Avez-vous des pistes pour définir cette carte comme périphérique de lecture par défaut dans tous les programmes et jeux ?

Merci d’avance
Edité le 12/04/2011 à 00:15

T’as bien virer tout les drivers de ton ancienne carte son?

Tout à fait, tout est clean


Petit up : lorsque je passe par windows media player, l'activité sonore apparait bel et bien sur le panneau lecture cette fois. Simplement, ce n'est toujours pas le cas pour mes jeux et foobar.

Personnellement avec ma Xonar, je vois pas ca non plus dans ce pannel le son.

Toutefois, je ne suis pas avec le built-in plug-in de Windows DirectSound. Je suis avec ASIO, alors c’est normal.

La votre gere aussi ASIO nativement dans les drivers (apparamment). Ces drivers la sont des dizianes e fois pus performant que ceux avec WIndows et offre un bien meilleur son que DirectSound (sur un kit hi-fi ou de quoi de bon qui peut nous faire voir la difference evidemment. Ca sera pas avec des speakers a 50 euros qu’on verra quelque chose). Mais l’avantage de ces drivers la, c’est qu’il vont exploiter plus en profondeur le processeur Audio de la Xonar.

www.foobar2000.org… place ca dans C:\Program Files (x86)\foobar2000\components

Dans Foobar Preferences :

Playback -> Output -> ASIO Virtual Devices. Tu add celui qui apparait.

Dans Output, tu choisis ASIO : Xonar DS ASIO

Bref c’est ca que j’ai fait pour ma Essence STX.

J’ai aussi mit dans les propriete de speakers le 24-bit / 192 KHz question de faire fonctionner la carte a son plein potentiel lorsque les driver DirectSOund embarque (pour tout ce qui est hors Foobar).

Les drivers Asio c’est dur a parametrer. Faut trouver le bon response time (perso je suis a 40 ms, en bas de ca j’ai des craquements et Foobar plante).

POur les jeux, faudrait mettre par defaut le StereoMix je crois.

Bonne chance !

Merci pour cette réponse, je test ça dans la journée et je te tiens au courant.:slight_smile:

Ok je viens de tester, le plugin fonctionne sous foobar mais me pose un problème. Lorsque je lis une musique sous foobar, je n’ai plus de son sur aucun autre programme…Le son revient dès que je coupe le son de foobar. Les asio doivent prendre le dessus sur toutes les autres sources…
Bref, ma question va sans doute parraitre bête, mais y’a t-il possibilité de repasser en pilote directsound ? Du moins pour un moment histoire de finaliser quelques enregistrements dans de meilleures conditions ?

Oui c’est normal, les ASIO sont en priorite. Ca fait ca moi aussi. C’est pour du Hi-Fi, alors ca coupe tout le reste. Moi ca me plait.

Pour repasser en directsound, allez dans Output -> Primary audio driver.

Donc en gros si je comprend bien, je ne peu pas lancer foobar en mode asio en tâche de fond avec un jeu par dessus par exemple (je n’aurai pas le son du jeu). Je dois donc passer par directsound et me priver du contrôle du volume de foobar.
Pas super opti tout ça…
Concernant la capture de son micro+output(le son du programme, du jeu) via fraps, je cherche encore la solution…sachant que par exemple fraps va me capturer et le son et ma voix si j’enregistre une vidéo sur dailymotion par ex, la sortir audio étant bien gérée par directsound, mais n’enregistrera que ma voix si je lance un jeu (dans lequel je pense les codec asio prennent le dessus tout en passant à la trappe dans fraps).
Bref, c’est un peu galère tout ça et je n’ai pas du tout envie de repasser sur ma XFI xtrem audio vu la calamité que sont les drivers sous windows 7 64.


Sinon je viens d'y penser, y'a t-il un moyen de faire gérer à Asio tous les sons du pc, histoire de ne plus avoir à switcher sans arrêt ? Edité le 12/04/2011 à 18:42

J’ai réussi à capturer et ma voix et le son de mes jeux via fraps. La manip est simple mais tordue ;D

Ouvrez le panneau Xonar DS audio center et décocher GX.
Fermer le panneau et le clore en cliquant droit dessus.
Le relancer via démarrer/programme
Lancer votre jeu

Et miracle, le son du jeu passe bien par direct sound et non par asio, rendant possible la capture voix/son combinée via fraps. Lorsque je ne souhaite pas enregistrer, je n’ai qu’a réactiver gx dans les options.

Perso pour moi DirectSOund gere tout sauf Foobar … On a pas le choix je crois … A moins de changer le driver dans le kernel de Windows …

Perso je pense que les drivers Asus prennent le dessus sur ma config lorsque GX est activé. Bref, le problème est résolu et je devrai switcher de mode lors de mes phases de capture sous fraps. Rien de bien méchant au final mais c’était casse tête.
Au passage, Foobar en Asio avec un casque pro sur les oreilles est un vrai régal.

Quand je le dis que malgré son aspect “brut de décoffrage” c’est le meilleur lecteur audio :oui:

Tu utilise le DSP de resamplage ?