Forum Clubic

Problème avec steamapps en double

bonjour à tout le monde, je passe ici pour vous demander un petit renseignement car il se passe des choses sur mon ordinateur que je ne comprends pas, alors le premier défaut, dans mon dossier Steam j’ai le dossier steamapps avec le dossier common ou je vois mes jeux installés sept ans tout. et dans le dossier steamapps y il y a un autre dossier steamapps avec dedans le dossier common où il y a de jeu de dans, je ne comprends pas pourquoi il y a ces deux dossiers steamapps.:etonne2:

De plus j’ai créé un raccourci sur mon bureau du jeu euro truck simulator2 à partir du dossier bin win_x64, eurotrucks2.exe, et quand je démarre depuis ce raccourci le jeu est en 32 bits.:etonne2:

encore un autre problème, j’ai une carte vidéo NVIDIA GeForce GTX 970, et quand je démarre un jeu par GeForce_Experience
le jeu plante, le jeu démarre et quand je clique sur un icône du jeu il plante.
De plus dans GeForce_Experience, il reconnaît mes jeux mais il y a deux fois la même étiquette de jeu c’est-à-dire que je clique sur l’une ou l’autre le jeu démarre en 32 bits moi j’aurais pensé qu’il y avait une étiquette pour le 32 bits et une étiquette pour le 64 bits.
Je précise que je suis sous Windows 10 64 bits.
Si vous pouviez éclairer sur ces diverses problèmes j’en serais ravi. Je vous remercie d’avance et sur ce bonne journée à vous.
PS : je précise aussi que mon Windows est à jour et que ma carte graphique l’est aussi, ainsi que mes jeux.
Edité le 23/05/2017 à 11:48

bonjour tout le monde, je constate que je n’ai pas de réponse, y aurait-il un problème dans la compréhension de ma demande car si c’est le cas je peux reformuler. vous comprendrez ma demande car le deuxième dossier steamapps pèse quand même 15 go et sur un SSD cela fait du volume.

steam : c’est exactement les même jeux? ou pas du tout les même?

  • si c’est pas les même, faut voir si steam sait les gérer :
  • les jeux des 2 répertoires sont dans sa liste de jeu “installé”? : il y a eu un problème d’adresse dans la base de registre a un moment donné et steam les mettait alors au mauvais endroit : pas de problème en vu, juste des jeux en trop
  • les jeux d’un des 2 répertoires ne sont pas installés dans la liste de steam : surement des vieux restes : steam à l’arrêt tu renommes autrement le répertoire common des jeux qui ne sont pas connus par steam , et tu regardes ensuite si steam fonctionne correctement, si pas de problème dans l’utilisation de steam pendant qq heures (ou jour si tu veux être sur) tu supprimes ce répertoire renommé
  • j’y crois pas trop car mais si c’est les même : si tu ajoutes un fichier quelconque à un répertoire de jeu de l’un, il apparait aussi dans l’autre répertoire? -> cela voudrait dire que le deuxième steamapp c’est juste un lien symbolique vers le premier, cela ne prend pas de place sur le hdd c’est juste un raccourci spécial qui fait une liaison invisible (pour les executables) entre les 2

pour geforce experience, c’est peut etre juste le lanceur du jeu et l’executable du jeu qui sont vu?
pour le plantage peut etre (supposition!) un probleme de droit utilisateur, le jeu est lancé avec des droits trop restreints ou trop élevé, il hérite des droits de geforce experience qui sont inadapté pour lui et ne prend pas le focus. quand tu cliques tu cliques sur l’application derrière le jeu. -> essaye de faire un alt + tab pour sortir du jeu, puis qq alt+tab pour y revenir avant de cliquer dans le jeu
peut etre (supposition2!)l’effet d’un antivirus aussi, un executable qui lance un autre executable cela peut être louche. et si geforce experience a été mis en lancement " bac à sable" je ne sais pas trop quel effet cela aurait sur un jeu lancé par lui

semblerait qu’il faille un -64bits dans la ligne de commande de eurotrucks2.exe pour qu’il démarre en 64bits
dans le raccourci, dans cible
“chemin\eurotrucks2.exe” -64bits
ou
“chemin\eurotrucks2.exe” “-64bits”
ou
chemin\eurotrucks2.exe “-64bits”
(normalement les “” c’est quand il y a un espace ou caractère pas appréciè dans la ligne de commande, je ne sais pas si le - en aura besoin ou si tu as déjà un espace dans ta ligne de commande, par defaut faut laisser comme c’est et ajouter -64bits, puis le mettre entre “” si problème/change rien, puis ajouter “” dans le chemin avant si c’est toujours pas cela avec 2eieme essai)
Edité le 25/05/2017 à 12:21