Forum Clubic

Problème avec mysqldump

:hello:

Je cherche à faire un dump d’une base pour l’exporter vers un autre serveur. Le user du deuxième serveur n’a que les droits SELECT et DELETE.

Seuleument, mysqldump (v 5.0) me rajoute une ligne

/*!40000 ALTER TABLE `releves` DISABLE KEYS */;

Et comme le user n’a pas le droit ALTER TABLE, l’importation ne fonctionne pas. Je ne veux pas supprimer à la main, cette tâche sera executée chaque jour par un cron.

la doc indique qu’il faut rajouter l’option –disable-keys à mysqldump pour avoir ce “alter table”, je n’ai pas mis l’option et j’ai quand même le “alter table”.

comment faire pour qu’il ne soit pas inclu dans le dump ?
Edité le 13/08/2007 à 09:54

Si tu veux passer l’étape, rajoute simplement l’option --skip-disable-keys.
Elle fait partie des options rajoutées par défaut par mysqldump :

(man mysqldump)

Merci je testerais ça :]

Edit: C’était bien ça.
Edité le 13/08/2007 à 09:54