Forum Clubic

Probleme avec mon serveur ftp

Salut.
Voila j’ai installé filezilla server sur mon ordi qui se connecte a internet via une neufbox.
Puis j’ai installé filezilla et je n’arrive pas à me connecter a mon server (enfin si mais je n’ai pas le listage du répertoire). J’ai demandé a des amis d’essayer de leur ordi et il on les même soucis que moi.
Et l’erreur est
" Erreur : Le canal de transfert n’a pas pu être ouvert. Raison : Aucune connexion n’a pu être établie car l’ordinateur cible l’a expressément refusée.
Erreur : N’a pas pu récupérer la liste du répertoire"
Suivi de :
“425 Can’t open data connection.”

Sachant que pars je ne sais quoi ça fonctionne du genre une mâtiné puis paf plus rien et l’erreur.

Si quelqu’un pouvait m’aidé svp

Ps: antivirus sygate et même chose qu’il soit actif ou pas.

Je ne possède pas ta box, mais je suppose que si elle fait office de routeur, il faut lui définir les règles de NAT pour qu’elle sache que lorsqu’on vient chez toi sur le port 21 (FTP) il faut qu’elle redirige vers l’adresse IP de l’ordinateur ayant le serveur FTP d’installé …

Un peu comme ca :

http://www.clubic.com/article-31687-5-conf…-pas-a-pas.html

Image : redirection de port => faire le meme que le port 21

http://www.clubic.com/afficher-en-plein-ecran-270782.html

Mon port 21 est déja redirigé.

Redirige aussi le port 20 si ce n’est pas déjà fait.

Vérifie aussi que le mode Passif (PASV mode) soit configuré de la meme maniere sur le serveur et le(s) client(s).

verifié et j’ai redirigé le port 20 aussi.
J’ai meme essaié de redeirigé les ports 50000 a 60000 que j’ai dédié au mode pasif sur le serveur et sur le client.

Apres quelque rebout ça fonctionne mais jusqu’a quand.

Et voila ça recommence.
“Erreur : Le canal de transfert n’a pas pu être ouvert. Raison : Aucune connexion n’a pu être établie car l’ordinateur cible l’a expressément refusée.
Erreur : N’a pas pu récupérer la liste du répertoire
Réponse : 425 Can’t open data connection.”
Et je sais pas pourquoi alors que ça fonctionnais hier apres midi et que j’ai rien arreté.

HELP!!!!!!

salut,
qd jai eu se probleme j’ai du redriger les ports 50000 a 50100 en ftp pour le passif… si tu veux je peux faire un test voir si de l’exterieur ca passe…

j’ai trouvé une solution de merde c’est de débrancher ma neufbox et redémarer l’ordi.
Mais il me faut une autre solution

:frowning: sacré soluce…
personne n’arrive a se connecter a ton ftp?

Comme tu dis je veux bien que tu essais mais la ça fonctionne (mon pére est connecté et a la liste de repertoire) et je sais toujours pas pourquoi.
Je me demande si ce ne serais pas les ports qui une fois ouvert ne se referme pas?

étrange effectivement… vous etes en reseau?

Donc j’ai deux ordi en réseaux chez moi derriere la neuf box et mon pére la meme chose chez lui (a 500km) mais derriere un freebox.

On dirait que le NAT ne fait pas son job… as tu essayer de repartir a zero sur ton serveur… le desinstaller et de le reinstaller…??
N’as tu pas trop bidouiller au niveau des options du seveur?

Oui j’ai déja essayé de desinstaller et de rreinstaller.
Je pense que le nat fais son job car on peux ce connecter le probleme c’est le chargement de la LIST de répertoire ne se fait pas et a partir de la on peux rien faire.
J’ai bidoullé que se que je connaisai ou ce que j’ai pu lire ici ou la et quand ça fonctionnait pas mieux je remettais par default.

Faudrait peut être essayer avec un autre server ftp…
http://www.01net.com/windows/Internet/serv…ches/22944.html en esperant que ca te depanne

Je l’ai déjà essayé j’utilisais que celui-là avant et dernièrement quand j’ai voulu m’en resservir ça a merdé alors j’e suis passé a filezilla server et le Pb est le même.

Donc si t’as toujours le meme problème, ca peut venir du nat… enfin je pense… faudrait un pro là je pense… :frowning: sorry de t’aider plus

Pas grave merci quand meme je pense que ça doit venir de la neufbox car je l l’ai mis en route hier soir et ce matin ça tournais plus et me mettait cette ereur.

Juste une question tu eteinds pas ta neuf box le soir?