Forum Clubic

Problème avec mon boot.ini

Bonjour tout le monde!
Alors, voilà, comme l’annonce le titre, j’ai un léger problème avec mon fichier Boot.ini…

Au démarrage du PC, y’a marqué :
Fichier boot.ini non valide
Démarrage à partir de c:\windows

Un truc du genre… J’suis allé m’informer sur internet, un peu partout, et des personnes disent qu’il faut démarrer la console de récupération via le démarrage du système à partir du CD de Widows XP… Et bien soit, j’ai essayé, mais lorsque que je tape sur une touche pour démarrer à partir du CD-ROM, ils me lancent l’installation de Windows XP… Comme vous devez vous en douter, il est déjà installé, alors pourquoi vouloir l’installer à nouveau? Parce que le problème, là, c’est que je ne sais pas comment faire pour lancer la console de récupération et donc réparer mon problème…

Si vous pouviez m’aider, ce serais sympathique =). Merci!

C’est un problème Windows, je déplace :jap:

Ah, autant pour moi :yeux2:

Salut,

y’a quoi, dans ton boot.ini ?

il faudrait l’afficher.

Edité le 05/08/2009 à 10:46

Bonjour! ^^
Où est-ce que je peux te donner cette information? C’est dans le Disque C:\Windows? Si c’est le cas, je n’ai pas de fichier de ce nom il me semble. Mais je vais re-vérifier. =)

Dans c:\Windows, il n’y a rien.
Je suis allé sur Poste de Travail [clic droit] => Propriété => Avancé => “Démarrage et récupération” Paramètres => Modifier.

Il me dise que j’peux pas accéder au fichier, et ils demandent si j’veux en faire un nouveau… J’suis peut-être allé un peut trop vite mais, j’ai dit oui… x)

Et là, un fichier Bloc note vide s’affiche.
Edité le 05/08/2009 à 10:53

Salut,

c’est un fichier caché

Tu peux faire ça

Panneau de Configuration
Système
Onglet Avancé
paragraphe Démarrage et récupération
clique sur Paramètres
Paragraphe Démarrage du Système
puis clique sur modifier

copier coller

Je copie colle =). Et j’redémarre le PC?

(C’est fait)
Edité le 05/08/2009 à 10:56

Salut

t’as pas compris que je veux voir ce qu’il y a dans ton boot.ini
donc tu copies tout et tu le colles dans le message sur
le forum.
Ensuite, tu fermes ce boot.ini sans y toucher

ne valide aucun changement
sors en annulant du panneau de config
Edité le 05/08/2009 à 10:58


et alors ? étant donné que tu vas plus vite que la lumière, ça donne quoi ?

Il n’y avait rien d’écrit dans le boot.ini

=)

Et effectivement, j’ai fait le con… :frowning:
Edité le 05/08/2009 à 11:05

Si tu ne peux pas y accéder,
c’est que tu n’as pas assez de privilèges.

peux-tu démarrer en mode sans echec ?
Edité le 05/08/2009 à 11:06

Je suis administrateur. Je peux y accéder. Lorsque je clique modifier, y’a un fichier bloc note qui apparait sans rien écrit dedans.

Et ouai, j’pense que j’peux aller en mode sans échec. Mais une fois dedans, j’fais quoi? =)
Edité le 05/08/2009 à 11:09

Boot.ini vide = cause de l’erreur

Pourquoi ? vide as-tu essayé d’installer un autre système ?

sinon, voici un boot.ini pour un XP installé sur la partition C
en mono systeme
tu peux essayer de le mettre dans ton boot.ini vide.

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP " /fastdetect /NoExecute=OptIn
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS=“XP MODE SANS ECHEC” /fastdetect /Safeboot:minimal/sos/bootlog

Non, non, je n’ai installé qu’un seul OS depuis l’acquisition de ce PC. J’me casse pas trop la tête. XP ça me va =). En tout cas, ok, j’mets ça dans le truc =).

Et j’redémarre après?

oui, pour voir l’effet,
en espérant que ça fonctionne,
pas sûr.


qui ne risque rien n'a rien :nexath

Re. J’ai redémarré et au redémarrage, ils m’ont demandé si je voulais lancer Windows XP normalement ou en mode sans échec ou encore si je voulais afficher les options x)…

C’est normal?

J’y connais pas grand chose, mais il me semble que si j’enlève :
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS=“XP MODE SANS ECHEC” /fastdetect /Safeboot:minimal/sos/bootlog

Je n’aurais plus de “choix de démarrage” non? Mais je préfère ne rien faire x).

En tout cas, plus de message disant que boot.ini est non valide =)
Edité le 05/08/2009 à 11:39

tout est OK et le boot.ini est réparé.
crée un point de restauration

effectivement, si tu enlèves la deuxième ligne, il démarre par défaut sur XP “normal”
tu peux aussi abaisser le nombre de secondes pour l’affichage du choix
à la place de 30 , tu peux mettre 5.


mais tu peux aussi régler ça dans le panneau de config, etc...etc... tu peux décocher les options, changer le temps c'est plus propre de le faire ainsi.

Ok! Merci pour tout! =D

il avais juste a faire une reparration avec son cd de xp
comme ceci,
avec ses 2 commande-la fixboot et fixmbr

mon astuce/Tuto pour reparer xp pro
la première chose a faire ,est de utiliser le cd de démarrer avec .
apres linstallation des pilotes ,tu as 3 choix
Entré pour installer windows et R pour reparrer ou Échape pour sortir de linstallation
tu apuis sur R pour le réparration
il démarre en Dos et tu utilise ses 3 commandes-la une apres les autres
(fixboot,fixmbr et chkdsk ou chkdsk /r
chkdsk sil detecte que windows est defectueux il vas effacer et reconstruire
chkdsk /r lui il vas prendre la sauvegarde que windows sait fait lui meme,
chkdsk /r est un peut comme le programme de la restauration sisteme
windows protège ses fichiers

la deuxième manière est seulement avec le cd Xp Pro OEM
tu demarre avec le cd et tu fais un installation,rendus de ou est ecrit tes partitions
C:\Windows
tu appuis sur ®,il vas effacer le windows sans affecter tes données ,progrs,dossier mes documents,dorsier que tu a créer et aucune perte de tes fichies ect…
il reconstruit seulement ton windows
Edité le 06/08/2009 à 06:48

cela vas servire a ceux qui vont lire cela