Forum Clubic

Probleme avec les lettres de Lecteur

Bonjour, je sollicite votre aide car moi j’en perds mon latin (nan…je blague…a part “cave canem” je parle pas latin :wink: )
Bon déjà voilà un bref descriptif de la config:

un P4 3Ghz sur une carte mere Asus P4P800 512 de ram
2 Disques Durs Western Digital en IDE classique: un de 20Go et un de 80Go

Le probleme maintenant:
Les deux disques durs physique sont eux meme partitionnés en 2 dd logiques, soit 4 partitions en tout… C: D: E: F: (jusque là du classique)

Le probleme apparait lorsque j’éteins l’ordi: au redémarrage les partitions D et E sont inversées (avec les conséquences néfastes que vous pouvez imaginer-> raccourcis erronés…windows qui ne retrouve pas ses petits…etc…)… donc a chaque allumage du pc je suis obligé de passer par le gestionnaire de disque de windows xp afin de remettre manuellement les lettres comme il faut…
Maintenant la subtilité…si il s’agit d’un simple redémarrage tout se passe normalement=>l’anomalie décrite au dessus ne se produit que si il y a extinction complete du pc…

Voilà j’avoue ne pas comprendre ni meme savoir où chercher pour remedier a ce probleme…
Donc si vous avez la solution (on peux rever) ou meme quelques idées pour m’aider je les examinerai avec le plus grand intéret…
Par avance je remercie la communauté Clubic pour l’aide qu’elle voudra bien m’apporter!

Ce qui n’est pas logique, c’est d’utiliser des partitions logiques, il aurait mieux value utiliser des partitions primaires.

Mais ça n’explique pas ton problème … :frowning:

Peux-tu poster une capture d’écran de ton gestionnaire de disques stp ? Merçi.

Pas de probleme:

Et si tu procédais chaque fois une seule partition, avec une extinction complète du PC, genre :
1- D-> Z
2- extinction - allumage
3- E -> D
4- extinction - allumage
5- Z -> E
6- extinction - allumage

c’est pareil après chaque renommage ?

Moi, cela me semble normal, les lettres de lecteurs sont attribuées d’abord aux partitions principales, puis ensuite aux partitions logiques.

Mais on peut re-attribuer les lettres de lecteurs, et c’est ce que tu as essayé de faire.

Toutefois, on ne peux pas le faire pour les partitions système.

La PP de ton HD1 est une partition système, donc C: obligatoire.

La PP de ton HD2 est "active", donc est ptet considérée comme une partition système ( bootable ), donc D: obligatoire.

C’est ptet la solution du pb. Il faudrait la désactiver…

Autre chose: C’est quoi cette partition “fichier d’échange” ???

Les “commentaires” sont attribués par l’ordre de priorité : c’est quand une partition n’est ni système ni active mais qu’elle héberge pagefile.sys.

Ahhh ok !! :slight_smile:

Merci Ngle :wink:

Corgu a donc déplacé son swap sur le 2ème HD ! , c’est effectivement une bonne optimisation :wink:

Apres quelques recherche sur le pourquoi “du actif” cela semble effectivement etre une piste valable voir…prometteuse…le seul hic c’est que je ne sais pas pourquoi elle est active ni comment la rendre “inactive”…je creuse…et avec des rames croyez moi c’est pas facile…
Merci en tout cas!!!

Je ne suis pas absolument sûr que ce soit la cause de ton pb, ce n’est qu’une piste, surtout que la seule solution serait sûrement de repartitionner le HD, puis de reformater, ce qui est assez lourd. Surtout si ça ne résoud pas le pb… :confused:

Il suffit d’activer une autre partition :wink: