Forum Clubic

Problème avec géneric host process 32

Depuis que j’ai réinstallé mon pc, j’obtiens fréquement le message “Generic host process for win32 services à rencontré un problème et doit fermer.” Une fois le processus fermé, j’obtiens divers problèmes sur mon pc, le plus notoire étant qu’il m’est impossible d’installer certains logiciels ou d’aller dans ma configuration son, et je n’ai plus aucun son sur l’ordinateur. J’ai fait une recherche sur le sujet, et les seules réponses que j’ai pu trouver sur Generic host process for win32 services concernaient un problème d’accès au web, or je n’ai aucun problème pour y accéder. J’ai déjà essayé de désactivé le service DNS sans succès, je ne sais plus quoi faire. Après un nouveau formatage et une protection antivirus totale, le problème est toujours présent. AU SECOUR !

Salut,

C’est curieux qu’avec une installe propre ça produise ce probleme.
Piste de recherche:

Dans une invite de commande:
si tu as XP Pro, taper:
TASKLIST /svc

tu pourras voir le contenu des services gérés par les différents svchost.exe
et l’un d’eux gère tout ceci: ( extrait de la commande ,chez moi)

svchost.exe 852 AudioSrv, Browser, CryptSvc, Dhcp, ERSvc,
EventSystem, FastUserSwitchingCompatibility,
lanmanserver, lanmanworkstation, Netman,
Nla, RasMan, Schedule, seclogon, SENS,
ShellHWDetection, srservice, TapiSrv,
TermService, Themes, uploadmgr, W32Time,
winmgmt, wuauserv, WZCSVC

on voit que ce svchost ( le process 852 à l’instant de la commande) gère le service AudioRrv et Winmgmt ( Windows management) , ce qui semble correspondre à tes problemes ; mais attention, ce sont une conséquence de l’arret du process, et non la cause.

La marche à suivre serait donc de voir si tout tes pilotes ( cartes, périphériques) sont à jour, si tu n’utilises pas de theme exotique, si le réseau est bien configuré etc
En gros, quelque chose géré par ce svchost-là ( vaste entreprise, je le reconnais)

Je n’ai pas Xp pro, j’ai xp familial. Après quelques tests, il semble que le problème n’apparaisse que lorsque je suis connecté au réseau, mais c’est tout de même étrange car ma soeur est connectée au même routeur que moi et n’a pas ce problème. Pourtant l’explication tiendrait la route, car il y a 2 jours, nous avons installé un autre routeur pour un essai.

A défaut d’avoir pu résoudre le problème, j’ai trouvé d’où il vient, le fichier est svchost.exe dans c:/windows/system32 , maintenant, il faudrait que je trouve ce qui cause le problème :confused:

oui, c’est lui.
Svchost.exe est un gestionnaire de services , et on peut trouver jusqu’à 5 occurences du gestionnaire sur un PC , chaque occurence ayant à sa charge un certain nombre de services.

Est-ce que tu as du Peer to Peer , genre eMule ?
Vérifier les paramètres P2P dans ce cas.
Vérifier aussi du côté du firewall , si tu vois que ça arrive lorsque ton PC est connecté

J’ai bloqué le fichier avec un firewall logiciel et il semble ne plus y avoir de problème, mais c’est peut-être juste du au hazard puisque l’erreur survient après 1 heure comme après 2 minutes, j’espère que ça tiendra…