Forum Clubic

Probleme avec code::blocks sous windows

Bonjour,
alors que je n’ai aucun problème avec ce logiciel sous Linux, j’ai un souci avec sa version Windows.
Je crée mon pojet et s’affiche comme toujours dans main :
#include <stdio.h>
#include <stdlib.h>

int main()
{
printf(“Hello world!\n”);
return 0;
}
Quand je clique sur build and run, rien ne se passe, il est juste affiché ;
“essai - Debug” uses an invalid compiler. Skipping…
Nothing to be done.

J’en déduis qu’il faut un autre “compiler” mais lequel ?

Merci pour vos réponses !

Salut

Il y a certains problèmes avec les IDE sous windows, avant j’étais sur devc++, exactement le même problème. J’ai installé code::blocks et ça a marché. Je pense que certains programmes de l’os bloque la compilation, suivant l’IDE. Essaye soit devc++ ou visual pour voir si ça fonctionne, sinon il y a un gros problème.
Sinon quelle version de windows possède-tu ?
Edité le 07/02/2009 à 11:26

Salut,
Tu as pris la version sans le compilateur, il faut prendre celle-ci.

Salut, la version du post précédent datant un peu (normal me direz vous, le post a quand même 2ans^^), je me permet de mettre la version la plus recente (10.05) contenant bien sur aussi le compilateur MinGW. Pour le telecharger,C’est ici. (de mémoire le fichier fait environs 70 Mo)

Par contre, pour répondre au soucis du posteur originel, On peux aussi avoir ce soucis en téléchargeant la bonne version. Si lors de l’installation vous avez changé le chemin d’installation (après tout , vous devez pouvoir l’installer ou vous voulez hein;) ), il se peux que Code::Blocks ne detecte pas votre compilateur intégré MinGw.

Dans ce cas, la solution est simple rassurez vous! Il va simplement falloir le forcer a chercher un peu ou se trouve le compilateur. Donc:

-Faites Menu Settings>Compiler ans debugger
Une fenêtre s’ouvre. Profitez en pour pour vérifier que le compilateur sélectionné est bien : “GNU GCC Compiler”

-Aller dans l’onglet Toolchain executable et cliquez ensuite sur auto-detect.

Cela devrai résoudre le problème.

Je sais bien que le post initial date de 2 ans et que donc il a du trouver la solution a son soucis (enfin j’espère :stuck_out_tongue: ) mais en postant ici, je pense plus aux suivants.
Edité le 17/02/2011 à 19:15

Alors j’ai le même soucis et même en faisant cette manipulation, celle de l’auto detect ça ne marche pas.