Forum Clubic

Problème après installation Ubuntu (GRUB) (page 2)

Et en logiciels stp ?

Merci d’ailleurs pour le lien

Mon problème de Boot windows serait-il dû à ceci : [quote=""]
d. Pour booter sur Windows

Maintenant, il se peut que Grub n’arrive pas à lancer Windows. Il faut savoir que Windows est très exigeant : il n’accepte de se lancer que s’il est sur le premier disque dur. Cependant, il n’est heureusement pas très malin et nous pouvons le tromper facilement.
[/quote]

Voyant donc qu’il ne se situe pas sur la premier disque dur, il lancerait la partition de récupération windows

Ou dois-je faire celci ?
doc.ubuntu-fr.org…
Edité le 06/09/2010 à 20:15

Heu je n’ai jamais fait d’install d’un OS sur un disque usb :frowning: (car bon ca me semble étrange de le faire)
Qlqn sait?

Poste nous, s’il te plait, le contenu de ton fichier " /boot/grub/menu.lst " ou le contenu de ton /boot/grub/grub.cfg si tu as GRUB2.
Poste nous aussi la sortie de cette commande :

sudo fdisk -l

Il va te demander ton mdp, qu’il faut taper à l’aveugle (même pas de petites étoiles).

Edit, je viens de voire que tu as restauré le mbr de windows ><
Go réinstaller grub, tu ne bootera jamais ton linux avec le mbr de win$, ensuite fait ce que je t’ai indiqué plus haut…
Edité le 07/09/2010 à 14:03

Bonjour

Je viens d’installer Ubuntu sur mon disque USB avec les opérations faites à la lettre
Tout se passe bien jusqu’a la fin de l’opération où IL N4EXISTE NI DE FICHIER menu.lst NI grub.cfg. J’ai même cherché manuellement

J’ai rebooté donc sans faire cette opération et GRUB est apparu. Ubuntu a pu se lancer. Un fichier grub.cfg s’est crée

#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by /usr/sbin/grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
if [ -s $prefix/grubenv ]; then
  load_env
fi
set default="0"
if [ ${prev_saved_entry} ]; then
  set saved_entry=${prev_saved_entry}
  save_env saved_entry
  set prev_saved_entry=
  save_env prev_saved_entry
  set boot_once=true
fi

function savedefault {
  if [ -z ${boot_once} ]; then
    saved_entry=${chosen}
    save_env saved_entry
  fi
}

function recordfail {
  set recordfail=1
  if [ -n ${have_grubenv} ]; then if [ -z ${boot_once} ]; then save_env recordfail; fi; fi
}
insmod ext2
set root='(hd1,7)'
search --no-floppy --fs-uuid --set 71dcb630-5fcf-4625-849a-002ee917f071
if loadfont /usr/share/grub/unicode.pf2 ; then
  set gfxmode=640x480
  insmod gfxterm
  insmod vbe
  if terminal_output gfxterm ; then true ; else
    # For backward compatibility with versions of terminal.mod that don't
    # understand terminal_output
    terminal gfxterm
  fi
fi
insmod ext2
set root='(hd1,7)'
search --no-floppy --fs-uuid --set 71dcb630-5fcf-4625-849a-002ee917f071
set locale_dir=($root)/boot/grub/locale
set lang=fr
insmod gettext
if [ ${recordfail} = 1 ]; then
  set timeout=-1
else
  set timeout=10
fi
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/05_debian_theme ###
set menu_color_normal=white/black
set menu_color_highlight=black/light-gray
### END /etc/grub.d/05_debian_theme ###

### BEGIN /etc/grub.d/10_linux ###
menuentry 'Ubuntu, avec Linux 2.6.32-24-generic' --class ubuntu --class gnu-linux --class gnu --class os {
	recordfail
	insmod ext2
	set root='(hd1,7)'
	search --no-floppy --fs-uuid --set 71dcb630-5fcf-4625-849a-002ee917f071
	linux	/boot/vmlinuz-2.6.32-24-generic root=UUID=71dcb630-5fcf-4625-849a-002ee917f071 ro   quiet splash
	initrd	/boot/initrd.img-2.6.32-24-generic
}
menuentry 'Ubuntu, avec Linux 2.6.32-24-generic (mode de récupération)' --class ubuntu --class gnu-linux --class gnu --class os {
	recordfail
	insmod ext2
	set root='(hd1,7)'
	search --no-floppy --fs-uuid --set 71dcb630-5fcf-4625-849a-002ee917f071
	echo	'Chargement de Linux 2.6.32-24-generic ...'
	linux	/boot/vmlinuz-2.6.32-24-generic root=UUID=71dcb630-5fcf-4625-849a-002ee917f071 ro single 
	echo	'Chargement du disque mémoire initial...'
	initrd	/boot/initrd.img-2.6.32-24-generic
}
### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/20_memtest86+ ###
menuentry "Memory test (memtest86+)" {
	insmod ext2
	set root='(hd1,7)'
	search --no-floppy --fs-uuid --set 71dcb630-5fcf-4625-849a-002ee917f071
	linux16	/boot/memtest86+.bin
}
menuentry "Memory test (memtest86+, serial console 115200)" {
	insmod ext2
	set root='(hd1,7)'
	search --no-floppy --fs-uuid --set 71dcb630-5fcf-4625-849a-002ee917f071
	linux16	/boot/memtest86+.bin console=ttyS0,115200n8
}
### END /etc/grub.d/20_memtest86+ ###

### BEGIN /etc/grub.d/30_os-prober ###
menuentry "Windows NT/2000/XP (on /dev/sda1)" {
	insmod ntfs
	set root='(hd0,1)'
	search --no-floppy --fs-uuid --set 06a0fc5416d9b5d2
	drivemap -s (hd0) ${root}
	chainloader +1
}
menuentry "Windows 7 (loader) (on /dev/sda2)" {
	insmod ntfs
	set root='(hd0,2)'
	search --no-floppy --fs-uuid --set 4e2826db2826c1b7
	chainloader +1
}
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###

2 eme chose

matias49@matias49:~$ sudo fdisk -l
[sudo] password for matias49: 

Disque /dev/sda: 250.1 Go, 250059350016 octets
255 têtes, 63 secteurs/piste, 30401 cylindres
Unités = cylindres de 16065 * 512 = 8225280 octets
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Identifiant de disque : 0xaf9c5cc0

Périphérique Amorce  Début        Fin      Blocs     Id  Système
/dev/sda1               1        1274    10233373+  27  Inconnu
/dev/sda2   *        1275        7313    48508267+   7  HPFS/NTFS
/dev/sda3           12025       30401   147613252+   7  HPFS/NTFS
/dev/sda4            7314       12024    37841107+   f  W95 Etendue (LBA)
/dev/sda5            7314       12024    37841076    7  HPFS/NTFS

Les entrées de la table de partitions ne sont pas dans l'ordre du disque

Disque /dev/sdb: 1000.2 Go, 1000204886016 octets
255 têtes, 63 secteurs/piste, 121601 cylindres
Unités = cylindres de 16065 * 512 = 8225280 octets
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Identifiant de disque : 0xe8900690

Périphérique Amorce  Début        Fin      Blocs     Id  Système
/dev/sdb1   *           1       59084   474592198+   b  W95 FAT32
/dev/sdb2           59085      121601   502167777+   f  W95 Etendue (LBA)
/dev/sdb5           61875      100496   310231183+   7  HPFS/NTFS
/dev/sdb6          100497      101894    11229403+  82  Linux swap / Solaris
/dev/sdb7          101895      108488    52966273+  83  Linux
/dev/sdb8          108489      121601   105330141    7  HPFS/NTFS
/dev/sdb9           59085       61874    22410240   83  Linux

Les entrées de la table de partitions ne sont pas dans l'ordre du disque

Pour le problème de l’ancien boot windows qui lançait le disque de réparation, cette image veut tout dire :
http://a.imageshack.us/img525/4127/capturelk.png

Ce qui fait que je dois modifier (HD0,1) en (HD0,2) (partition vista) et (HD0,2) en (HD0,5) (partition Windows 7) ?
Edité le 07/09/2010 à 17:11

D’après archwiki, grub2 numérote toujours ses disques à partir de 0, mais numérote les partitions à partir de 1

=> /dev/sda1 = (hd0,1)
     /dev/sda3 = (hd0,3
     /dev/sdb1 = (hd1,1)
     /dev/sdc4 = (hd2,4)
.....etc...

J’ai fait comme je le sentais, j’ai donc modifié (HD0,1) en (HD0,2) (partition vista) et (HD0,2) en (HD0,5) (partition Windows 7). En utilisateur root
Première fois : j’ai fait “update-grub” et les paramètres n’ont pas été enregistrés. Idem sans.
J’ai cliqué les 2 fois sur “enregistrer” dans Gedit.

Ai-je oublié une étape ?

Tu étais bien en root quand tu as fait tes modifs ?

oui

-sudo -i
etc…

J’ai fait enregistrer dans Gedit

Terminal (en root) : update-grub
Il n’y avait plus mes modifications

Ça m’a fait pareil sans update-grub. J’ai rebooté, j’ai mis windows 2000/XP et je suis tombé sur la partition cachée

Dans Grub 2 Il n’y a plus de fichier de config clair et centralisant tout le shmilblik (en tous cas il ne faut pas le modifier directement), comme dans les anciennes versions, maintenant il faut s’amuser avec les fichiers du dossier /etc/grub.d/ …
A priori, il faut ajouter un truc du style :

menuentry "Windows" {
set root=(hd0,3)
chainloader +1
}

Dans le fichier 40_custom

EDIT
Pour ton cas, ce devrait être

Vista

menuentry "Windows Vista" {
set root=(hd0,2)
chainloader +1
}

# Seven
menuentry "Windows 7" {
set root=(hd0,5)
chainloader +1
}

Edit 2 :: j’ai viré le trool au début de mon post.
Edité le 07/09/2010 à 20:06

il n’y a que le fichier 40_custom a modifier ? Et de grub a un dual-boot, c’est la même chose ?

Je rajoute 2-3 trucs : après le premier boot grub, je suis allé sur ubuntu le mettre en français et le mettre à jour.
J’ai redemarre. Grub s’est lancé, j’ai booté sur ubuntu et là, lors du démarrage, s’est affiché une erreur et un problème d’affichage à l’allumage et extinction d’ubuntu. Le gestionnaire de mise a jour m’a indiqué un paquer “cassé”. Je n’arrive pas a le trouver. Ce n’est pas très embêtant et ça ne gêne pas.

J’ai ensuite fait les modifs sur le fichier de grub. (Voir anciens posts)
Pour vérifier, j’ai donc lancé l’option windows NT/2000/XP et je suis tombé sur la partition cachée.
redemarrage. Je lance cette fois l’option windows 7 (loader). Boot sur le disque interne et je tombe sur le dual-boot windows. J’ai choisi windows 7. Il se lance.

Et là, j’ai redemarré et je suis tombé direct sur le dual-boot windows. J’ai du appuyer sur Echap pour un reboot et tomber sur grub

[http://wiki.archlinux.org/index.php/GRUB2]
Le wiki d’archlinux a un article assez complet sur grub2 (comme, en fait, sur tous les programmes existant et ceux à venir).
A priori oui, pour les ajouts manuels au menu, ça se passe dans ce fichier

Et quelque part ailleurs il etait stipulé que modifier à la main le grub.cfg était assez déprécié (grub écrit automatiquement par dessus).

Pour le grub.cfg, j’ai lu ça aussi. La raison pour laquelle il faut être en root pour le modifier

Non, il faut être en root pour le modifier parce que c’est un fichier système, mais le fait de ne pas devoir écrire manuellement dessus, c’est parce que grub le génère lui même, à partir des fichiers présents dans /etc/grub.d/. Le truc c’est donc qu’il faut éditer les fichiers de ce dossier (dans ton cas “40_custom” car c’est pour rajouter une entrée autre qu’un GNU/Linux) et demander à grub de re-générer le grub.cfg…

Avant que je fasse une erreur, dois-je taper ces entrées à un endroit déterminé dans le fichier

EDIT : Problème : impossible de modifier le fichier (permission non accordée) et si je veux le faire via un terminal, je dois connaitre l’extension de fichier que je ne connais pas
Edité le 08/09/2010 à 15:47

Arf non dans un terminal tu tapes sudo bash et paf tu obtiens une ligne de commande avec toutes les premissions dont tu reves.
Pour ce qui est de l’extension il y a un touche magique sous linux “TAB”.
Tape “ged” TAB et ca va te completer ca directement en “gedit”.

“sudo bash” !? que c’est laid :ouch:

sudo -s : ça c’est bien :slight_smile:

fakbill@nano:~$ echo $SHELL
/bin/bash

donc bon :wink: (mais ok c’est laid si on n’utilses pas QUE bash (et encore…je scripte tout en python…je hais le shell dès qu’il faut programmer un peu))

Rien ne fait. Je n’arrive toujours pas à le modifier :frowning: