Forum Clubic

Problème à l'installation de .NET Framework 3.5 SP1

Lorsque j’installe la mise à jour SP1 pour .NET Framework 3.5, tout se télécharge bien mais à l’installation, il y a un blocage et le programme quitte.
Tout ce qu’il trouve à me dire est : ?[01/28/09,22:24:59] Microsoft .NET Framework 3.0 SP2 x86: [2] Error: Installation failed for component Microsoft .NET Framework 3.0 SP2 x86. MSI returned error code 1603
?[01/28/09,22:24:59] Microsoft .NET Framework 3.0 SP2 x86: [2] Error: Installation failed for component Microsoft .NET Framework 3.0 SP2 x86. MSI returned error code 1603
[01/30/09,18:55:02] Microsoft .NET Framework 3.0 SP2 x86: [2] Error: Installation failed for component Microsoft .NET Framework 3.0 SP2 x86. MSI returned error code 1603
?[01/28/09,22:24:59] Microsoft .NET Framework 3.0 SP2 x86: [2] Error: Installation failed for component Microsoft .NET Framework 3.0 SP2 x86. MSI returned error code 1603
[01/30/09,18:55:02] Microsoft .NET Framework 3.0 SP2 x86: [2] Error: Installation failed for component Microsoft .NET Framework 3.0 SP2 x86. MSI returned error code 1603
[01/30/09,19:04:49] Microsoft .NET Framework 3.0 SP2 x86: [2] Error: Installation failed for component Microsoft .NET Framework 3.0 SP2 x86. MSI returned error code 1603
?[01/31/09,16:25:08] Microsoft .NET Framework 3.0 SP2 x86: [2] Error: Installation failed for component Microsoft .NET Framework 3.0 SP2 x86. MSI returned error code 1603
?[01/31/09,16:25:08] Microsoft .NET Framework 3.0 SP2 x86: [2] Error: Installation failed for component Microsoft .NET Framework 3.0 SP2 x86. MSI returned error code 1603
[01/31/09,16:36:08] Microsoft .NET Framework 3.0 SP2 x86: [2] Error: Installation failed for component Microsoft .NET Framework 3.0 SP2 x86. MSI returned error code 1603
?[01/31/09,16:25:08] Microsoft .NET Framework 3.0 SP2 x86: [2] Error: Installation failed for component Microsoft .NET Framework 3.0 SP2 x86. MSI returned error code 1603
[01/31/09,16:36:08] Microsoft .NET Framework 3.0 SP2 x86: [2] Error: Installation failed for component Microsoft .NET Framework 3.0 SP2 x86. MSI returned error code 1603
[01/31/09,16:37:03] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0 SP2 x86 is not installed.
[01/31/09,16:43:01] Microsoft .NET Framework 3.0 SP2 x86: [2] Error: Installation failed for component Microsoft .NET Framework 3.0 SP2 x86. MSI returned error code 1603
?[01/31/09,16:25:08] Microsoft .NET Framework 3.0 SP2 x86: [2] Error: Installation failed for component Microsoft .NET Framework 3.0 SP2 x86. MSI returned error code 1603
[01/31/09,16:36:08] Microsoft .NET Framework 3.0 SP2 x86: [2] Error: Installation failed for component Microsoft .NET Framework 3.0 SP2 x86. MSI returned error code 1603
[01/31/09,16:37:03] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0 SP2 x86 is not installed.
[01/31/09,16:43:01] Microsoft .NET Framework 3.0 SP2 x86: [2] Error: Installation failed for component Microsoft .NET Framework 3.0 SP2 x86. MSI returned error code 1603
[01/31/09,16:45:15] Microsoft .NET Framework 3.0 SP2 x86: [2] Error: Installation failed for component Microsoft .NET Framework 3.0 SP2 x86. MSI returned error code 1603
?[01/31/09,16:25:08] Microsoft .NET Framework 3.0 SP2 x86: [2] Error: Installation failed for component Microsoft .NET Framework 3.0 SP2 x86. MSI returned error code 1603
[01/31/09,16:36:08] Microsoft .NET Framework 3.0 SP2 x86: [2] Error: Installation failed for component Microsoft .NET Framework 3.0 SP2 x86. MSI returned error code 1603
[01/31/09,16:37:03] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0 SP2 x86 is not installed.
[01/31/09,16:43:01] Microsoft .NET Framework 3.0 SP2 x86: [2] Error: Installation failed for component Microsoft .NET Framework 3.0 SP2 x86. MSI returned error code 1603
[01/31/09,16:45:15] Microsoft .NET Framework 3.0 SP2 x86: [2] Error: Installation failed for component Microsoft .NET Framework 3.0 SP2 x86. MSI returned error code 1603
[01/31/09,16:46:07] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0 SP2 x86 is not installed.
[01/31/09,16:54:30] Microsoft .NET Framework 3.0 SP2 x86: [2] Error: Installation failed for component Microsoft .NET Framework 3.0 SP2 x86. MSI returned error code 1603
?[02/03/09,18:58:38] Microsoft .NET Framework 3.0 SP2 x86: [2] Error: Installation failed for component Microsoft .NET Framework 3.0 SP2 x86. MSI returned error code 1603
?[02/03/09,18:58:38] Microsoft .NET Framework 3.0 SP2 x86: [2] Error: Installation failed for component Microsoft .NET Framework 3.0 SP2 x86. MSI returned error code 1603
[02/04/09,21:57:19] Microsoft .NET Framework 3.0 SP2 x86: [2] Error: Installation failed for component Microsoft .NET Framework 3.0 SP2 x86. MSI returned error code 1603
[02/04/09,22:03:44] Microsoft .NET Framework 3.0 SP2 x86: [2] Error: Installation failed for component Microsoft .NET Framework 3.0 SP2 x86. MSI returned error code 1603

EDIT : Je précise que j’ai toutes les anciennes versions de .NET Framework. Devrais-je les désinstaller ?
Edité le 04/02/2009 à 22:09

Salut

télécharge revo_uninstaller : www.01net.com…

supprime tout en option avancé

puis prends ici : www.clubic.com…

et installe

a+
Edité le 05/02/2009 à 17:43

Je désinstalle toutes les versions de .NET Framework ?

EDIT : Revo ne trouve pas les packages de désinstallation -_-
Le rapport parle de version 3.0 SP2, mais elle n’est pas installée sur mon PC et n’est pas sur clubic. Existe-t-elle ?
Edité le 05/02/2009 à 20:42

dans revo dans la barre de rechercher tape : framework

Il me semble que Microsoft dit que même s’il n’est pas absolument indispensable de désinstaller les anciennes versions du .Net Framework, il est tout de même fortement conseillé de le faire…

Perso, après l’installation de windows XP SP1, j’ai directement installé la version 3.5 SP1 du .Net Framework.

Ce que je voulais dire, c’est que lors de la désinstallation, (le logiciel apparait dans la liste de revo hein :wink: ) il me dit que “le composant se trouve sur un disque amovible non disponible, insérez le disque de .Net Framework et cliquez sur ok” :frowning:
Edité le 06/02/2009 à 17:23

tu fais ok,

et suivant et continue avec revo… en supprimant toutes les clefs et les dossiers

a+

Tout est désinstallé et l’installation de la version 3.5 SP1 a bien fonctionné, merci à toi vyger ^ ^)
Je suivrais dorénavant ton conseil Jacky67 :wink:

De rien

@+

:super:

Salut a tous

j’ai le meme souci et malgré les manips trouvées ici et sur d’utres forums, rien ne marche
la réinstall de .NET plante à la fin, error 1603

j’ai viré la clé de registre du Framework, utilisé l’utilitaire Framework Cleanup Tool
depuis le Framework n’apparait plus dans la liste des programmes intallés

le 3.0 apparait par contre dans la liste des composants de Vista qu’on peut Activer ou Désactiver.

j’ai tout essayé rien ne marche !
HELP !!!