Forum Clubic

Plantages Pilotes Nividia

Bonsoir,
Je viens de me faire une box Linux via une Fedora Core 4 sur un amd64, j’ai donc installé la version 64 bits et les pilotes nividia 64 bits (7676 et 7667) qui vont bien : compile, installation, lancement de X, tout fonctionne nickel.
Mais problème : dès que je switch d’une résolution à une autre dans un jeux OpenGL, paf, le PC se met à ramer sévere (avec les 2 versions des pilotes) et la obligé de reset (la touche magique ne fonctionne pas, l’input est toujours sur le jeux).
J’ai une MSI 6600 GT PCIE 128 mo pour information, vous me seriez d’une précieuse aide quant à un début de réponse :ange:

il est possible que ce soit du à un problème lié à la configuration d’une option dans Xorg. Afin d’éviter ce genre de problème, laisse moi te donner un petit conseil.
Je suis moi aussi utilisateur de la Fedora core 4 et j’ai également une version X86-64 et une 6600 GT. Un des avantages de Fedora c’est qu’il éxiste des packages pour les pilotes propriètaires comme ceux d’Nvidia, il te suffit pour les installer d’ajouter le depot de rpm.livna.org dans ta liste de depot de mise à jour.
Va sur rpm.livna.org et suis simplement la démarche à suivre. Par la suite il suffit alors de faire un simple yum install nvidia* pour avoir les drivers installés et surtout configurés tout seul comme il faut.
Fini les gallères d’édition de xorg.conf et autres problèmes de configuration, là tout marchera nikel avec en prime toutes les optimisations d’activées pour ton desktop :slight_smile:
Bref encore plus simple que sous windows :wink:

c’est clair que ça doit etre une option activée ou non dans le fichier de config de xorg qui doit poser problème.

Soit tu suis les conseils de LeGlop, soit tu postes ton xorg.conf (se trouvant dans /etc/X11) et ce sera plus facile de voir ce qui ne va pas :wink: .

Enfin j’essaierai plutot la methode de LeGlop, ça me semble plus sain de passer par yum.

Ce n’est pas une option de mon fichier Xorg qui est en cause car il est tres minimaliste et j’ai d’ailleur corrigé le problème en installant de vieux pilotes (les 7167) : cela montre bien que le problème vient des pilotes (vu aussi chez nvnews).
Merci quand même :slight_smile:

Justement ça peut tout aussi bien provenir d’une option qui n’est pas spécifiée. A l’époque ou j’avais une autre machine les pilotes plantait si je ne spécifiais pas explicitement l’utilisation du driver AGP Nvidia au lieu du pilote libre AGPart habituellement utilisé.
Maintenant je suis d’accord avec toi, au final le problème vient toujours des pilotes, mais des fois il éxiste une option de configuration qui permet d’avoir un support stable.
Enfin, à l’avenir je te déconseille quand même d’essayer d’installer les pilotes Nvidia à la main sur la Fedora, alors qu’il éxiste une manière bien plus simple et “error-free” :wink:

Yopla :slight_smile:
Je ne les ai pas installé à la main mais depuis l’installeur de Nvidia, ca fonctionne sans problème apparant.
Mais bon, je persiste en disant que ca vient d’un bug des pilotes, ce n’est pas la première fois, j’ai déja eu un problème avec les tous premiers pilotes Geforce et j’ai discuté avec les développeurs pour régler le problème … sans succès !
Je leur ai soumis une hypothèse qu’il leur a semblé crédible (pb du ramdac) et ont fait un patch qui a effectivement corrigé le problème.
Donc il y a quelques rares cas qui sont inhérents aux pilotes :slight_smile:
En tout cas, pour le moment, tout fonctionne au poil, c’est stable.

Ok mais c’est bien ce que j’avais compris. Quand je dis “à la main” ça sous entends avec l’installeur Nvidia (qui t’oblige à aller éditer toi même les fichiers de conf).