Forum Clubic

[php] probleme avec oscommerce (fichier php.ini!)

salut a tous

j’ai un probleme avec oscommerce!!quand je le met sur mon serveur il me met une erreur “FATAL ERROR: register_globals is disabled in php.ini, please enable it!”
et je ne sais pas quoi faire!!!

merci de m’aider A++

et bien tu mets register_globals à on dans le php.ini :slight_smile:

ok mais il est ou se fichier?
j’ai trouve

php.in.dist
php.ini-recommended

je l’ai peux etre trouver dans le fichier php.ini.dist il ete bien sur off mais sa marche toujours pas!!

Tu as redémarré Apache/PHP ?

HPPP > on sait où il se trouve le register_globals, inutile de balancer tout ton fichier de config php

sinon ce n’est pas ce fichier là qu’il te faut éditer, mais le php.ini TOUT COURT :oui: … si tu est sur un système windows, il doit se trouver dans C:\Windows, ou dans un dossier accessible par ton path System, ou dans le dossier d’apache.exe :wink:

bon j’ai fait une recherche dans tous mon pc mais il n’as rien trouve!!!!

comment tu envoie t’on message pour dire que IE est de la MRD???

merci A++

heureusement que tu n’as pas trouvé ce fichier parce que register_globals à on, parce que c’est souvent concidéré comme une source de failles de sécurité si le code n’est pas de toi.

voici ce qui est écrit dans le php.ini :

; You should do your best to write your scripts so that they do not require
; register_globals to be on;  Using form variables as globals can easily lead
; to possible security problems, if the code is not very well thought of.
register_globals = Off

ouiat, et???

pour mon probleme comment je doit faire???

Pourrais tu éditer le titre du topic pour ajouter le langage, afin que des gens (comme moi) ne pense pas que tu ai un problème avec un logiciel appelé OS Commerce qui n’aurait rien à voir avec php, donc j’ignore basta?

Merci.

(un petit clic sur http://www.clubic.com/forum/style_images/1/p_edit.gif sur ton message, et yopla!)

j’ai bien un probleme avec OS Commerce car il me met une erreur si tu a lus le topic!!!

dans oscommerce tu as un fichier .htaccess
ouvre le, cherche les lignes, mets les en commentaire avec un # devant chaque ligne
<IfModule mod_php4.c>
php_value session.use_trans_sid 0
php_value register_globals 1
</IfModule>
et copie en dehors de ce bloc IfModule

php_flag register_globals 1
php_value session.use_trans_sid 0

fini

de cette facon oscommerce marchera quelque soit la valeur de registr_globals du php.ini

comme sa?car elles ont deja ete mise!!!et pour la fin c’est comme sa qu’ils fallaients metre les lignes php_flag register_globals 1
php_value session.use_trans_sid 0??

# $Id: .htaccess,v 1.3 2003/06/12 10:53:20 hpdl Exp $
#
# This is used with Apache WebServers
#
# For this to work, you must include the parameter 'Options' to
# the AllowOverride configuration
#
# Example:
#
# <Directory "/usr/local/apache/htdocs">
#   AllowOverride Options
# </Directory>
#
# 'All' with also work. (This configuration is in the
# apache/conf/httpd.conf file)

# The following makes adjustments to the SSL protocol for Internet
# Explorer browsers

<IfModule mod_setenvif.c>
  <IfDefine SSL>
    SetEnvIf User-Agent ".*MSIE.*" \
             nokeepalive ssl-unclean-shutdown \
             downgrade-1.0 force-response-1.0
  </IfDefine>
</IfModule>

# Fix certain PHP values
# (commented out by default to prevent errors occuring on certain
# servers)

#<IfModule mod_php4.c>
#  php_value session.use_trans_sid 0
#  php_value register_globals 1
#</IfModule>
php_flag register_globals 1
php_value session.use_trans_sid 0

personne ne peux m’aider car sa ne marche toujoure pas et sa fait 3 joure que je suis desus

Là n’est pas le problème que tu ai un problème, sinon tu ne le crierai pas sur les toits…

Ce que je te demande c’est de mettre le langage dans le titre du topic, genre

[php] Problème avec OS Commerce

Je ne demande rien d’autre vois tu.

(je suis le modérateur, alors ne t’étonne pas de ma réaction)

a d’accord!!
j’avais comprie qu’il falait que je mets un titre genre “probleme avec le fichier php.ini”!!

desole!!!

Ce n’est pas grave.

non elles sont pas ‘mise’ : un # ds un .htaccess ca signifie que ce qui suit est en commentaire
si ca ne marche pas, c’est que ton httpd.conf doit etre un poil modifié pour accepter de bypasser/ajouter des règles au dossier
Concernant le dossier racine des pages web(c:/www par exemple) cherche AllowOverride, mets y à All au lieu de None(ou autre) et redémarre apache

PS : c’est pas pour dire mais t’avais la réponse dans l’.htaccess :

# This is used with Apache WebServers
#
# For this to work, you must include the parameter 'Options' to
# the AllowOverride configuration
#
# Example:
#
# <Directory "/usr/local/apache/htdocs">
#   AllowOverride Options
# </Directory>