Forum Clubic

[PHP] PHP4 & PHP5 sur Apache 1.3.27 - Problème de fichier "php.ini"

Bonjour à tous :hello:

Je me suis enfin décidé à installer PHP5 sur mon PC pour m’y mettre (j’étais en PHP 4.3.7) avec mon Apache 1.3.27.
Le problème c’est que je voudrais garder PHP4 en même temps que PHP5 (et pouvoir les faire tourner en même temps), j’ai donc opté pour deux instance d’Apache avec PHP en tant que Module.
J’ai scindé en deux mon fichier de config Apache (“httpd.conf”) et tout va bien, je peux faire tourner les deux Apache (et donc les deux versions de PHP) en même temps, le seul problème c’est que PHP4 et PHP5 partagent le même fichier de config “php.ini” (vérifié à l’aide de “phpinfo()”). Initialement, pour PHP4, je le place dans “C:\WINDOWS”, j’ai donc gardé cet endroit pour PHP4 et j’ai mis le “php.ini” de PHP5 dans le dossier d’installation de PHP5.
J’ai lu qu’avec Apache 2.x on pouvait dire où rechercher le php.ini, mais je n’ai pas trouvé pour Apache 1.3.27.

Des idées ?

Apparement je pourrais recompiler PHP5 en rajoutant une directive pour lui dire que le path du php.ini n’est pas C:\WINDOWS mais un autre dossier, mais je trouve que c’est pas terrible terrible comme solution…

Par défaut php regarde dans le dossier courant si je ne m’abuse, et tu peux spécifier ça dans le fichier httpd.conf itout.

http://fr.php.net/manual/fr/configuration…figuration.file ?

J’ai testé pour le répertoire courant : ne marche pas :frowning:
Spécifier dans httpd.conf où chercher le php.ini ne se fait que pour Apache2 :frowning:

Bricomix > Tous ces réglages ne sont pas indépendants de la version de PHP (les variables d’env sont communes) et le dossier du serveur est commun :frowning:

Je vais donc opter pour Apache 2 je crois… :S

Voilà.

C’est pas trop tôt d’ailleurs :wink: