Forum Clubic

[PHP/MySQL] PB easyPHP, MySQL ne démarre plus

bonjour,

voila, easyphp est installé depuis plusieurs semaines sur mon PC, il marchait niquel, mais aujourd’hui mysql ne démarre plus.

j’ai changé mon mot de passe récemment, et ca avait l’air de marcher.
mais aujourd’hui plus rien

je n’ai aucun message d’erreurs.
Dans le panneau de lancement des serveurs ( double clic sur l’icone easyphp dans la barre des taches) mysql est au rouge, dès que je fais redémarrer, il passe au vert puis aussitot au rouge.

Pouvez-vous m’aider ? merci.

[Déplacé] Logiciel Général > Programmation

up

supprime easy php totalement de ta machine et install
amp (apache/mysql/php)

un tutoriel tres simple et efficace pour installer tout cela sans se prendre la tete
tu rempli le formulaire avec tes infos et hop tu n’a plus qu’a recopier
http://giminik.developpez.com/apache/
quand au version tu peut prendre celle que tu veut la procedure est la meme (sauf php 5 ou il faut que modifie ton php.ini pour avoir les commande mysql au lieu de sqllite)

sur ma machine j’ai un apache 2, mysql 4, php4 et un php5 (les deux cohabitent pour debug de certaines fonctions)

apres dans le php.ini a toi de modif selon tes besoins

Ou plus simple, consulte tes logs mySQL. Ca doit se trouver quelque part dans le dossier EasyPHP.

slt,
S-N > le log d’easyphp ne me dit rien de spécial.
“01/03 21:52:54 EasyPHP: Démarrage des serveurs”
Mysql est pourtant bien à l’arrêt, par contre apache tourne normalement.
Y a ptetre d’autres logs, mais je sais pas où ?

sdjinn > merci, je pense que je vais les installer avec le tuto.

(EasyPHP 1.8 est sorti)

Le log de mySQL. On s’en burne d’Easyphp :o

j ai pas trouvé de log de mysql.
chez moi je ne trouve que le log d’esayphp et le log d’apache.
c’est tout.

Dans le dossier data de mysql, ‘truc.err’

oups, ca c’est surement quand j ai voulu faire du ménage avec une table de mysql.

xxx/Easyphp/mysql/data/NomDHoteDuPC.err

[cpp]050302 17:42:57 Fatal error: Can’t open privilege tables: Table ‘mysql.host’ doesn’t exist
050302 17:42:57 Aborting[/cpp]

merci a vous trois

je suis en train de réinstaller mes serveurs et je voudrais que lorsque que je tape un nom de répertoire (www.monsite.com), cela exécute mon index.php

malheureusement dans la config proposé dans le lien plus haut,
ceci n’est pas configuré par défaut.

j ai bien essayé de mettre ces lignes:
[cpp]DirectoryIndex index.html index.html.var index.php index.php3 index.php4[/cpp]
ou encore
[cpp]
DirectoryIndex index.htm
DirectoryIndex index.php
DirectoryIndex index.php3
[/cpp]

sans succes !!!

me manquerai-t-il la “fonction” mod_dir.c ?

voila ce que j’ai dans ma config :

DirectoryIndex index.html index.php index.php2 index.php3 index.php4 index.php5 index.html.var

je n’utlise pas le module

si tu galere je peut t’envoyer mon fichier de config apache epure :slight_smile:
n’oublie pas de recopier les dll (extensions php) dans le repertoire system32 de windows

il faut redemarrer apache apres chaque modif de la config pour que cela soit pris en compte

je suis perplexe, je viens juste de tester avant de répondre au post et ca marche.

merci de ton aide sdijnn

pour info la ligne actuelle dans mon httpd.conf est
[cpp]DirectoryIndex index.html index.html.var index.php index.php3 index.php4[/cpp]

les mysteres de l’informatique :=)

T’as du oublier de sauvegarde/redémarrer, c’est totu

vi, il m’est arrivé la même chose, mysql gère ses droits utilisateurs avec la table ‘mysql’, comme toi un jour j’ai cru qu’elle ne servait à rien et je l’ai viré, du coup, plus de MySQL. :smiley:

WinterOfTheWolf > comme tout maniaque, tout ce que je ne comprends pas ou que je n’utilise pas est aussitôt supprimé. Résultat, j ai une usine à gaz dans ma maison au lieu d’un PC :wink:

Sans-Nom > oui, je pense que c’est l’erreur la plus probable de n’avoir pas sauvegarder avant de relancer apache, cependant je préfère quand meme la réponse de sdijnn.
[cpp]les mysteres de l’informatique :=)[/cpp]
:lol:

d’ailleurs, un nouveau mystère est apparu dans la config de phpmyadmin

j’arrive a me connecter a mysql via la ligne de commande,
par contre il m’est impossible d’acceder à mysql via l’authentification http de phpmyadmin.

voici, qques lignes de mon fichier config.inc.php qui ont été modifiées
[cpp]$cfg[‘PmaAbsoluteUri’] = (!empty($_SERVER[‘HTTPS’]) ? ‘https’ : ‘http’) . ‘://’
. $_SERVER[‘HTTP_HOST’]
. (!empty($_SERVER[‘SERVER_PORT’]) ? ‘:’ . $_SERVER[‘SERVER_PORT’] : ‘’)
. substr($_SERVER[‘PHP_SELF’], 0, strrpos($_SERVER[‘PHP_SELF’], ‘/’)+1);
[/cpp]
et
[cpp]$cfg[‘Servers’][$i][‘auth_type’] = ‘http’; // Authentication method (config, http or cookie based)?[/cpp]

Remarque:
le codage du mot de passe dans la base de données est différent de celui montré dans le tuto:
tuto:
[cpp]1104420466474a75[/cpp]
chez moi ( environ : 40 lettres )
[cpp]*6E418…[/cpp]

j ai essayé avec un utilisateur lambda sans mot de passe et ca marche.
mais dès que je spécifie un password, ca ne parche plus !!!

une idée ?

pour le codage
c’est la version 4 de mysql qui fait cela
c’est dans la table quand tu veut modif c’est l’option PASSWORD qui sert a crypter le pass

pour phpmyadmin dsl je ne peut te dire il y a bien longtemps que je n’utilise plus ce truc pas assez intuitif a mon gout et trop galere a gere

pour ton authentification
c’est probablement ton fichier htaccess qui ne pointe pas sur la bonne direction

40 lettres, c’est probablement du sha1 :slight_smile: