Forum Clubic

Petit soucis RSS

Bonjour,
Il y a un problème au niveau des fils rss, ils ne peuvent pas être lu par internet explorer. Le problème se situerais au niveau de l’entête content-type : IE n’aimerais pas les espaces après charset=. Se serait possible de corriger ca?

De quelle version de IE s’agit-il ?

NB : L’entête est : “Content-Type:text/xml;charset=iso-8859-1;”

WiP :nico:

La dernière en date, suffit d’ouvrir un des liens rss dans IE pour avoir l’erreur suivante:

Certains lecteur RSS utilisent le moteur xml de IE alors ils ont le même problème. Se pourrait-il que IE soit vraiment idiot et que ce soit le ; à la fin qui pose problème ? Quelqu’un avait le même problème avec “Content-Type: application/xml; charset= iso-8859-1”, puis ca a marché en enlevant l’espace.

Bizarre. Je viens de tester avec IE6 et je ne vois pas d’erreur particulière …
Peut être est-ce une version non européenne de IE (qui aurait du mal avec le jeu de caractères iso-8859-1) ?

WiP :nico:

Bah non, c’est un windows WXPSP2 bien francais avec un IE6 bien francais. Et j’ai pas de problèmes avec les flux d’autres sites. J’ai essayé sur un autre ordi, avec WXPSP2 aussi, et même résultat. :neutre:

Nous avons effectué quelques modifs. Est-ce que cela fonctionne mieux à présent ?

WiP :nico:

Parfait ! :super: Merci.

Heu par contre ca ressemble plus a du RSS2 qu’a du RSS 0.91 alors ca valide pas trop avec le dtd donné.

Un DTD qui correspondrait pas ? Mais non voyons :wink:

NB : Merci pour l’info …

WiP :nico: