Forum Clubic

Petit soucis avec le PATH et un package

urpmi est TB en général, du moins tant qu’on compile pas à tout va.
G justement compilé wxWidget (alias wxBase & wxGTK) ce WE.

Là je dois mettre à jour mkvtoolnix (outils Matroska), que j’ai “rebuildé” tout à l’heure, mais il ne trouve pas : [fixed]# ‘urpmi mkvtoolnix’
Certains paquetages demandés ne peuvent pas être installés :
mkvtoolnix-1.4.1-1mdk.athlon (car libwx_base-2.5.so.5 est non satisfait)
Continuer ? (O/n) o[/fixed]
Bon, il est bien là (sinon amule marcherait comment?) : [fixed]# ‘locate libwx_base-2.5.so.5’
/usr/lib/libwx_base-2.5.so.5[/fixed]
Donc je tape ‘PATH=/usr/lib=$PATH’ et vérifie /etc/ld.so.conf : c bien là, suivi de ‘ldconfig’
mais urpmi me répète que “libwx_base-2.5.so.5 est non satisfait”

Pliz keske g oublié :??:

Sans Matroska je vais m’ennuyer :sweat:

Avant que je crée les symlinks, svp comment j’ajoute définitivement un chemin au $PATH ?
‘/usr/lib’ est ds /etc/ld.so.conf, mais pas dans le $PATH :heink:

urpmi --allow-force mkvtoolnix

locate [chaque] :

ajoute --allow-nodeps

(j’vous dis qu’on va bien y arriver à lui casser son système si on s’y met tous)

nan, les polices sont un tantinet aliasées mais ça marche
g muxé 2 films & sous-titres --> résultat nickel :slight_smile:

J’crois que t’aurais dû installer wxWigdet cia urpmi au lieu de compiler…

vi, vais voir ça sur la durée…
Là je voulais essayer amule-cvs, et il me fallait la dernière version de wxWidget pour le compiler.

C’est plus propre de faire les installations via la commande dédiée à la gestion des paquets (apt-get, rpm, emerge… suivant la distro).

Chez moi, quand je veux mettre un programme de test que je compile moi même, je le mets dans son propre répertoire, par exemple, dans ton cas, je l’aurais mis dans :
/opt/test/amule-cvs

avec toutes ses dépendances (en général, ./configure --prefix=/opt/test/mon_prog) sachant que /opt/test est accessible en lecture écriture pour l’utilisateur standard ce qui me permet de faire un “make install” sans passer en root (évite que des fichiers n’aillent où il ne faut pas sans crier gare). Pour virer le programme, j’ai juste à supprimer le répertoire d’installation.

http://c.laloy.free.fr/images/smileys/yaisse.gif ‘./configure --prefix=/opt/test/lib/librairie_pour_mon_prog’ puis un truc dans le genre :
‘./configure --prefix=/opt/test/ --with wx_base=/opt/test/lib/librairie_pour_mon_prog’

Même pas besoin de s’embêter avec le PATH dans ce cas.

en gros g compris ?

ps : matte donc cette page > 10: Logiciels : “Tester un programme”

:smiley:

j’essaye :

likairui -> pour resoudre definitvement ton probleme : rm -Rf /

OK http://c.laloy.free.fr/images/smileys/dog1.gif

bon j’ai fait un rm -Rf / mais ça marche plus & je crois que je vais tuer KP2 http://c.laloy.free.fr/images/smileys/biggygirl.gif

Nan je plaisante (sauf que j’ai bel et bien ni**é la table de partitions de mon disque, c t marrant… grâce à Knoppix-kaella)

Donc j’ai créé les directories /bin, /etc & /lib, tout ça dans /opt
Quand je veux installer une big “librairie” (genre une version antérieure de Python) je lance ./configure --with-prefix=/opt

Ça marche pour le moment (g pas encore eu de message d’injures :slight_smile: )

reprenez moi si je me trompe mais le $PATH sert juste pour les executables, dans le cas des libraries c’est bien /etc/ld.so.conf qu’il faut editer
sinon pour amule c’est un probleme recurrent, la plupart des distros fournissent la version stable de wxgtk (2.4) alors qu’amule dans sa mouture 2.x ne se comporte correctement qu’a partir de la 2.5 (enfin 2.4 ça crashe souvent)

En tous cas ça fonctionne + généralement (python + zope dans mon cas) avec --prefix=/$DIRECTORY après avoir créé les $DIRECTORY/bin/ & ~/etc & ~/lib (make install crée même les directories manquantes genre ~/include)

Me reste à inclure à python ce %$*§ prob de zlib library module :fou: