Forum Clubic

Pb suite à installation Mandrake

Salut,

Je viens d’installer la Mandrake 10.1 mais le double-boot avec Windows n’a pas fonctionné. Lilo me propose Linux/Linux-conf/Failsafe/Windows/Windows1, mais aucunes des 2 entrées Windows ne me permet de booter.

La première m’affiche quelques caractères de couleurs éparpillés sur fond noir (voir des symboles comme des coeurs) et la seconde fait apparaitre une curseur qui clignote indéfiniment.

Cela ne serait pas si important que ca si les données que j’ai stockées sur mon DD externe étaient utilisables. Le pb, c’est que lorsque je tente d’accéder à ce DD (connecté en Firewire) et formatté en NTFS à partir de l’icone qui s’ajoute sur le bureau, j’ai le message suivant :

[fixed]mount: type de sys. de fichiers erroné, option erronée, superbloc erroné sur /dev/sdc1 ou trop de système de fichiers montés. Please check that the disk is entered correctly[/fixed]

Donc plus d’OS ni de données [:austindangerpowers]

(c’est maintenant que je crie o-secours ? [:matleflou] )

Donne :

1/ mount
2/ cat /etc/lilo/lilo.conf (fait un slocate pour localiser lilo.conf, car, bon, ça fait très longtemps que je suis passé à Grub :p).

NB : il y a une FAQ Mandrake à lire aussi (pour info ;)).

pour lilo, c’est cat /etc/lilo.conf :stuck_out_tongue:

C’est ce que je disais :stuck_out_tongue: ;).

:oui: J’ai déjà lu la FAQ

mount
[fixed]/dev/hda5 on / type ext3 (rw)
none on /proc type proc (rw)
none on /proc/bus/usb type usbfs (rw)
none on /sys type sysfs (rw)
/dev/hda7 on /home type ext3 (rw)
/dev/hda1 on /mnt/win_c type ntfs (ro,umask=0,nls=iso8859-15)
/dev/hda2 on /mnt/win_d type ntfs (ro,umask=0,nls=iso8859-15)[/fixed]

Sachant qu’en plus de mon dd externe, j’ai 2 partitions en ntfs

cat /etc/lilo.conf
[fixed]# File generated by DrakX/drakboot

WARNING: do not forget to run lilo after modifying this file

default=“linux”
boot=/dev/hda
map=/boot/map
keytable=/boot/fr-latin1.klt
prompt
nowarn
timeout=100
message=/boot/message
menu-scheme=wb:bw:wb:bw
image=/boot/vmlinuz
label=“linux”
root=/dev/hda5
initrd=/boot/initrd.img
append=“acpi=ht resume=/dev/hda6 splash=silent”
vga=788
read-only
image=/boot/vmlinuz
label=“linux-nonfb”
root=/dev/hda5
initrd=/boot/initrd.img
append=“acpi=ht resume=/dev/hda6”
read-only
image=/boot/vmlinuz
label=“failsafe”
root=/dev/hda5
initrd=/boot/initrd.img
append=“failsafe acpi=ht resume=/dev/hda6”
read-only
other=/dev/hda1
label=“windows”
table=/dev/hda
other=/dev/hda2
label=“windows1”
table=/dev/hda[/fixed]

C’est grave docteur ? :sweat:

passe ton disque en LBA, y a des fois ça marche pour booter windows je crois (a regler dans le bios)

Merci :super:

en passant mon disque dur interne en LBA, j’ai pu booter sur l’entrée de lilo windows1 (l’entrée windows me renvoi NTLDR manquant)

Et pour mon DD externe (si je peux abuser de vos connaissances :D)

il te fait la même erreur si tu tentes de le monter manuellement dans une console (en root) ?

mount -t ntfs /dev/sdc1 /le_dossier_que_tu_veux

Petit compte rendu de mes investigations :

J’ai créé un dossier /mnt/sdc1 (mkdir /mnt/sdc1), puis saisi en tant que root la commande :
[fixed]mount -t ntfs /dev/sdc1 /mnt/sdc1/[/fixed]

En tant que root (en ligne de commande), je peux parcourir le contenu de mon DD externe, mais pas créer de répertoire dessus par ex.

En tant qu’utilisateur, je n’ai plus de message d’erreur lorsque je clique sur l’icone de mon DD sur le bureau, mais rien ne s’affiche.

Si ca peux aider :
[fixed] 1280 dr-xr-xr-x 1 root root 4720 aoû 25 2003 cdrom/
555973 drwxr-xr-x 2 root root 4096 mar 8 16:01 cdrom2/
555994 drwxr-xr-x 2 root root 4096 mar 8 15:19 hd/
5 dr-x------ 1 root root 12288 mar 8 12:26 sdc1/
5 dr-xr-xr-x 1 root root 4096 mar 8 12:45 win_c/
5 dr-xr-xr-x 1 root root 24576 mar 8 17:18 win_d/[/fixed]
Mais impossible de changer les autorisations sur sdc1 :
[fixed][root@localhost mnt]# chmod u+w sdc1
chmod: modification des permissions de `sdc1’: Read-only file system[/fixed]

Si ca vous parle plus qu’à moi :slight_smile:

En même temps, modifier des permissions sur une partition NFTS ;), tu aurais formaté en reiserfs ou ext3, il n’y aurait pas de souci ;).

Sinon, tu peux prendre FAT32, ça ne gère pas les permissions :D.

Le truc c’est que ce disque dur externe contient des données dont je me sert aussi bien depuis Mandrake que Windows.

Si le DD reste en ntfs, je ne pourrais rien en faire ? Si je passe en fat32 c’est mieux ??

J’ ai un probleme aussi de disque externe, usb, (en fait un jukebox) avec lequel il faut que je soit root pour mettre un fichier dessus (pas moyen de changer les permissions ou l’utilisateur). idem pour mon appareil photo.

D’après ce topic la solution serait d’utiliser le FileSystem Fat32

Il n’y a pas d’autres solutions ?

ça n’empeche pas les problemes d’écriture, puisque mon jukebox est en fat 32 (je ne sais pas pour les carte de mon appareil)

sidney_v :l’écriture sur le format ntfs est encore expérimentail, si tu peux écrire sur DD externe passe le ou une partie en fat32

robert_b : as-u essayé de passer ces paramètres la sur ta partition dans /etc/fstab
[fixed]/dev/hda1 /mnt/win vfat defaults,rw,user,uid=1000,gid=1000,umask=022 0 0[/fixed]
(à adapter avec l’uid et gid de ton user, commande “id” pour savoir ces infos)
et vérifie que le dossier ou est monté la partition appartient bien à ton utilisateur et pas au root

en fait le truc c’est que avec la mandrake le disc est monté automatiquement sur mon bureau et le dossier créé juste à cet instant. Mais je garde la ligne sous la main et vais faire de tests. Merci bien.

ne jamais essayer d’écrire sur une partoche NTFS malheureux (enfin si vous avez des données que vous voulez pas perdre) ! :stuck_out_tongue:

robert_b -> dans les options de montage, “user” permet de monter en tant qu’utilisateur simple mais pour monter et démonter il faut mettre “users” :wink: je sais pas du tout pourquoi :smiley:

Chose normal, je viens vous informé que toutes vos informations m’ont permis de faire fonctionner mon DD externe en lecture/ecriture depuis Linux ou Windows.

Donc pour ceux que ca intéresse, j’ai formatté en FAT32 depuis la Mandrake puis assigné un point de montage (/mnt/windows) et mis à jour mon etc/fstab (proposé automatiquement)

Je note au passage la phrase “vous devez utiliser un vrai système de fichier” lorsque j’essaye formatter la partoche en FAT32 et de la monter ailleurs que dans /mnt :lol:

Du coup, il suffit que le DD soit sous tension au démarrage de Linux pour que le DD soit bien monté. C’est pas possible de gérer le hotplug ?? (je sais je pousse mais ca serait bien pratique :smiley: )

Merci à vous les gars :jap:

Normalement, Linux gère le hotplug… Chez moi, je branche mon disque et mon graveur DVD externe de cette manière… Ca me crée automatiquement les entrées dans /etc/fstab et ça me rajoute les icônes sur le bureau KDE (Gentoo inside + KDE 3.4.0 + hal/dbus)

J’ai même viré un disque interne IDE (sur un PC classique) une fois sans perte de données (j’ai pas essayé de le remettre). Essaye ça sous Wiwi :wink:

bon en fait le probleme c’est que ce disque est monté automatiquement, et lorsque cela se produit, la ligne dans le fstab est :

/dev/sdb1 /mnt/removable auto umask=0,user,iocharset=iso8859-15,sync,kudzu,codepage=850,noauto,exec,users 0 0

et comme je ne connais pas comment modifier ce paramaetrage automatique.