Forum Clubic

Pb réseau 2PC 1 cable croisé RJ45 connection impossible

Bonjour à tous,

Je sollicite votre aide sur une histoire de fou …
J’ai 2 PC sous Mandriva 2007Spring, l’un est installé avec une distribution FREE ONE 2007Spring KDE, et l’autre est une version FREE DVD 2007spring KDE.

Je voulais recopier un gros fichier 3,4Go d’un PC vers l’autre, je me suis dis facile ça va aller vite avec un câble croisé RJ45.

Je précise que le câble à été vérifié et est en bon état.

en root sur le 1er PC :

ifconfig eth0 10.10.10.1 netmask 255.255.255.0 up
ethtool eth0 autoneg on

en root sur le 2ème PC :

ifconfig eth0 10.10.10.2 netmask 255.255.255.0 up
ethtool eth0 autoneg on

Je coupe le firewall dans drakconf.real sur les 2 pc.

J’essai de ping les ips les destinations sont : « Destination Host Unreachable »

J’essai de ping les ips de broadcast les destinations sont : « Destination Host Unreachable ».

Un ethtool me renseigne que les ligne sont vu en down, pourtant j’ai fait un ifconfig eth0 up.

Je retest mon cable d’un PC vers ma freebox, ethtool me renseigne que la ligne est bien UP, dc le cable est OK.

Moult et moult essai, + ajout de route + test en autoneg off speed 100 duplex full etc etc, rien n’y fait les link sont down.

Les PC n’arrivent pas à ce voir, je n’y comprend plus rien.

Je n’ai jamais eu ce pb, même sur solaris au taf, je craque HELP ME please.

Y a forcement un troc que j’oublie ou qlq chose comme ça.

@+Will

Tu es sur que pour se connecter à une freebox c’est un cable croisé qui est utilisé?
Moi je dirai plutot que c’est un cable droit, comme quand on se connecte à un routeur ou switch.

La freebox est cool elle gère automatiquement et aussi bien les câbles droits et croisés.
La connection à la freebox est juste là pour tester le câble, sinon les 2 PC sont reliés directement via mon câble croisé.

@+Will

Ba alors pas d’idée ?

Help me please …

Non pas d’autres idées, mais il y a un topic assez similaire la : www.clubic.com…

oui il avait juste un petit problème de routage + peu etre firewall avec les requettes icmp.

Franchement je sais pas, mais en regardant la doc de ethtool je vois ca :

autoneg on|off
Specify if autonegotiation is enabled. In the usual case it is,
but might cause some problems with some network devices, so you
can turn it off.

Ca se trouve ca pose probleme. Va savoir :wink:

Déjà essayer les 2 modes, j’ai l’impression que la carte n’envoie rien car la ligne est flagué en down, c’est logique puisque un câble est un élément passif et comme mes 2 cartes se trouvent dans le même état … si j’avais un élément actif entre les 2 ce serais ok, la preuve, dès que je branche sur la freebox qui est un élément actif la line est up. Masi je n’ai pas de hub et je n’ai pas l’intension d’en acheter 1. Il doit bien y avoir un moyen de paramétrer la ligne pour quel envoie un signal même sans ligne.

a mon avis, ta fait trop de manips…
1erement, a moins d’avoir un besoin specifique a ce niveau, on ne touche jamais l’autonegociation…
2ement, c’est pas une bonne idee de faire des trucs sur la conf reseau dans mandriva sans passer par les outils graphiques ou les commandes mandriva (c’est en partie pour ca que j’aime pas trop mandriva)
3ement, si ton lien est down entre les 2 machines et pas avec ta freebox alors une des 2 machines a probablement un prob materiel au niveau de la carte…
4ement, je suis etonne que tu ne fasses pas un bete ifconfig pour voir si ta conf est bien prise en compte au niveau OS
5ement, t’as qu’une seule carte reseau sur tes machines ? c’est couillon des fois de se planter de port… :ane:
6ement, tu peux normalement utiliser ta freebox comme switch… elle a au moins 2 ou 3 ports si je me souviens bien…
7ement… ah bon… j’ai plus rien a dire :smiley: