Forum Clubic

Pb mandriva 2008 et samsung 206BW

bonjour
je suis sous mandriva 2008 et lors de l’installation mon samsung 206BW est reconnu comme écran pnp (samsung)
Malheureusement lorsque j’effectue un test de la résolution, un carré apparaît indiquant “Mode non optimal, Mode conseillé 1680 1050, 60hz”
La seul manière d’enlever ce carré est de choisir un écran par défaut en 1024*768.
malheureusement je n’est pas trouvé de driver linux sur le site samsung
quelqu’un aurait il une solution ?
merci.

Salut,

Tu as essayé d’indiquer le modèle exact de ton moniteur dans le Centre de Contrôle Mandriva -> Matériel -> Configurer le serveur graphique ?

S’il n’est pas dans la liste, tu peut essayer de rajouter les entrées HorizSync 30.0 - 81.0 et VertRefresh 56.0 - 75.0 à la section “Monitor” de ton fichier /etc/X11/xorg.conf (ou modifier si ces entrées existent déja).
Ca devrait donner cela :

Section “Monitor”
Identifier “Monitor0”
ModelName “écran pnp”
HorizSync 30.0 - 81.0
VertRefresh 56.0 - 75.0
EndSection

PS : j’ai pris les valeurs 30.0 - 81.0 et 56.0 - 75.0 par apport au manuel en ligne du 206BW, à confirmer en regardant dans ton manuel.

merci pour cette solution, j’ai réussit a monter un peu en résolution 1280x960, mais je n’arrive toujours pas a monter en 1680x1050 même message.
Peut être que cela vient de ma carte graphique qui ne peut pas afficher ces résolutions ( ati 9200)

Tu peux poster le contenu de /etc/X11/xorg.conf ?

voici mon xorg.conf, et merci pour ton aide

File generated by XFdrake (rev 230776)

Section “Extensions”
Option “Composite”
EndSection

**********************************************************************

Refer to the xorg.conf man page for details about the format of

this file.

**********************************************************************

Section “ServerFlags”
#DontZap # disable (server abort)
#DontZoom # disable <KP_+>/<KP_-> (resolution switching)
AllowMouseOpenFail # allows the server to start up even if the mouse does not work
EndSection

Section “Module”
Load “dbe” # Double-Buffering Extension
Load “v4l” # Video for Linux
Load “extmod”
Load “type1”
Load “freetype”
Load “glx” # 3D layer
Load “dri” # direct rendering
EndSection

Section “InputDevice”
Identifier “Keyboard1”
Driver “kbd”
Option “XkbModel” “pc105”
Option “XkbLayout” “fr”
Option “XkbOptions” “compose:rwin”
EndSection

Section “InputDevice”
Identifier “Mouse1”
Driver “mouse”
Option “Protocol” “ExplorerPS/2”
Option “Device” “/dev/mouse”
EndSection

Section “InputDevice”
Identifier “Mouse2”
Driver “evdev”
Option “bustype” “0x0003”
Option “relBits” “+0+1+2”
Option “product” “0xc041”
Option “vendor” “0x046d”
Option “HWheelRelativeAxisButtons” “7 6”
EndSection

Section “Monitor”
Identifier “monitor1”
HorizSync 30.0-81.0
VertRefresh 56-75

# Monitor preferred modeline (59.9 Hz vsync, 64.7 kHz hsync, ratio 16/10)
ModeLine "1680x1050" 119 1680 1728 1760 1840 1050 1053 1059 1080 -hsync +vsync

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576"     50.00  768  832  846 1000   576  590  595  630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576"     63.07  768  800  960 1024   576  578  590  616

EndSection

Section “Device”
Identifier “device1”
VendorName “ATI Technologies Inc”
BoardName “ATI Radeon 9250 and earlier”
Driver “ati”
Option “DPMS”
Option “XaaNoOffscreenPixmaps” “1”
EndSection

Section “Screen”
Identifier “screen1”
Device “device1”
Monitor “monitor1”
DefaultColorDepth 24

Subsection "Display"
    Depth 8
    Modes "1280x960" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubsection

Subsection "Display"
    Depth 15
    Modes "1280x960" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubsection

Subsection "Display"
    Depth 16
    Modes "1280x960" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubsection

Subsection "Display"
    Depth 24
    Modes "1280x960" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubsection

EndSection

Section “ServerLayout”
Identifier “layout1”
InputDevice “Keyboard1” “CoreKeyboard”
InputDevice “Mouse1” “CorePointer”
InputDevice “Mouse2” “SendCoreEvents”
Screen “screen1”
EndSection
Edité le 04/03/2008 à 09:02

Salut,

Essaie de rajouter dans les subsections display à la fin du xorg.conf “1680x1050” :

Subsection "Display"
Depth 8
Modes "1680x1050" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubsection

Subsection "Display"
Depth 15
Modes "1680x1050" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubsection

Subsection "Display"
Depth 16
Modes "1680x1050" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubsection

Subsection "Display"
Depth 24
Modes "1680x1050" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubsection
EndSection 

bonjour
j’ai effectuer la modification et cela ne fonctionne toujours pas, j’ai encore le message “Mode non optimal, Mode conseillé 1680 1050, 60hz”
est il possible de forcer la fréquence a 60hz ?
Etant sur mandriva 2008 free j’ai les drivers ati installés par défaut, es ce qu’en installant les drivers ati propriétaires cela pourrait résoudre mon problème ?
Edité le 09/03/2008 à 13:45