Forum Clubic

Pb installation programme - message d'erreur

Bonjour, j’ai un probleme, lorsque je veux installer un logiciel, il demarre le processus puis il me met un message d’erreur “lecteur h: invalide”.
Cela me le fait sur plusieurs programmes téléchargé dont un sur clubic. :??:

Est-ce que tu as/avais un lecteur à cette lettre ?

Si tu fais
set
à l’invite de commandes, ça donne quoi ?

non pas de lecteur justement.
Faire set comment? je ne connais pas.

Démarrer -> Exécuter -> cmd -> OK et là tu tapes
set

ok et apres une fois que j’ai fait ça qu’est ce que je dois voir?

Ma question était : ça donne quoi ?

ça me donne une fenetre dos avec des infos dedans mais je ne sais pas les interpretées.

Ben justement, je voulais connaître ces infos-là.

ça donne:
Microsoft Windows XP [version 5.1.2600]
© Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Carbendi>set
ALLUSERSPROFILE=C:\Documents and Settings\All Users
APPDATA=C:\Documents and Settings\Carbendi\Application Data
CLIENTNAME=Console
CommonProgramFiles=C:\Program Files\Fichiers communs
COMPUTERNAME=PATISA
ComSpec=C:\WINDOWS\system32\cmd.exe
DEFAULT_CA_NR=CA6
FP_NO_HOST_CHECK=NO
HOMEDRIVE=C:
HOMEPATH=\Documents and Settings\Carbendi
LOGONSERVER=\\PATISA
NUMBER_OF_PROCESSORS=2
OS=Windows_NT
Path=C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\Program Files\AT
I Technologies\ATI Control Panel;C:\Program Files\Fichiers communs\Teleca Shared
;C:\Program Files\Fichiers communs\GTK\2.0\bin
PATHEXT=.COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH
PROCESSOR_ARCHITECTURE=x86
PROCESSOR_IDENTIFIER=x86 Family 15 Model 3 Stepping 3, GenuineIntel
PROCESSOR_LEVEL=15
PROCESSOR_REVISION=0303
ProgramFiles=C:\Program Files
PROMPT=$P$G
SESSIONNAME=Console
SystemDrive=C:
SystemRoot=C:\WINDOWS
TEMP=C:\DOCUME~1\Carbendi\LOCALS~1\Temp
TMP=C:\DOCUME~1\Carbendi\LOCALS~1\Temp
USERDOMAIN=PATISA
USERNAME=Carbendi
USERPROFILE=C:\Documents and Settings\Carbendi
windir=C:\WINDOWS

C:\Documents and Settings\Carbendi>

oki, les variables sont correctes.

Faisons un test : toujours à l’invite de commandes :

subst H: C:\

puis relancer l’installation. Est-ce que ça passe ? Sinon, un nouveau message d’erreur ou le même ?

oui ça passe!
Qu’est ce que ça signifie? :clap:

Ca signifie une tricherie :smiley: Pour une raison obscure, ces programmes exigent l’existence du lecteur H. Alors, la commande indiquée monte le lecteur C en tant que H, c’est-à-dire que tu vas avoir deux lecteurs identiques C et H, et qu’une modification sur l’un est effectuée également sur l’autre puisqu’ils ne sont en fait qu’un :wink:

L’idée était de fournir le lecteur manquant :wink:

Pour supprimer/démonter ce lecteur H de trop, une fois l’installation effectuée ou quand tu en auras marre ;), fais à l’invite de commandes :

subst H: /d