Forum Clubic

Pb EXCEL :Double recherche

Bonjour,

J’aimerai faire une double rechercher sous EXCEL :
en gros : j’ai un fichier qui contient 2 feuilles
ce que je voudrai : sur la feuille 2 : Si sur la feuille 1, jai une ligne avec colonne A = X et colonne B= Y alors affichier sur ma feuille 2 la valeur de la colonne C correspondant

X et Y correspondent à des valeurs contenu sur ma feuille 2

Merci de votre aide.

Alexandre
Edité le 18/07/2009 à 17:19

Bonjour tthhee29,
Je suis parvenu à ton résultat avec cette formule :
=SI(A5<>Feuil1!A17;0; SI( Feuil1!B17 <> B5;0;Feuil1!C17))
Si quelque chose te manque, demandes moi j’essaierais de t’expliquer la méthode… :slight_smile:

Merci NanoSpirit d’avoit pris le temps de me répondre.

C’est tout à fait ce que je veux faire, sauf que ma recherche comparative se fait sur une liste de valeur et non pas deux champs. Tu vois ce que je veux dire ?
En gros :

c’est pas Feuil1!A17 mais toute la colone A de la Feuille 1

Alex

s’il n’y a qu’une seule ligne qui vérifie la condition, tu dois pouvoir faire avec SOMMEPROD()
Après, tout dépend si ta colonne C contient des nombres ou des valeurs littérales
Edité le 18/07/2009 à 20:43

En effet, je m’e suis tiré avec SOMMEPROD() :=)

Merci !