Forum Clubic

Pb ecriture disque externe - j'ai pas les droits

Bon alors là j’ai vraiment honte, mais j’avoue secher quand meme… :ane:
Voilà, j’ai acheté un gros disque externe, il était au départ en VFAT, après un fdisk, et un mkfs en ext3, je me suis dit, je vais le monter, impec’!!! il se monte, mais impossible d’écrire quoi que ce soit si je ne suis pas root… il me dit dans la console que je n’ai pas les droits pour écrire…

Un petit tour dans les fichiers qui vont bien, le fstab:
/dev/sda1 /media/cle_usb auto defaults,rw,user,noauto 0 0

bon, je me dis ça colle… comprends toujours pas… je vais voir par acquis de conscience les fichiers /dev/sda* et là surprise…
brw-r----- 1 root hal 8, 0 2005-09-05 13:25 sda
brw-r----- 1 root hal 8, 1 2005-09-05 13:25 sda1
en comparaison de…
brw-rw---- 1 root disk 3, 0 2005-09-05 15:22 hda
brw-rw---- 1 root disk 3, 1 2005-09-05 15:22 hda1
brw-rw---- 1 root disk 3, 2 2005-09-05 15:22 hda2
brw-rw---- 1 root disk 3, 5 2005-09-05 15:22 hda5
brw-rw---- 1 root disk 3, 6 2005-09-05 15:22 hda6
J’ai pas la possibilité d’écrire sur sda…
De maniere un peu folle, je me suis dis, passons les droits en 760… mais la meme erreur reste…
je trouve pas, et ça m’ennuie beaucoup car ce disque est pour un gros backup…
Si qqn a une idée, et sans m’incendier SVP! :wink:

rajoute dans le ftab aprés noauto : ,umask=000 et remonte ton dur pour voir

chose faite, et nouvelles peu réjouissantes…

mount: wrong fs type, bad option, bad superblock on /dev/sda1,
missing codepage or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

Mais faut dire aussi qu’il a du mal avec cette option… visiblement
dmesg |tail… nous donne:

EXT3-fs: Unrecognized mount option "umask=000" or missing value

Il me fallait avoir ça au final c’est bien ça?

/dev/sda1 /media/cle_usb auto defaults,rw,user,noauto,umask=000 0 0

dans le mtab on peut lire, une fois monté (mais que simplement root a les droits en écriture)
/dev/sda1 /media/cle_usb ext3 rw,noexec,nosuid,nodev,user=sebastien 0 0
j’ai pourtant bien semble-t-il un’rw’… :heink: je dis une imbécilité?

chmod 777 /media/cle_usb auto

Est-ce qu’il change les permissions ?

Sinon umask=0 ne fonctionne pas pour l’ext3

Alors quand je passe en chmod 777 pour cle_usb, je peux écrire en tant que non root. J’ai donc baissé de niveau pour savoir où se passait le pb, et une fois passé en chmod 771, j’ai donc ça :
drwxrwxr-x 5 root root 4096 2005-09-05 14:40 cle_usb
après, j’ai essayé de copier mes fichiers… mais en fait le rep créé a le chmod 755 ce qui m’empeche d’écrire dedans… je ne poursuis pas ces chmod en cascade, car je pense avoir oublié de faire qqch mais quoi… :??:
je ne peux plus écrire, est-ce à dire que je suis considéré comme faisant partie des ‘autres’?

PS: e.nounours… c’est quoi le auto à côté de cle_usb?

Rien, un mauvais copier/coller

Ton user fait-il parti du groupe usb ?

Sinon met le en 766 ou 666 et roule.

j’ai listé tous mes groupes, et je ne vois pas à priori de groupes USB…

root:x:0:
daemon:x:1:
bin:x:2:
sys:x:3:
adm:x:4:
tty:x:5:
disk:x:6:
lp:x:7:
mail:x:8:
news:x:9:
uucp:x:10:
man:x:12:
proxy:x:13:
kmem:x:15:
dialout:x:20:sebastien,nathan
fax:x:21:
voice:x:22:
cdrom:x:24:sebastien,hal,nathan
floppy:x:25:sebastien,hal,nathan
tape:x:26:
sudo:x:27:
audio:x:29:sebastien,nathan
dip:x:30:
www-data:x:33:
backup:x:34:
operator:x:37:
list:x:38:
irc:x:39:
src:x:40:
gnats:x:41:
shadow:x:42:
utmp:x:43:
video:x:44:sebastien,nathan
sasl:x:45:
staff:x:50:
games:x:60:
users:x:100:
nogroup:x:65534:
crontab:x:101:
Debian-exim:x:102:
sebastien:x:1000:
plugdev:*:46:
messagebus:x:103:
ssh:x:104:
gdm:x:105:
hal:x:106:
saned:x:107:
camera:x:108:
scanner:x:109:sebastien,nathan
dirmngr:x:110:
nathan:x:1001:

Mais ce que je trouve étrange dans cette affaire est qie à priori, mon disque dur fonctionne de la meme façon que ma clé USB, et pourtant il ne suffit pas de brancher… pourquoi?

Moi j’en ai un mais je n’utilise pas hal. Essaye en t’y mettant.

Tu peux aussi essayer en mettant users dans le fstab (au lieu de user)
et tu listes les utilisateurs dans le groupe users.