Forum Clubic

Pb disque dur externe mal reconnu

salut !
j’ai un problème avec mon disque dur externe
quand je le branche sur mon ordinateur portable ( Dell Inspiron 8600c, xp pro sp2 ), il le reconnait, je peux aller dans les partitions et y faire ce que je veux sauf que quelques minutes après, il se “déconnecte” et j’obtiens ce message :
www.flickr.com…
quelqu’un a la solution à ce problème ?
j’ai mis à jour les driver du controleur USB mais ça ne change rien

il fonctionne très bien sur mon autre ordi avec windows xp sp2 familiale

caractéristiques du disque dur :
Maxtor, 160 Go, 8 Mo cache, 7200 trs/min, 3,5 pouces dans boitier en alu, alimenté sur secteur
connection par USB 2.0, il possède 3 partitions

vista est un peu suceptible avec les périphériques usb, parfois il me demande de réparer ma clé usb sans raison…

as tu essayé de faire un scandisk de ton disque externe?
avec quel logiciel as tu partitionné ton disque dur externe?
ton controleur usb a peut être des soucis l’a tu testé avec un autre périphérique? est t’il déconnecté ?
Edité le 02/01/2008 à 21:14

je vais essayer de faire un scan disque ok
mon contrôleur usb à l’air de bien marcher puisque ma souris (filaire) fonctionne parfaitement et mes clé usb aussi !!
je l’ai partitionner avec partition magic 8 mais quand j’ai voulu fusionner 2 partitions, il a planté et ne voulait plus travailler dessus
je n’ai pas partitionner le disque avec mon pc portable mais avec mon autre ordi, sur lequel il marche !!

je ne sais pas si ton problème est ou découle de celui-ci:
blogs.codes-sources.com… mais ça coute rien de lire l’article

:fou: perso je n’aime pas partition magique ça n’a de magique que de vider son porte monnaie :MDR

pourquoi n’as tu pas partitionné ton disque via le gestionnaire de disque de xp ou vista ?

autre ordi avec xp pas vista donc on ne peut pas savoir d’ou viendrait le problème ni comparer les situations qui sont différentes
Edité le 02/01/2008 à 21:15

je ne sais pas me servir du gestionnaire de partition de windos, d’ailleur je ne savais même pas qu’il existait !!
j’ai fais un scan disk, tout à l’air de marcher, je l’ai fait sur l’ordi sur lequel il fonctionne bien


peut être en essayant de désinstaller le pilote et de réessayer le le réinstaller ?
a oui mais j'oubliais, comment je fais pour le désinstaller vu qu'il ne veut pas le reconnaitre plus de quelques minutes, voir moins, maintenant, c'est quasiment juste après l'avoir reconnecté!! j'avais oublié de signaler qu'il faut que je l'éteigne et le rallume pour que xp lle reconnaisse ensuite, le reconnecter alors qu'on l'a déjà connecter une fois en restant allumé ne fait rien

sous xp:
clic droit sur poste de travail, puis gérer
dans stockage: gestions des disques
et là tu peux formater, partionner…

si tu n’as rien sur ton disque ou que tu peux refaire les partitions essais, partitions en ntfs avec un formatage rapide suffira au moins on saura si ça vient du partitionnement de truc magique ou pas ou que de vista

la seule façon de bien débrancher un périphérique usb c’est de faire clic droit et éjecter ou dans l’icone en bas a droite sur ce qui ressemble a un port usb avec une flèche verte faire retirer le périphérique en toute sécurité et attendre qu’il te dise de le retirer
Edité le 02/01/2008 à 21:42

j’ai windows xp sous mes 2 ordis
euh c’est mon HDD de sauvegarde …
ok merci pour le gestionnaire de formatage
j’utilise toujours l’utilitaire en bas à droite pour enlever mon disque avec sécurité
sinon j’ai vu dans ses propriétés qu’on était pas obligé de la faire vu que la mémoire tampon est désactivée

c’est peut être du justement au fait que la mèmoire tampon n’est pas activée et windows envoit plus de donné que le disque peut en digérer

excuse j’avais cru que tu avais vista sur le portable

essais ça :

vérifie dans la base de registre, notament l’entrée suivante :

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion:DevicePath

l’entré DevicePath doit contenir %SystemRoot%\inf par défaut

pour entrer dans la base de registre : menu “Démarrer/Exécuter” ; et taper “regedit” ; et “OK”
pour modifier la valeur , double cliquer sur DevicePath
Edité le 02/01/2008 à 21:53

c’est étrange parce que le disque dur est récent et puissant !
la valeur dans la base de registre est comme celle que tu as écris
cela correspond à quoi d’ailleur cette valeur ?

au répertoire par défaut ou sont stockés les drivers, certains périphériques modifies cette valeur et celà pose des soucis

as tu vérifié les branchements de ton disque dur si c’est toi qui l’a assemblée ?

ok
oui c’est moi qui l’ai assemblé mais je suppose que oui, de toute façon il n’y a que 2 branchements : l’alimentation et le connecteur IDE
et puis il fonctionne très bien sur l’autre pc !!!
j’y pense, ce ne serait pas le cavalier de master/slave, sur l’autre pc je suis en sata alors que la je suis en IDE,
le cavalier est sur la 2eme paire de pins en partant de la gauche

normalement il est reconnu comme péripéhérique de stockage amovible mais ça pourrait être une piste si c’est la seule différence apparente entre les deux pc

tu as sur le disque dur une indication, soit un dessin soit marqué sur le bord, qui montre ou placer le cavalier
essais les 3 possibilités master, slave, cable sélect.

j’ai de gauche à droite : DS (slave) / CS Enabled / Cap Limit
et écrit au dessus : No jumper = DS (slave), le cavalier est sur CS Enabled

heu et master? no jumper ça serait pas master ?

oups c’est plutôt DS (master) / CS Enabled / Cap limit
et apparemment No jumper = DS (slave), c’est sans cavalier donc il est en slave non ?

oui exactement :super:

donc ton disque dur est en cable select
Edité le 02/01/2008 à 22:57

ça veut dire quoi cable select ? :smiley:

Un contrôleur IDE dispose de 2 canaux. Chaque canal peut gérer 2 disques durs reliés à un même câble appelé nappe. Pour fonctionner correctement, chaque disque doit être défini soit comme Master (maître) soit comme Slave (esclave).

Cable select permet au contrôleur de reconnaître automatiquement les disques Slave et Master. Cette méthode de paramètrage s’oppose à la méthode Master/Slave qui implique un paramètrage manuel.
Edité le 02/01/2008 à 23:05

ok merci pour l’information
mais qu’en ait-il de mon problème de HDD ? :o(

tu as essayé en changeant le cavalier ?