Forum Clubic

Pb de son sous debian (réglé)

bonsoir à tous!

j’ai installé une debian sur un portable tohiba satellite 4200 pro series, mais je ne sais comment installer le son
la carte son est une yamaha YMF-744B
faut-il que j’installe alsa driver alsa utils alsa lib?
en plus, le site d’alsa en anglais ne m’aide guère :frowning:

merci si qqun peut m’orienter :jap:

Peut-être une solution, mais en rien une explication ni même quoi que ce soit de très instructif dans ce que je vais te conseiller.
Vu que tu viens à peine d’installer ta debian, tu tournes normalement sur un noyau 2.4. Installe donc un noyau 2.6 précompilé (via apt-get) et le support d’alsa sera compilé en dur dans ton noyau. Et à priori, vu que les noyaux précompilés sont assez “généraliste” le son devrait fonctionner.
Bon, évidemment, comme je te le disais au départ, ça ne t’aide pas vraiment à comprendre comment marche le son sur ton portable, mais si tu ne connais pas grand chose en la matière et si tu es pressé (un film à regarder, un album à écouter ou faire écouter…) ben il y a des chances que ça marche. (j’ai déjà vécu cette scène chez un pote qui voulait absoluement me faire écouter un morceau :slight_smile: )

merci de ta réponse mazkagaz :), ça m’interresse
j’ai fait un apt-get install alsa-source puis alsa-base et alsa-utils
mais ça me dit qu’il manque le module snd, à quoi cala correspond?
et avec apt-get comment j’installe ce noyau pré-compilé?

je crois que c’est apt-get install kernel-image-… la suite je ne sais plus.
Fais un “source /etc/bash_completion” puis lorsque tu tapes “apt-get install kernel-image” tape 2 fois sur la touche Tab. Ensuite tu complètes avec celui qui te convient. Et installe aussi le kernel-header associé au kernel-image que tu auras choisi.

si tu est sous kde il faut que tu aille dans le kde control center et dans la partie son tu vas pouvoir choisir quel serveur de son tu veux utiliser, la tu prend alsa :wink:

il est probable que ton noyau ne soit pas compilé avec alsa, la une chtite recompile vite fait (ta des super docs sur google) en activant alsa et hop ca roule :slight_smile:

il me semble que tu doit installer un démon alsa aussi…

non, je suis sous xfce (portable ancien!)

je vais essayer ce que tu écris mazkagaz

merci à tous les deux :slight_smile:

je ne trouve pas grand chose de clair concernant le kernel, à part compiler
et j’en suis encore loin je pense

par contre, j’ai fait un lsmod qui reconnait

ymfpci, soundcore et ac97_codec

grâce à un sndconfig

j’ai du son au lancement de xfce mais c’est tout [:zjk3]

c’est réglé
j’ai dl le kernel
j’ai joué avec snconfig et modconf
puis j’ai réglé le driver avec l’outil son de xfce ouahoo :slight_smile: