Forum Clubic

Pb de paquet apache sous debian

J’ai installé un serveur apache par la célèbre commande apt-get
Je l’ai configuré, et ça marche bien.

J’ai installé le support php5 de la meme manière :
apt-get install php5

Par contre le serveur n’interprete pas mes scripts php… :confused:

Aprés avoir vérifier dans module.conf, le module php n’est pas chargé.
Je le cherche donc dans /usr/lib/apache/1.3/ pas de module php :ouch:
Par contre il y en a un dans /usr/lib/apache2/mod

Il s’avère qu’a chaque fois que je demande l’installation d’une “extension” de apache il installe la version apache2…
Et quand j’essai d’installé apache2 ( en me disant que peut-etre ça marchera) il veut pas marcher…

La ça fait plus de 2 jours que je suis sur le truc, quelqu’un a rencontré ce problème ?

J’ai une ubuntu, et visiblement c’est pas la première fois qu’il y a des problèmes avec la gestion des paquet sous cette distribution :confused:

Puré,
j’ai choisi debian pour sa stabilité et sa gestion des paquets,
je commence a sérieusement regréter ces choix,
faut m’expliquer pourquoi ubuntu est aussi merdique !!!
Sur une woody ou une sarge, j’ai jamais eu de problème :grrr:

La c’est le bordel complet dans les paquets… :paf:
Les tutoriel n’ont fait qu’agraver les choses et ça commence à m’énerver grave !
:sarcastic:

euh… t’as une debian ou une ubuntu ? :??:

Les deux :wink:

J’ai une ubuntu sur une machine et une debian sur une autre…
Et mes problèmes concerne l’ubuntu…

Comme ça marchait toujours pas et qu’aucun tutoriel ne résolvait mon problème, j’ai installé tous les paquets suivants :
apache2 apache2-common apache2-mpm-prefork libapache2-mod-php4 libapache2-mod-auth-mysql php4-gd php4-mysql php4 php4-common php4-cli php4-cgi mysql-server-4.1 mysql-client-4.1 mysql-common-4.1 libmysqlclient14 phpmyadmin

Le serveur fonctionne (aprés m’être bien énervé dessus) mais j’ai un problème de police maintenant, les accents ne sont pas reconnus :confused:
J’ai mis le language fr en premier dans le LanguagePriority
et j’ai ajouté


AddDefaultCharset       ISO-8859-1
AddDefaultCharset       ISO-8859-15
AddCharset ISO-8859-15 .iso8859-15  .latin15 .fr

Cela marche toujours pas, j’ai regénéré les locales avec dpkg mais, rien n’y fait…
:sweet: