Forum Clubic

Pb de CMD WINDOWS - commandes(ping,ipconfig..) non reconnus

Slt,
Toutes mes commandes ne passent pas sous CMD/DOS : msconfig,ipconfig,ping netstat…
ALors j’ai copié le “cmd.exe” de C:\WINDOWS\ServicePackFiles\i386 et j’ai écrasé celui qui était ds C:\WINDOWS\system32. Mais rien!

J’ai verif les variable d’environnement , je vois un chemin :

variable :ComSpec
valeur : %SystemRoot%\system32\cmd.exe

mon os :Xp :wink:

Et la variable d’environnement PATH ?

En ligne de commande, tapes SET et vérifie les valeurs :
SystemDrive
SystemRoot
TEMP
windir

Voilà ce que j’obtiens avec SET en ligne de commande :

Microsoft Windows XP [version 5.1.2600]
© Copyright 1985-2001 Microsoft Corp.

ALLUSERSPROFILE=C:\Documents and Settings\All Users
APPDATA=C:\Documents and Settings\Paul\Application Data
ASANY9=C:\Sybase\SQL Anywhere 9
ASANYSH9=C:\Sybase\Shared
CommonProgramFiles=C:\Program Files\Fichiers communs
COMPUTERNAME=EPB-PCOMPAORE
ComSpec=C:\WINDOWS\system32\cmd.exe
FP_NO_HOST_CHECK=NO
HOMEDRIVE=C:
HOMEPATH=\Documents and Settings\Paul
LOGONSERVER=\\EPB
NUMBER_OF_PROCESSORS=1
OS=Windows_NT
path=;c:\scriptolp;C:\Nmap
PATHEXT=.COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH
PROCESSOR_ARCHITECTURE=x86
PROCESSOR_IDENTIFIER=x86 Family 15 Model 2 Stepping 9, GenuineIntel
PROCESSOR_LEVEL=15
PROCESSOR_REVISION=0209
ProgramFiles=C:\Program Files
PROMPT=$P$G
SESSIONNAME=Console
SystemDrive=C:
SystemRoot=C:\WINDOWS
TEMP=C:\DOCUME~1\Paul\LOCALS~1\Temp
TMP=C:\DOCUME~1\Paul\LOCALS~1\Temp
tvdumpflags=8
USERDOMAIN=EPB-PCOMPAORE
USERNAME=Paul
USERPROFILE=C:\Documents and Settings\Paul
windir=C:\WINDOWS

q

Ton PATH est faux.

C’est %SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem dans les variables systèmes, et rien dans les variables utilisateurs.

Ce n’est pas grave si tu as un valeur dans le PATH de ton compte, à condition que
%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem
soient compris dedans.

Pour ton cas, ajoute ces chemins dans ton PATH, juste devant les chemins existants, le point-virgule compris, c’est-à-dire par : clic droit sur Poste de travail -> Propriétés -> onglet Avancé -> Variables d’environnement :

Si ;c:\scriptolp;C:\Nmap est dans :

  • la partie variables système : modifie pour que PATH devienne :
    %SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;c:\scriptolp;C:\Nmap

  • la partie variables utilisateur :

  • modifie/vérifie pour que PATH de la partie variables système soit :
    %SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem
  • ET corrige pour que cette variable de la partie variables utilisateur soit :
    %PATH%;c:\scriptolp;C:\Nmap

cool mon pb est résolu!

merci à vous deux :wink: