Forum Clubic

Pb d'affichage

Bonjour, j’ai un petit problème en ce qui concerne l’affichage de mes icones de bureau + barre de taches en bas sous win xp pro : ce **** ne m’affiche que le fond d’écran sans icone de bureau ni barre de menu avec démarrer et tout le tralala d’icones

Apparement un probleme avec explorer mais il n’est pas ouvert et quand je l’exécute, il ne veut pas s’ouvrir.
J’ai donc fait plusieurs scans (ad aware,panda active scan, secuser) pour voir si ça ne venait pas d’un virus ou trojan quelconque mais apparement non.

J’ai ensuite demandé à qqun de me passer son explorer.exe qui s’ouvre et je l’ai remis en éxécution au démarage de l’ordi vu qu’il en était absent. Or non suelement il ne se lance pas malgré qu’il soit bien présent dans l’onglet démarrage de msconfig mais quand je l’exécute manuellement, il n’ m’ouvre que le dossier mes documents et je naviqe ensuite normalement mais toujorus pas de bureau…

J’ai voulu faire une restauration de systeme mais il m’affuche le message : impossibilité de protéger l’ordunateur et vous devez redémarrer, et ce à chaque fois que j’essaye.
Bref, je sais pas comment faire …

qu’est ce que tu as fait avant que tout ça n’arrive soit clair et précis SVP

L’interface ( qui est gérée par Explorer.exe ) est corrompue:

Il faudrait faire une vérification du registre, à faire en mode sans échec (1):
. démarrer > executer > taper Regedit
aller à la clé:
[fixed] HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon[/fixed]
vérifier le contenu à droite, de la valeur ‘Shell’ : elle ne doit contenir que : explorer.exe
Si ce n’est pas le cas, cliquer droit, modifier, et changer la donnée

(1) touche F8 gardée appuyée lors du démarrage du PC - après les ecrans du BIOS -

Bartouze, je n’ai justement rien fait avant que celà m’arrive : pas de téléchargement de quoi que ce soit ni installation depuis un mois.

Mike 27, j’ai fais ce que tu m’as dit et en mode sans éche comme en normal je n’avais bien qu’une donnée : explorer.exe.
Or l’explorer que j’ai téléchargé de mon pote je l’ai mis sous le nom explorer1.exe (car quand on veut remplacer l’original, il fait tout de suite une coppie au meme nom)donc j’ai remplacé la donnée explorer dans la clé que tu m’a indiquée par exporer1 pour qu’il prenne en compte celui qui marche mais pas de changement.

merci en tout cas pour la réponse

de rien , continuons
Registre :
remet explorer.exe quand même

Cette donnée étant bonne dans le Registre, il faut changer de piste: évoquer celle des virus, sypware et compagnie.

[*]Dans un premier temps:
un extrait du site de Hotline-pc.org sur un virus qui masque aussi les icones et la barre des taches:

– début extrait:

  • Mon Bureau est vide, je n’ai plus d’icônes ni Barre des tâches et je ne peux lancer une application qu’en utilisant le Gestionnaire de tâches :
    Votre système est infecté par un “Adware”. Terminez ce processus : sysu.exe
    Dans l’ Explorateur Windows, supprimez le dossier ddm
    Dans le Registre, supprimez cette clé : HKEY_LOCAL_MACHINE\SOFTWARE\ddm
    Par l’Editeur de configuration système, désactivez dans l’onglet Démarrage une entrée nommée msbb
    – fin extrait

[*]Dans un 2eme temps:

et

~~~~~~~~~~ Plouc avait déja fait tout ça ! au temps pour moi ( c'est moi le Plouc  :p  )

Je te remercie chaleureusement de ton aide et j’ai finalement trouvé ce que c’était d’après ce que tu m’a dit à ton post précédant :bounce: . En fait la clef dans shell ouvrait bien Explorer.exe mais sans le chemein d’accès c:\windows… donc j’ai rentré ça et maintenant il se lance tout à fait bine au démarrage. De toute façon j’avais déja fait sécuser.com, ad aware, et panda active scan donc je doutais qu’en le refaisant je trouve que ce soit un virus, d’autant que sysu.exe n’était pas dans ma liste de processus actifs et que j en’avais aps de dossier ddm ni la clef ddm dans le registre. Bref, merci encore et bonne continuation.

super

… mais quand même bizarre: “normalement”, il n’y a pas le chemin de Explorer.exe

Peut-être un soucis de la variable d’environnement PATH
mais ça m’étonnerait ( tu aurais d’autres ennuis dans ce cas )
La variable PATH s’examine dans une invite de commande (fenetre genre Dos ) et en tapant : PATH

de toute façon, c’est réparé :smiley:

En meme temps j’ai déja rien fait pour que ça m’arrive donc yavait meme pas de : normalement :slight_smile:
En plus en dos j’aurais galéré je pense huhu :stuck_out_tongue:

:stuck_out_tongue:
pour la prochaine fois , dans le gestionnaire de tâches vue que tu n’a pas de traces de ton explorer, tu fais Fichier, Nouvelle Tâche et tu tape en respectant la case : cmd /c copy %systemroot%\ServicePackFiles\i386\explorer.exe %systemroot%\explorer.exe , la commande va remplacer l’actuel explorer par celui que ont trouve dans I386 , puis nouvelle tâche explorer.exe (C:\WINDOWS\explorer.exe)

elle n’est pas belle la vie ? :sol:

Wow encore mieux^^
Mais j’espère qu’il n’y aura pas de prochaine fois.