Forum Clubic

Pb connexion réseau sous XP en mode MS-DOS

Bonjour à tous,
Voila mon problème :
Je suis sous XP SP2 avec une connexion à un dossier partagé sur un autre XP SP2. J’ai mappé le lecteur réseau avec reconnexion au démarrage. Ca fonctionne très bien si j’ouvre un logiciel sous windows qui se connecte sur mon lecteur réseau mais pas mon logiciel sous DOS !
Il faut que j’ouvre un première fois le lecteur réseau , avec l’explorateur windows par exemple, pour que le programme sous DOS puisse y accéder par la suite. Il faut que je refasse cette manip à chaque redémarrage de XP.J’ai fais la test suivant :

  • je demarre XP
  • j’ouvre la console d’invite de commandes (cmd.exe)
  • je tape E: (mon lecteur réseau) et XP ne le trouve pas.
  • j’ouvre l’explorateur windows (mon lecteur e: apparait bien sans croix rouge)
  • j’ouvre E: sans probleme
  • je retourne dans la console et tape de nouveau E: et là XP le trouve !!!

Comment faire pour éviter cette manip et que le lecteur réseau soit reconnu d’emblée par mon programme DOS au démarrage de XP ?
Meci de votre aide.

net start xxx (xxx= le service que ton application Dos utilise)
net use * \\192.168.254.55\share /use:utilisateur mdp

net start n’est utile que si tu dois initier un service spécifique pour ta session Dos
net use va créer un network drive * peut être remplacer par une lettre de station disponible comme T: par exemple
user= nom de l’utilisateur qui dispose des droits d’accès
mdp= son mot de passe associé
tout ça dans un batch file ou l’autoexec.bat ou NT

j’espère que cela résoudra ton souci:jap:

en fait tu peux le taper à la ligne de commande si ce n’est pas spécifiquement pour ta session Dos

Merci pour ta réponse. je vais tester.