Forum Clubic

Pb connexion lecteur de carte mémoire sur usb interne

Bonjour,

je viens d’acheter un lecteur de carte mémoires samsung sur cdiscount, pour remplacer mon lecteur de disquettes …

le connecteur du lecteur est un connecteur 9 broches / pins.
le schéma ressemble un peu à ça :

OOOOO
OOOOX
(en fait 10 broches mais 1 est bouchée).

et sur mon pc (CM MSI K7T Turbo2 … je sais, une antiquité :icon_biggrin: ) , il y a 10 pins (2x5)
OOOOO
OOOOO

ça semble pourtant être le même format :confused:

Quelle solution ai-je ? c’est compatible ?

oui mais en général ils ne mettent pas les 10

le plus embêtant est de ne pas se tromper sous risque que le lecteur de carte fonctionne mais qu’il grille ce que tu lui fais manger

le port usb fonctionn comme suit +5v -d +d ground id (courant donnée donnée masse non utilisé ) il faut trouver le sens des masses si sur ta carte elles sont à droite ou à gauche.

as tu un port comme ça ? aucun risque de se tromper

www.forum-auto.com…


je ne trouve pas le manuel de ta carte le lien de msi ne fonctionne plus

Vcc+ (1) ----> 1 o o 2 <-- vcc+ (2)
Data - (1)—> 3 o o 4 <-- Data- (2)
Data + (1) --> 5 o o 6 <-- Data+ (2)
Ground (1) --> 7 o o 8 <-- ground (2)
rien ----------> 9 - o 10 <- shield
Edité le 05/01/2008 à 23:02

yep je l’ai trouvé sur le net par hasard tout à l’heure … et j’ai oublié de l’enregistrer :pfff:

Mais bon, je l’ai aussi au format papier … quelquepart :pfff:

Bref, j’ai un connecteur interne sur la CM, mais qui dispose de 10 pins … donc sur le 9 il y a qqchose …

Sur la prise du lecteur le 9 est bouché … donc que faire ??? le percer ? ça marcherait ?

arff c’est les anciens port usb 1.1 ou ancienne norme c’est à l’envers même si tu retournes le bloc ça rentre pas.

l’idéal c’est d’avoir les fils séparés dans ce genre de cas :frown:

sur les fils a tu des indications ?

si j’ai bien compris ta cable lecteur de carte
OOOOO 12345
OOOXO 678910

ta carte :
OOOOO
OOOOO
Edité le 05/01/2008 à 23:44

effectivement la carte n’est pas usb2.0

Tes schémas sont pas tout à fait juste :
carte => OK
cable du lecteur :
OOOOO 12345
OOOOX 678910

aucune indication sur les fils :frowning:
Par contre sur la prise du lecteur :
1=> CKM
et le 5 est marqué (pour évitre un branchement inversé ??)

donc à ton avis c’est pas compatible ??
C’est quand même con je viens de l’acheter :pfff:

Il n’y a pas moyen de contourner ça avec un adaptateur, par exemple ?
Edité le 05/01/2008 à 23:56

si les normes sont rétro-compatibles sauf que tes lecteurs de cartes iront à la vitesse de l’ubs 1.1 11Mps au lieu de 480Mbps,

aprés je ne suis pas sur qu’en perçant le pin 9 ça fonctionne car les codes couleurs ne sont pas tout le temps normalisés, tu aurias eu les fils séparés qui souvent font pestés car faut tout mettre a la manos ça aurait été plus simple de tester car si tu perces et que ça marche pas ta garantie tu l’as dans l’os:pt1cable: dans l’hypothèse ou tu as des indications sur tes fils…
Edité le 05/01/2008 à 23:54

d’un autre coté un lecteur de carte à 8€ … ça peut valoir le coup de tester non ??
tant pis pour la vitesse:ange:

Le pb si c’est le pc qui crame :paf:
Edité le 05/01/2008 à 23:59

tu as dit "Sur la prise du lecteur le 9 est bouché … donc que faire ??? " :super:

ton pc grillé non car le lecteur n’envoit pas de courant il en reçoit, le seul truc que tu peux grillé c’est le lecteur ou ce queut vas mettre dedans

oups, c’est une bourde, il fallait bien sûr lire “10” :ennuye:

le lecteur ça va … la carte … nooooooon :peur:

merci pour ton aide, je vais aller tester ça …

A suivre donc … d’ici là, bonne nuit et encore merci !!!

ok a suivre…

bonne nuit

bon ben ça marche pas :frowning:
J’ai percé le 10ème pin sur la prise du lecteur …

Et au moment de brancher, je me suis rendu compte que les pins et les emplacements sont inversés … l’emplacement sur la carte est inversé par rapport à la prise du lecteur :pt1cable:

Donc du coup à moins de trouver un adaptateur, ou de jouer au petit mécano en défaisant tout et en rebranchant correctement, je crois que mon lecteur multicarte va rejoindre ses copains sur l’étagère … en attendant un hypothètique upgrade avec une CM qui a des prises usb2 :ange:

Par contre, bizarre, les broches 5 et 10 sur la prise du lecteur ne sont pas cablées :confused: … ça correspondrait à quoi sur une prise usb2 ??

c’est normal il existe de type d’adaptateur usb

Voici les fonctions des broches, pour les types A et B décrites ci-dessous :

8 pins donc 5 et 10 sans rien
Alimentation +5V (VBUS) 500mA maximum ;
Données (D-)
Données (D+)
Masse (GND)

Voici les fonctions des broches, pour le type mini B décrites ci-dessous :

10 pins
Alimentation +5V (VBUS) 500mA maximum ;
Données (D-)
Données (D+)
Masse (GND)
non utilisé (ID)

fr.wikipedia.org…