Forum Clubic

Pb au reboot après avoir branché un disque dur externe

Bonsoir,
ayant connecté un disque dur externe (modèle LaCie 2 To) en USB sur un PowerEdge 2900, j’ai rebooté le serveur.
Et là … impossible de booter, message “invalid device request” comme s’il ne trouvait plus son Master Boot Record (MBR) ou sa table de partitions …
En le débranchant et en rebootant, ça refonctionne !
J’ai regardé dans le BIOS (v1.2.0), mais l’ordre des disques est correct (d’abord en position 1 le disque SATA avec l’OS en l’occurence une SuSE 11, ensuite en position 2 le nouveau disque LaCie en USB).
Il n’y a pas d’option permettant de désactiver le boot sur périphérique USB, il y a juste une option qui permet de dire si on veut activer ou non les périphériques USB.
Avez-vous une solution me permettant de rebooter mon serveur sans etre obligé de déconnecter mon disque avant et de le reconnecter après le boot ?
Merci d’avance.
Cordialement,
Lionel

Bonjour,

Connecter le disque externe quand le PC est en marche, il ne devrait pas y avoir de problème.

ou connecter le disque et passer par le BIOS pour remettre ton SATA en premier dans le boot.

J’ai un CM qui est susceptible de ce coté là aussi :slight_smile:

Bonjour,
effectivement quand le serveur est en marche et que je branche le disque après, cela fonctionne.
Mais étant donné que le serveur doit rebooter assez fréquemment (mises à jour quotidiennes, installation de nouveaux produits, …), j’aurais voulu avoir une solution plus simple sans etre obligé d’aller en salle machines, de débrancher le disque, de rebooter le serveur et de rebrancher le disque après …
D’autant plus que mon disque SATA est bien en premier dans l’ordre de séquence de boot !
Je pense que le fait de connecter le disque dur USB doit modifier le MBR ou la table de partition … et que le système ne doit plus retrouver ses petits pour une raison inconnue …
Si vous avez d’autres pistes, je suis preneur !
Merci d’avance.

Bonjour,

Tu désactives dans le BIOS le démarrage des périphériques USB cela n’influera que sur le boot USB :slight_smile:

Dans le BIOS, je n’ai que l’option “Integrated devices” et “disable all usb ports”.
Quand je fais cette modif., et que le disque est branché, effectivement, le système démarre correctement.
Par contre, je ne vois plus mon disque une fois que Linux a démarré.
Ni par un “df”, ni par un “fdisk” sur le /dev correspondant
Il me manque dans le BIOS l’option “disable usb devices on boot” je pense …

Bonjour,

Dans le BIOS, section Boot, tu doit pouvoir “disabled” les périphériques USB (carte MSI)

Tu listes les Device et sur le disque externe le mettre en disabled.

1 disque système
2 lecteur DVD (si tu en as un)
3 lecteur externe “disabled”

Si ça ne fonctionne pas (ce serait étonnant) utiliser un prise (dateur) pour éteindre le disque à l’heure ou les MAJ se font et le rallumer après !

Dans la section Boot, j’ai l’ordre suivant :
1- Optical drive (lecteur CD/DVD)
2- Hard drive C:
3- Embedded NIC 1 MBA …

Il ne distingue pas le disque système du disque externe USB.

Par contre, j’ai une autre option dans le BIOS qui s’appelle “hard drive boot sequence” (je crois) sui m’affiche bien le bon ordre :
1- Hitachi … (mon disque dur SATA contenant le système)
2- USB MassStorage (mon disque dur USB externe)
Mais contrairement à l’ordre de boot, dans cette option, je ne peux pas désactiver mon disque USB, je peux juste changer l’ordre.
Et même avec cet ordre, ça ne fonctionne pas.

Merci pour l’autre solution (le programmateur).

Bonjour,

Le programmateur n’est qu’un pis aller, et risque de te poser un problème de temporisation entre un arrêt et la remise en marche ?

Si tu peux avoir la référence exacte de la carte mère, aller sur le site constructeur et leur poser la question par courriel ou si il y a un forum…

Si tu n’est pas trop loin du serveur, il existe aussi des prises radio-commandée manuellement mais, elles ne fonctionnent pas si il y a un réseau CPL !