Forum Clubic

Pas de son sous mandriva 2006 - portable muet sous mandriva

Voila, j’utilisait jusque la mandriva le 2005 et je beneficiait du son de mon portable mais depuis que j’ai installé la version 2006, je n’ai plus de son du tout malgré mes tentative:
j’ai essayé d’installer les drivers alsa proposés sur alsa-project mais meme avec les plus récent, ma bécane reste muette.
ma config: centrino sonoma 760, 1024MO, 60GO/7200tr/mn, circuit son intel realtek de base! et ati radeon mobility X700 PRO 256MO.

MERCI D’AVANCE DE VOTRE AIDE!!!!!

Je contourne un peu la question maisveut tu vraiment rester sius mandriva? Je dis ça parce aue apres avoir essayer plusieurs distribution je me suis tourné vers ubuntu qui marche vraiment bien ( mon pc est un notebook centrino ), tous les racourcis clavier fonctionnent (wifi, son,…).
Si tu as des raisons pour rester sous mandriva ( professionel, tu as tout configuré, … ) essaye un forum specialisé sur mandriva, tu auras plus de chances d’obtenir ta réponse :sol:
http://www.ubuntu-fr.org/ a titre d’information
Des que je trouve un forum mandriva sympa je te passerais l’addresse.
Bon, je sais, ce que je viens de dire n’est pas une vraie reponse a ton probleme mais je ne peux pas faire grand chose de plus, sorry

cé quel marque ton portable ?

lance alsamixergui et verifie que tu n’as rien de muet.

fais un lsmod et regarde s’il te charge un module qui pourrait ressembler à un pilote de son (dans le doute envoie nous le résultat)

essais aussi un dmesg et regarde s’il n’a pas eu de problèmes en chargant un module au démarrage.

Désolé, je ne suis pas un spécialiste du son, je ne peux pas plus t’aider :frowning:

Sinon, pour reprendre le post de petertosh, vu que tu es sous mandriva, c’est peut-être que tu préfère kde à gnome, dans ce cas, si tu veux tenter ubuntu, sache qu’il y a ubuntu sous gnome et kubuntu sous kde.

Mandriva c’est tres bien, et l’interface de config bien meilleure que celle d’ubuntu.

Va voir dans la panneau de config section materiel, quel est le driver correpondant a ta carte son ?

Merci de votre aide, je ne pense pas changer de distribution pour le moment, je me sert de linux pour mes études, je suis en cours de migration, cela dit, certains de mes périphériques ne sont pas encores suportés (WINTV USB, SCANJET 3690) je commence peu a peu a trouver mes marques sous mandriva que je suis dans la litérrature depuis 2ans et que j’ai installé cet été.
Je ne compte doncc pas pour le moment tester une autre distrib, mes partiels approchants. j’aurais donc besoin du son que j’ai perdu lors de ma mise à jour.

Pour répondre à toute vos questions, mon portable est monté sur mesure: c’est un KEYNUX compatible linux modèle SERENA X7 (www.keynux.com)

Il y a effectivement une erreur au démarrage, alsa non chargeable, je vous copierai l’écran.
Le truc, c’est que dans Hardrake le circuit est reconnu comme avant:snd-hda-intel…

Je pense que quand j’aurai le temps, je testerai volontier une distrib à base de DEBIAN et GNOME qui est parfaitement libre, mais comme je suis en migration depuis le mois d’aout, je commence soft, surtout que je n’ai pas vraiment de temps à perdre…lol!

En tous les cas merci de votre aide, sur tous les forums, j’ai toujours trouvé des gens fantastiques qui m’on aidés à résoudre certains de mes problèmes! VIVE LE LIBRE! VIVE LES COMMUNAUTE!!!

voila ce que me dit le système une fois démarré:
Sound server informational message:
Error while initializing the sound driver:
device: default can’t be opened for playback (No such device)
The sound server will continue, using the null output device.

et voici ce a que me dit lsmod

[CODE]snd_seq_dummy 2532 0
snd_seq_oss 31136 0
snd_seq_midi_event 5696 1 snd_seq_oss
snd_seq 46960 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device 6828 3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss 48960 0
snd_mixer_oss 16896 1 snd_pcm_oss
snd_intel8x0 29408 0
snd_ac97_codec 83900 1 snd_intel8x0
snd_pcm 79784 3 snd_pcm_oss,snd_intel8x0,snd_ac97_codec
snd_timer 20548 2 snd_seq,snd_pcm
snd_page_alloc 8392 2 snd_intel8x0,snd_pcm
snd 46116 9 snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_intel8x0,snd_ac97_codec,snd_pcm,snd_timer
soundcore 7008 1 snd

Sound server informational message:
Error while initializing the sound driver:
device: default can’t be opened for playback (No such device)
The sound server will continue, using the null output device.

problème de serveur de son, tout n’est peut-être pas perdu :wink:

si tu as un fichier wav qui traine sur ton disque, essais de le jouer avec cette commande :
‘aplay fichier.wav’

Si ça marche, va dans le centre de configuration KDE, son et multimedia -> système de son -> onglet ‘metériel’ et essais de changer le périférique audio (tu as plusieurs possibilités essais les toutes)

J’espère que ça va t’aider :wink:

Salut,

je viens de faire l’acquisition de ce portable et j’ai fait face aussi (entre autre) au problème de son. Cela s’est résolu automagiquement en installant le kernel 2.6.12-22 que tu peux trouver dans les miroirs contrib (installation facile de ce miroir via http://easyurpmi.zarb.org/))

Bon courage