Forum Clubic

Pas de son sous Kubuntu

Bonjour,
je suis un débutant sous linux, et j’ai un problème avec le son.
j’ai ce message au démarrage de Kubuntu 5.4 :

Sound server informational message:
Error while initializing the sound driver:
device: default can’t be opened for playback (No such file or directory)
The sound server will continue, using the null output device.

je n’ai donc aucun son.
je ne sais pas quelle est ma carte son ni comment le savoir, ni comment remédier à ce problème.

j’avais du son avant d’installer alsa sous ubuntu , j’ai suivi les instructions de Q : Comment configurer correctement le son dans GNOME ? qui se trouve dans le guide de démarrage d’Ubuntu 5.04 pour l’installer, c’est depuis ce moment que le son ne fonctionne plus.

avant d’installer alsa le son était mauvais, à la limité du saccadé.

Pouvez-vous m’aider?

dans le cas d’une carte son pci tu peux essayer d’installer pciutils.
Ensuite tu tapes lspci, moi ça me donne :

00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 60)

Ensuite je configure mon noyau avec alsa seulement en utilisant le pilote qui correspond :


<*> VIA 82C686A/B, 8233/8235 AC97 Controller

Si tu as le temps essaye de compiler toi meme un noyau… (ou alors compile simplement en module le module de ta carte son et charge le)
Les assistants automatiques sont foireux souvent.
En plus comme le montre ton message tu ne sais pas vraiment ce que tu as fait.
Peut etre alsa entre il en conflit avec oss qui tournerait encore.

Cela dit en relisant le message ça a pas l’air d’etre un probleme de driver mais simplement de localisation par alsa de la carte son. Essaye de lancer l’assistant de configuration d’alsa.

C’est pareil je pense qu’il s’agit plus d’un problème de configuration du serveur son, que d’un problème de driver, d’autant que tu avait deja du son au debut.

Regarde quand même les utilitaires de configuration du serveur son et essaye de configurer correctement alsa, ou utilises en un autre.

Sinon c’est quoi ta carte son?

voilà la réponse pour cette commande

~$ lspci
0000:00:00.0 Host bridge: VIA Technologies, Inc. VT8363/8365 [KT133/KM133] (rev 02)
0000:00:01.0 PCI bridge: VIA Technologies, Inc. VT8363/8365 [KT133/KM133 AGP]
0000:00:07.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super South] (r ev 22)
0000:00:07.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT82 3x/A/C PIPC Bus Master IDE (rev 10)
0000:00:07.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Contr oller (rev 10)
0000:00:07.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Contr oller (rev 10)
0000:00:07.4 Host bridge: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI] (r ev 30)
0000:00:07.5 Multimedia audio controller: VIA Technologies, Inc. VT82C686 AC97 A udio Controller (rev 20)
0000:00:10.0 Ethernet controller: Davicom Semiconductor, Inc. 21x4x DEC-Tulip co mpatible 10/100 Ethernet (rev 31)
0000:01:00.0 VGA compatible controller: nVidia Corporation NV20 [GeForce3 Ti 200 ] (rev a3)

sinon je ne sais pas comment configurer alsa, je vais chercher un peu. Et recompiler un noyau ça ne me dit rien, je suis encore un débutant!

voici ce que j’ai dans /proc/asound/oss/sndstat

Sound Driver:3.8.1a-980706 (ALSA v1.0.6 emulation code)
Kernel: Linux vieuxpc 2.6.10-5-386 #1 Thu Aug 18 22:23:56 UTC 2005 i686
Config options: 0

Installed drivers:
Type 10: ALSA emulation

Card config:
VIA 82C686A/B rev20 with STAC9721/23 at 0xdc00, irq 5

Audio devices:
0: VIA 82C686A/B rev20 (DUPLEX)

Synth devices: NOT ENABLED IN CONFIG

Midi devices: NOT ENABLED IN CONFIG

Timers:
7: system timer

Mixers:
0: SigmaTel STAC9721/23

des fois que ça pourrait servir…

dans le module de config de son de kubuntu, j’ai mis OSS à la place d’alsa, et là j’ai le son, qui ne saccade plus, et ça marche pour les mp3, videos et cds audio.
Le problème vient donc d’alsa!

Tu peux peut-être essayer de lancer la commande alsaconf en console :slight_smile: ( root bien sur )

cette commande est inconnue…

Installe le package

Bonjour,

J’ai la même carte et le même prob que ce monsieur :sarcastic:
et … je confirme qu’alsaconf n’est pas dispo, et même avec le package alsa-utils d’installé …
Lui a installé OSS, mais bon … moi j’aimerai faire fonctionner alsa !
Aidez-moi :stuck_out_tongue:

@++

teste une commande du genre:
sudo dpkg-reconfigure alsa-base