Forum Clubic

Pas de 5.1 par hdmi et nvidia high definition audio ?

Bonjour voilà mon problème :

Je branche mon pc portable samsung sur la télé par hdmi. Par le hdmi je fais aussi passer le son grâce au système “nividia high definition audio”.Ma télé est connecté en coaxial ( spdif) à mon ampli h-c.

Je lance un mkv hd et là l’image et le son (stéréo) sont nickel sur la télé. Je passe le son en “5.1 sur spdif” dans vlc et là le son sort bien en dolby digital mais saccadé, pas possible d’écouter. J’ai regardé au niveau processeur tout va bien, utilisation a 50% donc pas de limite de proc. A mon avis c’est le module “high definition nvidia” qui décode mal mais je ne sais pas.

Quelqu’un a-t-il déjà eu ce problème ?

Merci.
Message edité le 31/05/2010 à 23:09

Bonjour,

Si ton, processeur a deux coeurs, le fait d’être à 50% peut tout à fait montrer une saturation. :wink:
Utilises-tu l’accéleration matérielle pour le décodage du MKV ?

VLC a toujours posé des problèmes avec le décodage des pistes 5.1, ca n’a rien de nouveau. A propos, 50% d’occupation CPU lors de la lecture d’une vidéo HD ce n’est pas normal, je suis à peine à 5% sur le mien et c’est loin d’être une bête.

Les premiers trucs à vérifier mais sans aucun résultat garanti : dans “Outils” > “Préférences”, sélectionner “tous” dans les paramètres (tout en bas à gauche)

  • dans le menu “audio”, décocher la case “rééchantillonnage audio haute qualité”
  • cocher “utiliser spdif si possible”
  • replay gain sur “aucun”

Repasser en paramètres simple,

  • dans l’icône “vidéo”, vérifier que les cases “sorties vidéo accélérée” est cochée.

Sinon il y a des solutions qui fonctionnent bien comme Media Player Classic Home Cinema accompagné éventuellement d’un pack de Codecs :slight_smile:

Bonjour.Merci pour vos réponses.

J’ai pris media player classic home cinema avec le pack k-lite codec full.Apparemment il decode bien le dts mais le son ne sort toujours pas en 5.1:(

Je ne comprend pas.Comment faire sortir le son en 5.1 ?

Y a- t-il un moyen de faire sortir le flux en bitstream c’est a dire non décodé pour que ça soit mon ampli qui s’en charge ?
Message edité le 01/06/2010 à 23:55

Oui, comme dit plus haut, il faut activer la sortie S/P-DIF.

Donc tu as bien le son, mais en stéréo seulement, c’est ca ?

2 question bête mais : certaines pistes son sont en 2.0 uniquement, donc le 3.1 qui reste n’est pas actif. Les pistes sont souvent en 2.0 par défaut, il faut quelquefois sélectionner manuellement le 5.1

dans tes propriétés haut parleur windows, tu as bien déclaré des HP en 5.1 ?

Tu as quoi comme ampli et que dit l’afficheur ? (il devait se caler sur Dolby Digital, Prologic ou DTS en fonction des flux reconnus)

C’est bon j’ai réussi a sortir du bit-stream grâce au codec AC3 filter. Il faut aller dans les options et cocher spdif et faire en sorte qu’il ne sorte pas du pcm mais bien la source telle qu’elle est.

Je peux maintenant profiter de tous mes films hd. Merci.

Pour info j’utilise k-lite full pack pour la vidéo et AC3 filter pour le son. Voilà.

:super: impeccable !