Forum Clubic

Pas d'affichage vidéo sous VLC et WMP

Bonsoir à toutes et à tous,

J’en viens à demander de l’aide car je n’arrive pas à résoudre ce problème seul.

Récemment j’ai formater mon disque dur, et j’ai réinstaller ma version de windows XP (officielle). J’ai installé les drivers ( certes il ne doivent pas être très récents, mais ça marchait bien avant mon formatage ), et j’ai aussi installer le pack de codec XP généralement utile pour WMP.

Toujours est-il que lorsque je lance une vidéo avec Windows Media Player ou même avec VLC, je me retrouve avec un fond noir, cependant avec le son ( je n’ai pas tout perdu ^^).

En fouillant sur le net, j’ai vu que cela pouvait venir du fait que je n’avais pas réinstaller DirectX, donc j’ai installé DirectX 9.0c, mais j’ai toujours le même résultat.

Choses étranges, tout fonctionne bien avec le lecteur Media Player Classic ( son et image ), et aussi, lorsque que je lance VLC et WMP l’un après l’autre, le son et l’image sont présents dans le deuxième lancé.

Je souhaiterais avoir vos lumières pour résoudre ce problème.

Vous remerciant de m’avoir lu, et d’avance pour d’éventuelles réponses.

Bye.
Edité le 31/01/2008 à 19:29

telecharge Klite mega codecs:

www.clubic.com…

a+

D’accord je vais essayer ça.

Merci de ta rapidité.


J'ai téléchargé le pack, mais lorsque je veux l'ouvrir, un message d'erreur apparaît :

“The setup files are corrupted. Please obtain a new copy of the program.”

Saurais-tu d’où vient ce problème ?

étonnant, et un autre essai ici :

www.01net.com…

a+
Edité le 31/01/2008 à 19:43

Généralement je prône le pack conseillé par Vyger (je pense qu’il ne me contredira pas …)
Bizarre qu’il ne puisse pas s’ouvrir

Mais si la version de telecharger.com que t’a proposé Vyger ne fonctionne pas non plus, jette un coup d’oeil ici : XP codec pack


Je tiens à préciser que posséder plusieurs pack de codecs contribue à l'instabilité du système. Donc désinstalle un pack avt d'en tester un autre quel qu'il soit Edité le 03/02/2008 à 02:58

Heu k-Lite sa c’était bien y à 5 ans… Maintenant vaut mieu utiliser Satsuki, utilisation de filtre, c’est bien mieu… évite les conflits de codecs et les fichiers en pagaille des gros pack.

Edit => Le lien =>
ftp2.yatoshi.com…
Edité le 03/02/2008 à 12:35

A priori, peut être pas un problème de codec, VLC passant par les siens. Regarde s’il n’y a pas une option dans les drivers de ta CG, ou activer l’accélération matérielle.
Jacky67 help us^^

Salut Silggins :hello:
Je n’en sais pas plus que vous malheureusement… :frowning:

La seule chose que je peux dire, c’est que je suis d’accord avec toi Silggins : ça vient visiblement d’un problème d’overlay et non des codecs qui n’ont apparemment rien à voir là-dedans.
Si c’est une carte graphique nVidia alors il faut essayer des drivers plus récents.
Si c’est une CG ATI, alors c’est étonnant…

Tu peux forcer l’affichage en mode que j’appellerais “non overlay” dans VLC mais ça ne fera que palier à un probable problème des drivers de la CG.
Essaye donc ceci dans VLC :

  • va dans le menu “Paramètres \ Préférences…”,
  • va dans “Vidéo \ Modules de sortie”,
  • là, tu ne dois rien avoir dans la partie droite de la fenêtre,
  • coche alors “Options avancées” tout en-bas à droite dans la fenêtre,
  • tu dois avoir maintenant un champ nommé “Module de sortie vidéo” dans la partie droite de la fenêtre,
  • sélectionne “Sortie vidéo Windows GDI”.

Tu devrais maintenant avoir ton image avec VLC sans avoir besoin de lancer un autre palyer auparavant.

Tu peux essayer de sélectionner successivement les différentes possibilités de la liste “Module de sortie vidéo” afin de concerver le mode le plus efficace.

Merci de nous tenir au courant. :jap:
Edité le 03/02/2008 à 17:19

Jacky67>pas mieux,le mode GDI étant le mode le plus lent mais le plus compatible :wink:

Je vous remercie pour vos solutions, mais le problème est résolu.

Ce n’était pas un problème de codecs, ni de drivers de la carte graphique. En fait, c’est que lorsque de l’installation de mon écran, j’ai sans le faire exprès activer un clône ( ce qui fait que j’avais deux écrans théoriquement) ce qui pouvait servir à faire différent profil.

Et donc j’ai du sélectonner le deuxième écran, car les lecteurs devaient apparement chercher à afficher les videos sur ce deuxième alors que j’étais sur le premier.

Merci encore, bonne journée.

Merci du feed-back !

Bonjour,
J’ai exactement le même problème souf qu’il ne concerne que le Lecteur Windows Media (du son mais pas d’image et j’ai essayé les difféerents codecs). Je ne suis pas un pro alors j’aimerais savoir comment tu t’es rendu compte que tu avais installé un “deuxième écran” ? Je pense que c’est la même chose pour moi (je viens d’acheter un écran) mais je ne sais pas comment y remédier !
Merci d’avance.
Olivier

Ce que j’ai décrit est justement pour ce cas-là. :wink:

Pour savoir sur quel écran (primaire ou secondaire) tu travailles, tu as un bouton “Identification” normalement qui te permet d’afficher un énorme “1” sur l’écran primaire et un non moins énorme “2” sur l’écran secondaire.

Fait un clic droit sur un endroit libre du bureau et Propriétés.
Dans paramètres, tu verras sur quel écran tu es (avec les 1 et 2 décrits par Jacky67).

Oupsssss ! J’avais effectivement omis d’expliquer où se trouve le bouton “Identifier”… Heureusement que Silggins veille au grain. :jap:

Mon écran est bien identifié comme étant l’ecran 1 et tous les autres lecteurs fonctionnent bien. Il n’y a que WMP qui affiche un ecran noir. Comment puis-je vérifier que WMP ne cherche pas à afficher les vidéos sur l’écran 2 (que je n’ai pas !!) ?
Merci pour vos reponses.
Olivier

Peut-être as-tu un problème de codec vidéo ?

Quels autres players as-tu testés ?

J’ai précisé car j’ai cherché ^^

Sinon, c’est vrai que ça ressemble à un problème de codecs (tout en sachant que trop de codecs peuvent être nocifs).
Je poserais une question supplémentaire : quel fichier veux-tu lire ?

Je ne pense pas que ce soit un pb de codecs puisque, les deux icones ffdshow video decoder et tffdshow audio decoder apparaissent bien dans la zone de notification. J’ai essayé plusieurs packs (en les désinstallant à chaque fois) mais rien n’y fait. De plus, chose etrange, quand je pace en mode apparence, il lit la vidéo !!!
Je cherche à lire des fichiers .avi mais le pb est le même pour tous les fichiers vidéo.