Forum Clubic

Pas asser de memoire gothic 3 mais jai 4g de memoire et ma memoire virtuel 6g

jai 4g de memoire et vista 64 mais apres u certain temp une erreur se produit et une fenetre ouvre disant pas asser de memoire,jai essayer la memoire virtuel a automatic,gerer par le systeme et a 6000mo mais ca na pas marcher ,je joue a des jeux beaucoup plus exigant que ca et je nai jamais eu ce probleme.pouver vou m’aider svp.merci

Effectivement c’est gênant…Est-ce que tes 4 Go sont biens reconnus? regarde dans le gestionnaire de tâches combien prends Gothic 3 en RAM
Ce jeu est réputé pour avoir été ultra buggué, peut être devrait tu appliquer les patchs, dont ceux non officiels

quelque chose me dit qu’il n’aime pas la gestion mémoire de l’émulateur 32bits de vista 64, essaye de voir quelles options tu as dans les propriétés de l’exécutable en ce qui concerne la compatibilité 32 bits.

mes 4go sont bien reconnu et jai bien installer tout les patch que jai trouver plusieur fois ,jai reinstaller aussi,
je pren 2.13go total en jouant.
et dans les proprietes je ne vois rien concernant la compatibilite 32 bit

As-tu modifié un fichier .INI ou .CFG quelconque pour ‘optimiser’ le jeu d’une manière quelconque?
Des packs de textures ou autres?

Quand tu dis “j’ai installé tous les patch”, tu veux parler du jeu, de Windows Vista ou des deux ?
Si tu as le SP1 pour Vista (ce qui est fortement recommandé), il ne faut pas se fier à ce Vista affiche dans le panneau système; il faut lancer le gestionnaire de tâches, aller dans l’onglet Performance et regarder dans le cadre “Mémoire physique” quel est la mémoire totale.
Il ne suffit pas d’avoir Vista x64 pour avoir 4Go, sur certaines cartes mères (par exemple avec mon Asus P5B Deluxe), il faut activer un paramètre dans le Bios (Memory remapping) pour que Vista x64 puisse voir les 4 Go.

Cela étant dit, il est probable que le jeu ne soit pas à court de mémoire mais à court d’espace adressable qui est limité à 2Go pour les programmes 32 bits (même sous Vista x64).
Explications techniques en anglais ici: http://msdn.microsoft.com/en-us/library/aa366778(VS.85).aspx

Si cela ne t’aide pas et si tu as bien 4 Go avec Vista SP1 + patch, tu peux faire une recherche dans google avec: gothic 3 out of memory
Je n’ai pas le jeu Gothic 3 donc je ne peux pas t’aider davantage.

je nai rien modifier.
et mes 4go sont bien reconnu,merci pour le petit lien,tres interessant,mais ce n’est pas le seul jeux en 32 bit que je joue et qui prenne plus que 2go et c’est le seul qui me fait ca,
je commence a penser que je vais me contenter de sauvegarder souvent et d’endurer mon probleme.

Ne connaissant pas les systèmes 64bits je ne peux pas vraiment aider, mais si tu dis que ce n’est pas le seul jeu, je te conseille plutôt de te pencher sur le probleme.
Essaies de contacter des forums spécialisés plateforme 64 du genre içi

Tu n’a pas dit si tu avais bien Vista SP1 avec les derniers patch.

A priori Gothic 3 n’est pas compilé avec le flag LargeAddressAware donc il ne peut utiliser que 2 Go pour ses données propres (le reste étant disponible pour l’OS).
On peut modifier l’exe et les DLL pour activer ce flag, plus d’infos ici: http://www.rpgwatch.com/forums/archive/index.php/t-436.html

Tu peux trouver CFF Explorer ici: http://www.ntcore.com/exsuite.php
Lance CFF Explorer, ouvre gothic3.exe puis clique dans File Header puis dans Characteristics, regarde si “App can handle >2Gb address space” est coché.

Pour plus d’infos
google: gothic out of memory
google: gothic largeaddressaware

oui jai bien sp1 et tout mes patch.jai installer CFF Explorer et App can handle n’etai pas cocher,je l’ai cocher je vais essayer voir si tout c’est arranger ,mais je me demande si 32bit word devrai etre decocher pcq la il est cocher.

C’est normal que “32 bit word machine” soit coché: ne pas y toucher

J’ai regardé parmi mes jeux, lesquels avait “App can handle > 2Gb”
C’est oui pour The Witcher, Civ4 Beyond The Sword et NWN2 (c’est non pour Oblivion).
Par contre, ça n’est pas coché pour les DLL qui sont dans le même répertoire.

Dans le lien que j’ai donné, ils disent qu’il faut que ce soit coché pour gothic3.exe et toutes les DLL qui sont dans le même répertoire.

felicitation serieusement je te remercie beaucoup,je n’ai pls aucun probleme tout c’Est arranger,merci

Bonne nouvelle.
Il faudrait que tu cliques sur Résolu pour que le sujet apparaisse comme “Résolu”.