Forum Clubic

Partage fichier avec Samba - Problemes.. :/

Bonjour,

Voulant installé un fichier partager entre machine winXP et une red hat (serveur). J’ai donc voulu utiliser le systeme samba, permetant au machine win de voir le serveur unix.

Je me suis assez bien documenté et donc fait les reglages dans le fichier /etc/samba/smb.conf

Sur les postes windows je n’ai vu que de rajouter le protocle netware et d’avoir le meme nom de domaine.

Donc pour le moment je ne vois pas le fichier partagé sur la red hat depuis les winXP.

voici le fichier smb.conf

De plus quand je test la commande smbstatus, j’ai une phrase que je n’aime point. Cela vous dit il qqchose ?

toujours le meme message d’erreur sur une autre commande:

les daemon sur mon serveur on l’air de bien fonctionner

si vous avez des idées à me proposer svp , car la je ne sais plus trop quoi faire.
merci d’avance !

Rôôôôlàlàlàlà ! T’as fais une bidouille pas possible !

Tu veux faire un simple partage de fichiers ou carrément un contrôleur de domaine ? Et si tu fais un simple partage de fichiers, tu le fais avec authentification ?

Oui je suis un peu touche à tout :sarcastic:

Mais pour commencer si le simple partage de fichier sans authentification pouvait marché , sa me suffirai :frowning:

edit: ptite precision niveau reseau je suis plutot moyen.

Pour le message d’erreur (“Server’s Role (logon server) conflicts with share-level security”) j’ai pu l’enlever, en descativant ceci dans le smb.conf :

J’attend vos commentaires sur le fait que je n’arrive pas à voir mon fichier partagé a partir des machines windows :confused:

Pour le message d’erreur , ça doit pas être bien grave parce que moi, j’ai le même et le partage marche dans les deux sens… T’as essayé smb4k ?

Non je n’ai pas essayé, je crois que c un outil graphique pour samba?.

Mais je me pose une question…

j’ai creer le fichier à partager sur linux (/mnt/partage)
chmod 777

mais je me demande s’il faut le monter ou pas? et si oui quel est la commande a faire svp (oui je sais vous pourrez ma flagolez si c sa mon erreur :pfff: )

et une derniere question que je me pose ou peut on changer le groupe de travail réseau d’une machine linux? parceque à part dans le fichier smb.conf , je n’ai jamais changer modifier le groupe de travail sur le serveur

j’ai refait mon fichier smb.conf version simpliste:

c’est un peu compliqué avec mount en fait…
mais y’a d’autres techniques :

  • pour y revenir, ouvre sbm4k, dans l’onglet chercher, entre le nom de la machine distance et fait chercher. dès qu’il a trouvé fait ajouter et là, tu peux monter les dossiers partagés dans problèmes
  • si tu as swat d’installé, ouvre ton navigateur et dans la barre d’adresse entre http://localhost:901 pour configurer Samba (très) simplement et demander un montage auto…
    Bonne chance…

oki merci je voulais faire sans interface graphique mais bon on va essayer :neutre:

Sinon tu confirmes qu’il faut absolument monter le repertoire à partager coté serveur ?

Oui il faut monter le répertoire comme si il était un périphérique…
Mais “côté serveur” je sais pas, parce que dans un réseau familial (comme le tient si j’ai bien compris), ya pas de serveur ni de client, c’est du p2p… Mais bon ouai, il faut que tu le monte… oft, si t’as une Mandrake, tu peux le faire dans les partages Samba via drakconf…

alors ce n’est pas du tout un reseau familiale, je ne compte pas du tout faire du P2P¨ :slight_smile:

le serveur et les postes clients font partie d’un sous reseau.

en gros je dois configurer une dizaine de PC winXP pro / linux pour pouvoir avoir accées aux fichiers partagés sur le serveur (qui est une red hat 9)

Ce qui me chagrine le plus c’est que j’ai epluché bcp de documentation et il ne parle pas bcp des montages de fichiers en rapport avec samba.

bcp disent une fois les reglages finit sur le serveur (smb.conf) que nous devrions voir le repertoire partagés directement dans le favoris réseau des postes client windows (et ce n’est malheuresement pas le cas pour moi :’( ).

[i]EDIT: une question qui m’agace enormement :

J’ai mis mon PC (client winXP pro) sous le groupe de travail WORKGROUP. Du coté serveur j’ai configurer dans le smb.conf le workgroup = workgroup.

et dans le favoris reseau de windows quand je regarde dans workgroup je vois des pc mais pas du tout mon serveur samba :confused:

seriez vous pourquoi ?

comme indiquez au dessus les pings entre les 2 PC fonctionnent bien.[/i]

Attention : il ne faut pas mettre de minuscules pour les noms d’hôte !
workgroup = WORKGROUP
:o
Et maintenant ?
PS : pense à redémarrer ton réseau (console, root, “service network restart”, ou débranche le câble ! :slight_smile: )

C’est bien en majuscule que je l’ai ecrit :slight_smile:

Pas bete le coup de redemarrer le service réseau.

Je testerai demain, merci :slight_smile:

Mais fait attention, dans mon cas, il fallait que je coupe le firewall pour pouvoir échanger des fichiers et tout ça (service shorewall stop, si tu utilises shorewall).
Bien entendu, tu es sûr que ton groupe de travaille sur Wndws est bien WORKGROUP et pas MSHOME ?
Et essaye ça (dans ton smb.conf) :
server string = SambaServeur %v
Dernière chose, je n’ai pas vu de nom NETBIOS dans ton fichier… Il en faut un !
netbios name = IRSOT
(à ajouter dans la première section, [global].)
par exemple…
good luck !

Oui je n’ai pas coppier coller la bonne version du smb.conf :confused: dans la bone version il y a bien un netbios name :slight_smile:

alors apparement le prob viendrai du reseau , une fois le redemarrage du service network, j’ai pu avoir acces a mes partages samba :slight_smile:

merci a tous :stuck_out_tongue: