Forum Clubic

Partage de fichiers sous linux [Fixed]

Lut, je voudrais savoir comment partagé des fichiers entre mon pc sous Linux (VectorLinux 5.8, derivée de slackware) avec mes autres pc sous windows en réseaux local, jusque la j’arrive a acceder aux fichiers partagés de mes pc sous windows, mais de mes pc windows vers linux j’y arrive pas, je pense que c’est parceque je n’ai pas de dossier en partage Donc voila si quelqun ourrait m’indiquer la marche a suivre pour un partage de fichier… :sarcastic:
petite precision mon bureau c’est XFCE au cas ou…

Salut,

As tu installé samba?

ouais, il est inclus dans toute les distro maintenant, et en plus j’arrive a l’utiliser car je peut aller sur mes autres pc sous windows, le truc que je sais pas faire c’est mettre un dossier en partage, c’est surement trés con mais je vois pas trop comment faire :neutre:

en fait tu utilises le client samba qui s’appelle smbfs
Mais gabe te parle du serveur samba que tu dois installer et configurer pour faire ce que tu veux.

Salut,

J’ai un onglet “Partage” dans les propriétés du dossier, va faire un tour dedans. Je ne peux pas tester car j’ai qu’un seul PC.

j’ai verifié samba et fuse samba sont bien installer , sous windows je vois mon pc linux avec “nom+ samba sever”, sinon quand je vais ds l’onglet propriétés avec Thunar je n’ai que la gestion des droits… , ya rien pour mettre en partage un dossier… :peur:

c’est pour kde ca…
peut etre que gnome le fait aussi, je sais pas.
Mais xfce non c’est une certitude.

Donc samba est installe alors il faut que tu configures le fichier /etc/samba/smb.conf ou /etc/smb/smb.conf (ca depend des distribs)
Pour une bonne source d’infos, va la : www.samba.org
si t’as des soucis, n’hesite pas a poster le contenu de ton fichier de conf ici on te le corrigeras suivant ce que tu veux faire.

C’est bon youpi :super: , il suffisait de rajouter quelque ligne ds le .conf de samba
maintenant je peut utiliser mon pc sous linux comme serveur multimedia…
YA pas a dire une distro linux sur un vieux pc et sa revie :ane:

Un piti problème de mon coté : j’ai installé samba & co, j’ai l’onglet partage dans kde, avec deux boutons : non partagé et partagé. Quand je veux mettre partagé, il veut pas et me dit :

Or voila ce qui peut peut être aider un peu :

Je sens que ça va être le truc tout bête auquel il suffisait de penser :smiley: (j’espère en fait :stuck_out_tongue: )

Je suis pas un expert avec Kde, je preferre Gnome pour tout dire… :sarcastic: , mais je penses que ton probléme ne vient pas de samba , mais d’un programme que kde doit utiliser pour rendre son utilisation plus WYSIWYG, et le truc que je comprend pas c’est que ta tout les droits sur le fichier… et que ca merde :??:
tu peut essayer d’ajouter ton fichier a mettre en partage ds le .conf de samba, tu fais

[nom du dossier]
        path       =    #ton chemin pour le dossier a partager
        public     =    #yes ou no, no si on ne veut autoriser que certain utilisateur
        writable   =    #yes or no c pour que l'on puisse ecrire dessus
        browseable =    # yes or no , pas sur du nom,c peut-étre browsable... :whistle:  

aprés ta pliens d’autres options comme autoriser seulement certain utilisateur mettre un mot de passe etc…

Il est bien défini dans le smb.conf
Je vais refaire un test depuis l’autre pc.

Ou sinon j’ai LA Solution… Passe sous Gnome :smiley:

Non, merci :smiley:
Les rares fois que j’ai essayé, c’était assez mitigé… Question de goûts je suppose :stuck_out_tongue:

Sinon pour le smb.conf, j’ai tout bien mis je pense (bien défini le Workgroup, j’ai mis un netbios name = un truc unique :smiley: j’ai laissé security = user et le fichier est public, writable et browseable )
Le Pc est vu depuis Win, mais pas moyen d’y accéder.

Juste pour voir ce que ça fait vire la ligne security=user c’est peut-étre ça , mais je suis pas sur du tout…

Ça change rien

je vois plus trop quoi faire d’autre… :confused:

Trouvé !!!

Mea mxima culpa : le proprio du dossier que je voulais partager était… root :smiley:
Donc forcément il pouvait pas, non à cause de fileshareset, mais tout simplement parceque je ne peux pas partager (en tant qu’utilisateur) les fichiers d’autres personnes, en particulier root donc ^^
Un simple chown a réglé le problème.