Forum Clubic

Partage de fichiers oui / partage Internet NON

Salut à tous,
Après maintes tentatives infructueuses, je me résouds à demander de l’aide :
[réseau 2PC sous Win2000 pro SP4 par liaison direct cable croisé : PC1 (192.168.0.1) a internet et le PC2 (192.168.0.2] doit passer par le PC1]
Les 2pc se voient et peuvent s’échanger des fichiers mais le PC2 ne peut aller sur le net “Impossible d’afficher la page”. Le partage de connexion est bien activé sur le PC1. Dans les options internet du PC2, il n’y a pas de connexion affiché mais paramètre réseau script config auto 192.168.0.1 (avec ou sans c’est pareil).
J’ai essayé tout ceci (ensemble ou séparément):
IP auto pour (PC2 mais là pas de partage de fichiers et encore moins internet), passerelle IP du PC1, serveur DNS IP du PC1, idem…
Ca fait plus d’une heure que je recherche sur le forum et je ne trouve pas.
Je crois n’avoir rien oublié ; les questions sont les bienveues.
Merci d’avance

PS: prochainement j’activerai la fonction routeur de la freebox et acheterai switch et cables droits mais j’aimerai d’abord que ça fonctionne ainsi.

J’ai exactement le meme probleme que toi, j’ai tout fait …

le partage marche, mais pas la connexion

hum rajoute sur le pc2 les DNS de ton fournisseur d accès au moins le DNS principal

des fois ca peut aider a trouver la connexion internet

tu peux les trouver ici : http://diggi.services.online.fr/articles.php?lng=fr&pg=166

je ne dis pas que c la solution, mais ca peut etre une solution

Je viens d’essayer ton idée, Florent42 mais ça ne change malheureusement rien, DNS de free sur PC2 (avec ou sans scprit auto PC1 dans paramètre réseau option internet).
Bravo Windows Professionnel !
Ca m’énerve de pas savoir !

petite info supplémentaire : les PC1 et 2 “se ping” bien entre eux mais logiquement le PC2 ping rien du tout, il répond “hôte inconnu”.
Voilà je désepère
merci pour vos réponses et d’avance à ceux qui en feront autant.

pour le ping…tu as SP2 ? ou bien un firewall installe sur le PC1?

Comme c’est indiqué dans le 1er message, il s’agit de PC fonctionnant sous Win 2000 Pro SP4 à jour.
Pour “pinger”, je vais dans une invite dos (démarrer/exécuter/cmd) puis ping .
Firewall (look’n’stop 2.05) actif ou non : idem.

Peux-tu nous coller le résultat d’un ipconfig /all de chaque PC ?

Au niveau du firewall il y a parfois une option à activer pour lui dire que la macine sert de passerelle.

ipconfig /all PC1
D:\Mes documents\Mes images\ipconfig -all PC1.jpg

ipconfig /all PC2
D:\Mes documents\Mes images\ipconfig -all PC2.jpg

Si vous pouvez pas visualiser mes images, c’est que j’ai pas compris comment qu’on fait !

Pourquoi tu me parles de mon firewall, Loader, puisque j’ai écrit que même désactivé, le résultat est identique : pas internet sur le PC2

pour qu on puisse visualiser les images tu dois ou les mettre sur internet et nous donner l adresse du site…

et puis excuse moi je sais pas pk ms j etais parti que tu avais du XP…

J’ai trouvé !!!

en fait c un truc a la con :

il faut autoriser svchost.exe, alg.exe a se conecter a internet et au reseau, parceque jles avais bloqué

et jme suis fait chié une journée pour sa !!!

Tu vois que c’était pas si bête de parler de ton firewall :wink:

ça m’intéresse fortement gillou87 car moi aussi je viens de voir que le firewall du PC1 bloquait SVCHOST.EXE,
donc je le réautorise mais peux-tu m’indiquer quelle est ta configuration IP sur les 2 ordinateurs et les options internet/paramètres réseau du PC2 ?

ps: je sais pourquoi je ai bloqué SVCHOST.EXE, j’ai désactivé temporairement mon firewall et j’ai chopé un truc sympa ‘backdoor.win32.lil.a’ dans le fichier en question (bloqué par Kaspersky pendant une mise à jour).

Si c’est ça, je pète un cable mais serai bien soulagé !

slt magnum

enfait j’ai fait la meme configuration que clubic, sans utiliser l’assistant xp

par contre j’ai fait un petit truc en plus qui est pas marqué dans le topic:

tu clique droit puis propriete sur ta connexion internet (sur le pc1), dans la fenetre de partage (parametres avancés), tu clique sur parametre en bas et tu autorise tout, je sais pas si sa change grand chose

mais bon je le laisse quand meme, maintenant que sa amrche jy touche plus!

si t’a encore des blemes, tu peux me contacter sur msn

salut à tous,
mon pb n’est pas malheureusement pas encore résolu.
pour rappel, les 2PC sont sous windows2000 pro.
à gillou87, j’ai donc comme prévu autorisé le SVCHOST.EXE dans le firewall du PC1 (le PC2 n’en a pas) MAIS bien sûr, ça n’a rien changé.
J’ai déjà essayé la configuration décrite dans clubic (paramétrer son réseau local/partage internet sans routeur).
J’ai regardé le paramétrage du partage de connexion internet/paramètres, je ne vois ce que ça peut changer : j’ai deux onglets Applications & Services. Je ne sais pas configurer l’onglet Applications et le PC2 n’utilise pas les services indiqués dans le 2nd onglet.
Comment doit-être configuré le PC2 dans l’onglet connexions/paramètres réseau dans les options internet ?
Info supplémentaire: obligé d’attrbuer une IP fixe aux 2PC pour que les 2PC se voient dans les favoris réseaux et partagent leurs données.

Désolé pour la longueur mais j’essaie d’être le plus précis possible.
Merci de m’aider.

Ca y est enfin CA MARCHE : partage de fichiers et INTERNET !
J’ai tout bonnement repris la configuration réseau/partage internet sans routeur décrite dans clubic (sous XP, moi j’ai 2000 !), et cette fois, je ne me suis pas trompé ou n’ai rien oublié.
Par contre, je peux témoigner que

  • je peux bloquer le fichier SVCHOST.EXE dans le firewall du PC1 sans altérer l’accès internet des 2PC,
  • aucun besoin d’ajouter le suffixe DNS (nom PC1) dans paramètres TCP/IP du PC2,
  • finalement rien à configurer (PC2) dans options internet/connexions/paramètres du réseau local.
    Merci à tous

et je suis dégouté, CA MARCHE PLUS !

j’ai voulu installer le pare-feu que j’ai sur le PC2 mais version freeware (Look’n’stop) le PC1 a Look’n’stop 2.05. Et là, un coup le partage de fichiers marchait pas, un coup internet… je n’ai pas réussi à les paramétrer. Alors je l’ai désinstallé complétement du PC2,

et là, comme avant, plus internet sur le PC2 alors le partage de fichiers fonctionne à nouveau nickel. Je n’ai pas modifié la config par rapport à lorsque tout marché.

Comment vs témoigner de mon écoeurement !

Le firewall n’est utile que sur le PC qui partage Internet. Il ne sert à rien sur le 2è PC.

Vérifie que tu n’aies pas modifié la config du firewall sur le PC1.
Tu as peut-être une option dans ton firewall pour lui dire de considérer une carte réseau comme sûre (celle qui relie le PC1 au PC2) ou bien de ne faire aucune vérification pour des requêtes venant d’une IP donnée (celle du PC2).

J’ai vérifié la config du PC1 : OK

J’ai aussi complétement désactivé le firewall pour le réseau local, il n’y a aucune entrée du journal qui m’alerte à ce propos. De plus, il est déjà configuré pour ignorer les adresse de type 127.0.x.x et 192.168.x.x
Sauf erreur, je ne pense pas que mon pb vienne du pare-feu.
Voilà je sais pas trop quoi ajouter.
J’aimerai fortement faire cette config avant d’installer un switch et activer le mode routeur de la freebox.

Une fois que tu auras installé un switch et activé le mode routeur de la Freebox, cette configuration ne te servira plus.

Est-ce que ça vaut le coup de se prendre la tête pour ça ?