Forum Clubic

Paquets défectueux sur Debian testing

Salut tout le monde,

Voici ce qu’il m’arrive : çà fait plusieurs fois que je tente d’installer des applis relativement connus comme vlc et je me prends ce genre d’insulte :

Quelqu’un à déjà rencontré ce problème ?

dans ce cas de figure, j’essais d’installer les paquets duquel il dépend jusqu’à trouve celui qui pose problème.

Lance ces installations l’une après l’autre, et voit laquelle ne passe pas. ATTENTION quand même, avant d’accepter une installation, vérifie qu’elle n’enlève rien d’important à cause d’incompatibilités de version !

comme tu es en testing, je miserai sur un paquet qui a été mis à jour récemment et qui nécessite une version plus récente d’un autre paquet pas encore en testing.
Regulièrement, fait un apt-get update suivi d’un apt-get dist-upgrade, et vérifie que rien d’important n’est enlevé avant de valider.

Si t’es en testing aloors tu es expose a ce genre de probleme. A mon avis, le paquet est casse et il faut attendre qu’il soit repare. Ca peut prendre qq jours.
Peut etre que la testing n’est pas adaptee a tes besoins qu’il vaudrait mieux que tu revienne sur une sarge ou une ubuntu (pour avoir des paquets plus recents)

Alors :

  • J’en ai trouvé un qui est demandé par vlc : libflac6 que j’ai moi en version 7. D’où ce qu’il me dit : version non installable. Dans ce cas, je présume qu’il me faut attendre que vlc soit mis à jour avec cette lib là notament.

  • La testing est la moins mauvaise dirons-nous : la stable est pas assez avancée pour une utilisation en station de travail et l’unstable … je suis pas cinglé :smiley:

ben ouais mais visiblement, t’as l’air de galerer pour ce genre de problemes tout a fait courant.
Testing veut bien dire ce que ca veut dire.
Pour moi, les utilisateurs de testing ne devraient meme pas avoir a poser de questions dans des forums… sinon, ca veut dire qu’ils ont fait le mauvais choix.
A la rigueur, ils peuvent poser des questions sur comment config les nouvelles versions des paquets mais pas sur la gestion de la distrib…

Si tu veux du debian a jour et stable passe sur ubuntu

T’exagère un peu quand même :wink: le type peu avoir envie de découvrir et d’apprendre et s’il ne tente pas l’expérience du feu un jour, il ne sera jamais régler ce genre de problèmes…
L’important c’est qu’il ne flood pas sur les listes de diffusion de debian, un bug report (vérifie avant s’il n’existe pas déjà) suffit pour ce genre de chose. Mais il peut toujours demander conseil s’il a un doute :wink:

T’as raison mais je prefere decourager un peu l’utilisation des testing et des sid et conseiller ubuntu plutot que l’inverse.
Car debian est vraiment particuliere…

je vois ce que tu veux dire :oui:

au passage, si tu est en debian sid, évite la mise à jour de udev d’aujourd’hui (version 0.100-1) il est encore cassé :paf:
Si tu l’as déjà fait et que tu n’as pas nettoyé le cache, réinstalle l’ancienne version 0.098-2