Forum Clubic

Opera 8 sur clé USB ?

Est-il possible d’utiliser Opéra 8 à partir d’une clé USB (donc sans installation prealable) un peu comme le permet Portable-firefox ?

J’ai un peu essayé mais le lancement d’opera crée automatiquement un profil sur la machine dans “documents & Settings”.
Or j’aimerai que les infos de profils viennent avec Opera sur la Clé USB, et uniquement definir le cache sur la machine locale (le cache sur la Clé USB c’est pas jouable => trop lent)

Le problème vient de la première installation d’Opera.

Par défaut dans l’installation, il y a une option cochée qui permet de créer des profils par utilisateur, donc placé dans Documents & Settings. Dans le cas où elle est décoché, le profil sera stocké dans un sous-répertoire du répertoire d’Opera, ce qui conviendrait à ton utilisation.

Pour corriger cela, édite le fichier OperaDef6.ini qui se trouve dans le répertoire d’Opera.
Cherche une ligne de ce genre :
[fixed]Multi User=1 ; If enabled Opera will use Windows profiles to store individual user settings[/fixed]
Il suffit de changer à Zéro, de lancer Opera, ce qui créera un profil neuf dans le répertoire d’Opera qu’il suffira d’améliorer (copie des fichiers bookmarks/cookies etc… du profil originel).

:jap:

je vais voir ça

Pour le problème du cache en local et non sur clé USB, voici la piste :
http://forum.clubic.com/forum2.php?config=cl […] p=1&trash=0&subcat=0

Voila ce qu’il te faut: http://www.obermair.net/opera/operausben.htm

J’ai testé et ça marche nickel! :slight_smile:

Oula… Le site indiqué par dox me fait remarquer que j’avais oublié qu’il faut adapter le répertoire de chaque ligne du fichier Opera6.ini et Opera6Def.ini, à la Clé USB http://membres.lycos.fr/tkocgif/clubic/smileys/21596-5.gif

Par contre je ne comprend pas pourquoi dans Opera6.ini le répertoire devient .\Profile\ (logique), alors que dans OperaDef6.ini c’est %operadir% ce qui nécessite de donner à Windows une variable d’environnement (Le .bat sert à ça mais illogique) ?

Il serait curieux que la 1ère méthode ne fonctionne pas dans les deux fichiers :heink: Il faudra que je fasse un essai un jour…

dox -> Merci :super: