Forum Clubic

[OpenSuse 10.2] Problème de lenteur avec xgl - KDE

Bonjours a tous,

Je suis un débutant avec Linux Suse et je vien tous juste d’effectuer l’installation. J’ai eu l’idee de configurer le cube 3D en suivant ceci : http://www.novell.com/documentation/opensu…e_cust_xgl.html

mon gros problème a suivi le redemarrage :??: incapable de travailler, il est devenu telement lent ça prend un temps fou a ouvrir une petite fenêtre …

Comment corriger ce problème?
Si je me trompe pas, il faut que je remettre cette valeur DISPLAYMANAGER_XSERVER="Xorg"
mais comment en ligne de commande ???

Merci de votre aide!

Salut,

Pour avoir les plaisirs d’XGL/Aiglx, il faut (malheureusement) utiliser les pilotes non-libre de ta carte graphique.
Si tu as la chance de posséder une nVidia, ce sera facile de les installer, sinon … bon courage :smiley:

En tout cas, regarde si tu trouves ces pilotes dans les dépots de ta distribution et installe-les.

EDIT : bienvenue dans le monde Libre :hello:

Exist-il un moyen dans le mode ligne de commande de replacer la valeur de DISPLAYMANAGER_XSERVER="Xorg" a la place la valeur DISPLAYMANAGER_XSERVER="Xgl"

Je ne connait pas la syntaxe pour y arriver.

Merci!

Eu ton ps est peu etre incapable de le supporté

c’est quoi tes config ?(ram,processeur,etc)

J’ai une carte A7N8X-VM
Processeur Athlon 3200
Carte Graphique Saphire Radeon 9600 pro 128 mo
Memoire 512 mo

O pire on pourait dire que tu n’as pas assez de ram

Sinon il est conseillé 256 pour la CG avec la 3D

Regarde ici : http://forum.ubuntu-fr.org/viewtopic.php?pid=571211
En tout cas je ne pense pas que cela vienne du manque de mémoire.

Moi je tourne avec les pilotes libres et ça marche très bien. Beryl est un peu lent si je le lance, mais pour bosser, c’est pas l’idéal donc…
L’avantage du pilote libre c’est qu’il supporte directement aiglx qui est par défaut dans les dernieres versions de xorg. Autrement il n’y a presque rien à faire pour que ça marche.

Sinon tu trouveras des infos ici pour installer (et donc désinstaller) xgl: http://en.opensuse.org/Using_Xgl_on_SUSE_L…ng_Xgl.2FCompiz

Selon ce que j’ai trouvé la ligne de commande est : gnome-xgl-switch --disable-xgl
par la suite il ne reste qu’a rebooter.

Je vais vous revenir avec mon résultat.

Merci!

J’ai fait tourner beryl avec:
Geforce 4800se 128mo (de loin le plus fluide de tous)
Radeon 9800se 128mo
et même avec une radeon 7000 64mo.(C’est aussi fluide sur celle-ci que sur la 9800 parce qu’elle tourne avec le driver libre alors que la 9800 ne peux pas et que je suis obligé de passer par le driver proprio+XGL)

Donc 256Mo ne sont pas forcément obligatoire…

Avec une Ati je pense que tu va être obligé de passer par XGL + driver proprio.
Je ne connais pas l’install sous suse pour celui ci.

J’ai suivi la procédure de désactivation du XGL ici . Cette procédure fonction très bien. Il est important de se loguer en user root pour que cette procédure fonctionne. Il me reste qu’a installer les drivers ATI pour la 9600 pro.

Merci pour l’info,

Je vous reviens avec mes infor de l’installation du driver de la carte video.