Forum Clubic

OPENLDAP - Linux et Benny Hill

Bonjour,

Je doit attaquer une base LDAP en PHP.
J’installe donc OPENLDAP qui refuse, il demande d’installer CYRUS
J’installe donc CYRUS qui refuse, il demande d’installer Kerberos
J’installe donc Kerberos qui s’installe. (Hlleluja !!)
J’installe donc CYRUS qui refuse, il demande d’installer Kerberos…

Les auteurs de Linux seraient-ius des fans de Benny Hill ?

Version de Kerberos installée: 1.51 Stable
Tentative Cyrus : cyrus-imapd-2.0.17
Message obtenu: configure: error: The Kerberos DES library is required for Kerberos support.

Merci !

regarde du coté des paquetages DEV de kerberos

sinon tu utilses quelle distribution ?

c’est pour ca que ya des gestionnaires de packages qui gére les dépendances :wink:

apt
yum

L’ on insistes pas suffisament à mon goût sur l’importance d’utiliser le gestionnaire de packetages, seule manière efficace de gérer les dépendances. Pour ma part lorsque un programme n’est pas disponible au niveau du gestionnaire, j’essaies d’éviter de l’installer (sauf sur mon pc de test, lui ce n’est pas important) :na:

Je sais, j’ai essayé par les RPM. Vous croyez que ca m’amuse d’avoir perdu une journée. Quand je compare avec la procédure Windows ! Et pourtant j’adore Linux mais des fois !!
C’est une RedHat 9
J’essayerai les DEV

Merci !

Encore une distri en carton la RedHat :ane:

Un petit
emerge openldap

et çà roule !!!

Bon ok, ils ont déconné avec les dépendances de paquet sur ta RedHat.
Met à jour ta liste de paquets, pour vérifier qu’il n’y en a pas une plus récente.
Sinon, il va te falloir compiler les sources.
http://www.openldap.org/software/download/

PS : Kerberos n’est absolument pas une nécessité.

Y’en a vraiment qui tapent pour rien dire…

Ah bon ??? !!!

Compiler les sources n’est pas la solution à ton problème ???
C’est probablement la seulle solution que tu as pour installer ton openldap vu que ton gestionnaire de paquets délire.

Et je ne peux pas m’empêcher de penser que c’est lamentable de la part de RedHat, vu qu’il font payer leur distri, d’avoir ce genre de problèmes sur des paquets pourtant relativement utilisés.

D’ailleurs puisque tu payes pour avoir de l’aide, c’est chez eux qu’il faudrait que tu t’adresses.

Et rien ne t’empêche non plus de prendre une distri où openldap s’installe sans soucis.

Une personne qui doute de la puissance d’un gestionnaire de paquets :o :

La première instruction me liste le paquet, avec les options que j’ai choisi. Pour la seconde, c’est si je veux une autre version du paquet :sol: (ça se règle facilement, comme les options de compilation du paquet).

Ensuite, c’est sûr que sur une RedHat, ce n’est pas le même univers : bienvenue en 2006 donc :p.

edit : tu remarqueras le - devant kerberos, ce qui fait qu’il n’est pas actif sur cette compilation, et donc la réponse de e.nounours.

je trouve drolement etonnant que openldap necessite d’installer kerberos et cyrus-imapd ( :ouch: )
Redhat ne peut pas avoir ce genre de probleme, c’est impossible… surtout sur openldap qui est quand meme une grosse appli tres utilisee professionnellement.
As tu utilise ton gestionnaire de paquets (yum) ou as tu telecharge des rpm sur le net a la main ? IL NE FAUT PAS TELECHARGER DES PAQUETS A LA MAIN SI ON NE SAIT PAS EXACTEMENT CE QUE L’ON FAIT :wink:

De plus si on revient a ton probleme initial, je ne vois pas pourquoi tu souhaites installer openldap pour faire du php… ta base ldap n’est elle deja pas existante ?

Je reviens dessus si ta base LDAP existe déjà il te faut avoir le support de ldap dans php, si il ne l’est pas par défaut, afin de pouvoir l’exploiter. Un petit phpinfo te diras tout :slight_smile:

:heink: Enfin étrange quand même ton problème de dépendance j’ai fait des install de openldap sur mandriva, debian et même redhat sans avoir eu à installer kerberos ni cyrus-imapd c’est un peu stupide :ane:

Je pencherai plutot sur un update de ton arbre pour ton gestionnaire de package et refaire une install propre à partir de ton gestionnaire de paquets.

sur redhat je te conseil vivement yum, les commandes rpm ça va quand y avait pas yum :slight_smile:
et sert aujourd’hui essentiellement en ultime recours et aussi dans le cadre de recherche de
paquet sur ton OS

enfin bref bon courage :super:

Je vois pas trop ou j’ai merdé dans la mesure ou j’ai toujours réussi à installer des “fonctionnalités” dans PHP: le support pour SQLServer, GD, FPDF, etc…
Les RPM marchent pas je passe par la compilation. C’est tout !

>> Citation 1: je trouve drolement etonnant que openldap necessite d’installer kerberos et cyrus-imapd ( )
Redhat ne peut pas avoir ce genre de probleme, c’est impossible… surtout sur openldap qui est quand meme une grosse appli tres utilisee professionnellement.

Alors pourquoi me les demandes-t’il ?

>>Citation 2: Je pencherai plutot sur un update de ton arbre pour ton gestionnaire de package et refaire une install propre à partir de ton gestionnaire de paquets.

JE PASSE PAR LES SOURCES. SYSTEMATIQUEMENT

>>Citation 3: Ensuite, c’est sûr que sur une RedHat, ce n’est pas le même univers : bienvenue en 2006 donc

Et oui, on est en 2006 et on est à la Fedora 4 5 ou 6 ? Mais le support LDAP existait avant non ? Et puis le serveur est en prod. Je vois mal aller voir mon boss lui dire "Ecoute mec, on est en 2006, va voir les chébran de Clubic si tu me crois pas. Je vais passer 3 jour à installer la dernière distrib pour avoir acces à LDAP"

En dernier recours je modifirais les sources du configure.

Merci bonne nuis

les chébran de clubic essayent de te donner un coup de main alors change de ton s’il te plait

c’est pas parce que tu as réussi a installer les autres composants que tu n’a pas fait une erreur sur celui-là…
et passer systèmatiquement par les sources sur un serveur de production est BIEN PLUS DANGEREUX que d’utiliser une fedora sur un serveur critique !!!
si une faille de sécu est revelée, tu fais quoi ? tu recompile tout a la main en priant pour n’avoir rien oublié ???

bref…

red hat te conseillerais de passer par yum et si il y a une admin linux compétent dans ton entourage, demande lui conseil (et il te dira la meme chose)

Une erreur ?
./configure
make
make install

Y’a une erreur de syntaxe là ?

et ta lu la doc pour voir si yavais pas des arguments a passer au ./configure pour éviter d’avoir a dépendre de cyrus, kerberos et autres ?

aloaw :slight_smile:
la patience a ses vertues ke la raison ignore ? :jap:

http://www.int-evry.fr/mci/user/procacci/l…dap_int005.html

merci google, http://www.google.fr/search?hl=fr&q=redhat…ldap+make&meta=

pour information, lorsque tu demande de l’aide sur un forum, il est toujours + urbain de pas envoyer bouler les gens qui prennent un moment pour repondre a ton topic :slight_smile:

sinon, je ne vois pas vraiment l’interet d’utiliser une distrib sans son systeme de package, et je ne vois pas la difficultée d’installer un pc/serveur pour effectuer une migration vers un autre OS.

mais apparement, tu n’as pas l’air tres ouvert, et j’anticipe d’avance ton mecontentement, en te disant : bonne chance :neutre: :ane:

Merci pou tous ces précieux conseils.
J’ai trouvé un RPM qui s’installait. A présent j’obtient le message suivant à la compilation de PHP:
ext/ldap/ldap.lo: file not recognized: File truncated
collect2: ld returned 1 exit status
make: *** [libphp4.la] Erreur 1

Je désespère !

C’est bizzare la seule fois que j’ai installé openldap c’était sous Windows (pour vérifier sa compatibilité avec l’API client ActiveDS, sisi :wink: ) et pas besoin de kerberos ou cyrus ou autre :neutre:

Merci à tous (notement pour cette dernière remaque très constructive).
Finalement je compile php avec les librairies (./ext/ldap) livrées d’origine.
Pour la compilation, j’ai trouvé la soluce : make clean
Ca marche !!!!!!

C’est idiot dans la plupart des cas… surtout en prod…

c’est bien ce que j’avais en tete : prob d’install de php -> aucun besoin de kerberos ou cyrus-imapd pour openldap ni meme aucun besoin d’openldap tout court.

Je trouve que c’est vraiment pas le bon truc de recompiler php a la main… aujourd’hui la plupart des distribs permettent d’installer les principaux modules d’apache independamment les uns des autres avec les libs qui vont bien d’une maniere tres souple et tres rapide. La recompil n’apporte que le risque de faire une grosse erreur et perdre un temps fou en upgrade. A part pour des modules hyper particuliers (y’en a de moins en moins) non packages, il faut utiliser les paquets disponibles.