Forum Clubic

OpenGL très lent - lent, même après installation du driver

Bonjour,
Mon problème est le suivant, je viens récemment de me mettre à Linux, et honnêtement, j’entends bien y rester (j’ai la Mandrake 10.1 Download). J’ai installé, non sans peine mais avec succès, les drivers de ma carte graphique Nvidia. Chronium, SuperTux et autre TuxRacer fonctionnent très bien en mode OpenGL. Jouant à Unreal Tournament sous Wndws et le sachant compatible avec Linux, j’ai eu l’idée de l’installer. Je règle mes contrôles, mon perso et je commence une partie. Quelle ne fut pas ma surprise en voyant que j’avais moitié-moins de fps qu’avec Direct 3D sous Wndws ! Ma config est certes faible (PIII 800MhZ, 384Mo de Ram, Geforce4 MX440 128mo agp8x) mais dans la map Face Classic, j’avais bien 30fps moyens avec Direct3D et là, avec OpenGL (et en mettant toutes les textures au minimum) je peine à en avoir 10 ! Je crois pourtant avoir bien configuré ma carte graphique (j’ai éditer plusieurs fichiers)… Si quelqu’un peut m’aider ?
Merci

Oui, c’est bien Unreal Tournament 2004.

Fait un petit glxgears, et donne nous les résultats, pour voir si déjà les performances de ta carte sont normales.

et montre nous les lignes “Load blabla” de ton /est/X11/XFConfig-4 (qui sais comment s’appelle ce fichier avec xorg??)

/etc/X11/xorg.conf :wink:

Tout d’abord, merci de prendre mon problème à coeur.
Ensuite, le glxgear m’affiche 1800
et puis la section [Module] de /etc/X11/xorg.conf

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "glx" # 3D layer
EndSection

Merci
2on5

Au fait, mon pros, c’est un celeron, pas un PIII… ( :sweet: )
Excusez l’erreur.
Merci
2on5

il y a sûrement un problème :ane: : avec mon ati dont les pilotes sont tous pourris sous linux je fais 3000 fps à glxgears :paf:

Tu n’aurais pas trifouillé les paramètres d’antialiasing et compagnie avec nvidia-settings ? pour supertux ça peut passer, mais ut2004 risque d’avoir du mal avec l’antialiasing à fond :smiley:

Sinon regarde ton fichier de log de xorg pour savoir s’il n’y a pas des modules qui ne réussissent pas à se lancer : /var/log/Xorg.0.log (pour trouver les erreurs, tu peux faire : cat /var/log/Xorg.0.log | grep “(EE)”, ou encore cat /var/log/Xorg.0.log | grep “(WW)” pour les avertissements, etc…

hum…et si c’était le céléron qui limite…

Je suis tout ce qu’il y a de plus débutant donc, dans l’immédiat, j’ai un peu du mal avec les gros mots comme ‘antialiasing’ ! J’ai édité pas mal de fichiers alors peut-être ^^ ! Au sujet des erreurs et des avertiseements du log de ‘xorg.0.log’ ils ne sont pas si nombreux.0… Jugez par vous-même :

$ cat /var/log/Xorg.0.log | grep "(EE)"
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.

$ cat /var/log/Xorg.0.log | grep "(WW)"
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(WW) Option "XkbOptions" requires an string value
(WW) NVIDIA(0): Not using mode "700x525" (height 1050 is larger than
(WW) NVIDIA(0): EDID-specified maximum 1024)
(WW) NVIDIA(0): Not using mode "768x576":
(WW) NVIDIA(0): horizontal sync width (846 - 832 = 14) not a multiple of 8
(WW) NVIDIA(0): Not using mode "576x384":
(WW) NVIDIA(0): horizontal sync start (589) not a multiple of 8
(WW) NVIDIA(0): Not using mode "360x200":
(WW) NVIDIA(0): horizontal sync start (378) not a multiple of 8

C’est grave docteur :smiley: :??: ?
Merci
2on5

non c’est pas grave : pas d’erreur et quelques avertissements à la noix :wink:

c’est pas bête du tout ça :ane: :paf: : t’as sûrement raison :oui:
essaie avec un jeu moins gourmand, genre enemy-territory ça devrait passer sur ton celeron sans ramer…

[Edit] : ah bah non, c’est pas logique, puisqu’il ne rame pas sous windows :confused:

Oui, voilà, ça ne rame pas sous Wndws (moins :riva: ) c’est pour ça j’ai un peu du mal à comprendre… OpenGL est-il réputé moins rapide, moins performant que Direct3D ? L’un de vous n’a t-il jamais eu un problème semblable ?
2on5

Récemment, je suis repassé sous Wndws pour tester UT (à ma grande honte !!!). Pas de problème, comme avant… Et puis j’ai testé OpenGL, et c’était aussi lent que sous Linux… Peut-être est-ce normal…
2on5

Faut pas exagerer quand meme !
Tu ne peux pas avoir de bonnes perfs avec une carte pareille. Sous windows comme sous linux.
Sous windows tu dois jouer en 800x600 pour que tu dises que ca rame pas ?

Pour info avec ma Geforce 3 ti 200 :

ipo@gaia:~$ glxgears
15397 frames in 5.0 seconds = 3079.400 FPS
17925 frames in 5.0 seconds = 3585.000 FPS
17986 frames in 5.0 seconds = 3597.200 FPS
17972 frames in 5.0 seconds = 3594.400 FPS
17992 frames in 5.0 seconds = 3598.400 FPS
17978 frames in 5.0 seconds = 3595.600 FPS
17991 frames in 5.0 seconds = 3598.200 FPS

Sinon tu peux toujours utiliser un dual boot si ça marche sous Windows, autant profiter du fait que tu l’aies et que ça marche, sauf si tu aimes perdre ton temps. Même si ça fait mal au c*l à ta réputation d’jeuns rebelz. (T’as vu on met pas les étoiles au même endroit)

Je ne sais pas ce qu’il en est sous linux, mais sous windows les drivers nvidia activent par défaut un antialiasing en OGL et non en DX. Si tu vires cet antialiasing tu auras certainement de meilleures perfs en OGL qu’en DX, mais un rendu moins fin.
Pour le reste, désolé je ne joue pas sous linux, il faut bien que mon windows serve à quelque chose :slight_smile: