Forum Clubic

Nut et prtg

Bonjour,
Je suis actuellement en Formation et plus précisément en stage entreprise. J’ai vraiment besoin d’un petit coup de main…
Mon sujet est l’installation de NUT pour la gestion des onduleurs sous Debian Etch et Sarge.

Sous Debian Etch: NUT fonctionne correctement. La configuration est parfaite.
Apres, j’ai donc installé SNMP. Ca fonctionne bien aussi. J’ai installé WindowsNutClient, il remonte bien les informations. Il faut impérativement que je puisse récupérer les infos de l’onduleur dans PRTG. Je n’y arrive pas :frowning:

Sous Debian Sarge, impossible d’accéder à l’onduleur. J’ai exactement les mêmes fichiers de config.
#La commande upsdrvctl:
debian3:/etc/init.d# upsdrvctl start
Network UPS Tools - UPS driver controller 2.0.1
Network UPS Tools - Energy Sistems UPS Smart/Advanced UPS driver 0.22 (2.0.1)
Checking UPS…Found Q1…Found F…OK
Energy Sistem UPS Smart found

Après, le lance NUT:

debian3:/etc/init.d# sh nut start
Starting Network UPS Tools: (upsdrvctl failed) upsd upsmon.

Pourquoi?? Quelqu’un peut il m’aider?? Qu’est ce qu’il me manque?
Merci d’avance de prendre un ptit peu de temps
Nath

Salut,

Les logs racontent quoi ?

Bonjour,

Le /var/log/syslog raconte ceci…
Dec 16 15:03:25 debian3 upsd[1223]: /etc/nut/upsd.conf is world readable
Dec 16 15:03:25 debian3 upsd[1223]: Connected to UPS [ipel]: esupssmart-ttyS0
Dec 16 15:03:25 debian3 upsd[1223]: /etc/nut/upsd.users is world readable
Dec 16 15:03:30 debian3 upsd[1224]: Startup successful
Dec 16 15:03:30 debian3 upsmon[1226]: Startup successful
Dec 16 15:03:30 debian3 upsd[1224]: Connection from 127.0.0.1
Dec 16 15:03:30 debian3 upsd[1224]: Client localhost@127.0.0.1 logged into UPS [ipel]
Dec 16 15:03:30 debian3 upsmon[1227]: Poll UPS [ipel@localhost] failed - Variable not supported by UPS
Dec 16 15:03:30 debian3 upsmon[1227]: Communications with UPS ipel@localhost lost
Dec 16 15:03:35 debian3 upsmon[1227]: Poll UPS [ipel@localhost] failed - Variable not supported by UPS
Dec 16 15:03:35 debian3 upsmon[1227]: UPS ipel@localhost is unavailable

Merci d’avoir pris le temps de repondre…
Cordialement, Nath