Forum Clubic

Nouveau Disque: Copie de fichier impossible! - Serveur Debian 3.1

:hello:

J’ai installé hier soir un nouveau disque dur sur mon serveur de fichier Debian 3.1

J’ai donc 3 disques durs:

  • IBM DPTA20Go (PATA) sur lequel le systeme est installé
  • Seagate SATA 160Go pour les fichiers
  • Maxtor SATA 200Go (le nouveau)

Les disques SATA sont relié à une carte controleur SATA PCI.

Tout ce petit monde s’installe sans soucis et tourne en ext3

Mais depuis hier j’essay de copier une partie des données du seagate vers le maxtor, et ça ne veut pas :pfff: … ça coince irrémediablement au bout de quelques gros fichiers :grrr:

A savoir que je controle le serveur à distance soit par putty, soit webmin soit vnc

J’ai tout essayer, meme une copie en passant par mon PC via le reseau: idem ça plante sans appel. Tout ce qu’il me reste à faire après ça c’est forcer un reboot du serveur :neutre:

De quoi est-ce que ça peut venir ??

Matos:
P3-500
192Mo RAM

Merci

Et çà marche avec les petits fichiers ?
C’est toujours le même où çà bloque ?
Essaye fichier par fichier.

Essaye aussi avec un autre FS sur le nouveau disque. Au hasard, XFS :ane:

ben ça bloque plutot aleatoirement en fait :neutre: mais assez rapidement…

là justement j’essai fichier par ficher en passant par le reseau… mais bonjour la galere, j’en ai pour 2 jours à ce rythme là :pfff:

Et quand tu fais ton “cp -R *” dans la console, çà te donne un message d’erreur ?

File voir aussi les info hdparm -I /dev/sdX

rien du tout, nada … ça se bloque et c’est tout.
Une fois bloqué je n’ai plus acces au dossier de destination sauf à redemarrer

Avec VNC et gnome la fenetre de copie se gele sans que je puisse la fermer

bref c’est incomprehensible :??:

Par ex: là j’ai lancé une copie via entre les 2 disques via le reseau depuis mon poste WinXP avant de partir dechez moi… et je viens de constater que je n’ai quasiement plus acces à ma machine putty reste bloqué apres que je renseigne le password

:grrr:

Question les 2 disques dur SATA sont-ils à la même norme ?

2 ième question ce phénomène se produit-il lorsque tu copie de l’IBM vers ton nouveau disque ?

le seagate est un SATA1 , le maxtor est un SATA2 configuré en SATA1 via jumper

ça je n’ai pas essayé… je verrai ça tout à l’heure parceque là je n’arrive plus à prendre la main sur mon serveur avec putty :pfff:

si je fais ça avec sda ou sdb j’obtiens ça:

Avec hda il me donne bien des infos :neutre:

je viens de faire un essai rapide avec quelques petits fichier plus 1-2 gros: pas de soucis :ane:

mais je ne’ai pas de grosse liste de fichier sur l’IBM pour pouvoir faire un vrai test

là par contre je lance une copie de fichiers qui sont sur mon PC XP, pour voir si le probleme n’est pas du seul fait de la copie entre les 2 SATA qui seraient utilisé en meme temps.

bon ben la copie directe depuis mon PC c’est parfaitement deroulée

le probleme semble lié à l’usage conjoint des 2 SATA.

Probleme de controleur ? de driver ?

C’est ce que je pensais au départ mais il fallait en être sûr je pense un problème de contrôleur ou le dma mal configuré au niveau de tes disques sata .Pour un essai désactive le dma sur les 2 sata et refait le test.

et on fait ça comment ? :paf:

Pour désactiver


hdparm -d 0 /dev/xxx

Tu ajustes la /dev

Une autre chose as tu essayé la copie avec la commande rsync ?


~# hdparm -d 0 /dev/sdb

/dev/sdb:
 setting using_dma to 0 (off)
 HDIO_SET_DMA failed: Invalid argument

:neutre:

il connait pas rsync :riva:

Il est vrai normalement que avec le SATA le DMA est utilisé et que la commande hdparm n’est plus d’ aucune utilité utilité dans ce cas de figure. Je me grate la tête pour trouver une solution là :riva: .

Tu devrai essayer d’installer sur ton serveur rsync via apt-get ensuite refaire le test

niveau solution j’en ai trouvé une :ane:

je recopie les fichiers sur mon PC via le reseau… et je les réenvoi sur le serveur toujours via le reseau.
ça prend du temps (8Mo/s c’est pas les 30-40Mo/s qu’on peut avoir entre 2 disques) mais bon ça marche :neutre:

Une fois que j’aurai basculé les données je n’aurai plus à faire d’echanges entres les disques donc ça n’est pas problématique en soit, même si j’aimerai bien resoudre cette affaire :smiley:

J’vais voir pour rsync (quand j’aurai fini la copie :ane:)