Forum Clubic

.net framework 2.0 (vraiment obligatoire?)

Bonjour à tous,

J’aimerais déployer un petit programme de loginscript qui lit simplement un fichier texte , sur le réseau de l’école (travail de stage) , et la pluspart des machines de l’école n’ont pas le .net framework 2.0. Lorsqu’on lance le .exe sur une machine quelconque , un message d’erreur nous indique qu’il est impossible de lancer l’application justement parce qu’il manque ce framework.

Je voulais savoir si c’était possible de parader ce framework , enfin si c’était possible de pas devoir l’installer sur 600 machines juste pour un prog qui lit un fichier texte au login… merci d’avance

PS: J’utilise Microsoft Visual Basic 2005

Si tu utilises les spécificités du .NET, il faudra obligatoirement les runtimes.
Ton problème vient du fait de ton choix du langage, le C aurait largement fait l’affaire, voire, le VB, Delphi.

en gros si je code ca en c# , c’est gagné ?? Meme avec Microsoft visual studio

C# fait partis du .NET

ah , alors je code avec quoi? en VBA Excel ?? Ou aurais-tu un programme de developpement free en C ou C++

Code::Blocks

j’ai des problèmes avec code blocks , aurais-tu de la doc , ou un autre programme plus basique??

PellesC

merci bcp