Forum Clubic

Ndiswrapper Vs Madwifi... - La guerre est ouverte !

Bonsoir à tous !! Il y a quelques jours, j’ai posté le message suivant sur Ubuntu-fr : http://forum.ubuntu-fr.org/viewtopic.php?id=51994.

Voilà mon problème : J’avais enfin réussi à me connecter à mon réseau sans fil en passant par ndiswrapper et en désinstallant madwifi.Le problème, c’est que madwifi est installé en même temps que fglrx avec le Linux-restricted-modules-k7… Donc…

  • Si j’installe le Linux-restricted-modules-K7, l’accélération 3D est activée (normal, vu que les restricted-modules contiennent fglrx). De plus, la lecture des DVD est fluide. En revanche, je n’ai pas Internet.
  • Si je les désinstalle, je peux accéder au web via ndiswrapper et les drivers TNET1130. En revanche, pas d’accélération 3D et lecture de DVD saccadée à mort…

Si je veux les deux, je fais comment ???:o Y a-t-il moyen de désinstaller simplement madwifi sans virer en même temps les drivers pré-installés ?

Pour rappel, ma config :

  • AMD Sempron 2.8 GHz
  • ATI Radeon 9550
  • 1 Go de RAM
  • Ubuntu Dapper 6.06
  • D-Link PCI DWL-G520+

Merci à tous d’avance !!

Dans le fichier /etc/default/linux-restricted-modules-common, ajoute ça pour empêcher au module madwifi de se charger automatiquement au démarrage :
DISABLED_MODULES="ath_hal"

PS : j’ai mis “ath_hal”, mais je ne suis pas sûr que ça corresponde effectivement au module madwifi : faudra que tu vérifies.

Merci Mr_puit !! Je finis mon nettoyage :wink: et je teste çà !!

Bonjour.

Pour infos je possède une Dlink G-520 (chip atheros).
Les carte G520+ On un chipst Texas Instrument.
Tu ne peux donc pas utiliser les madwifi qui ne sont que pour les chipset atheros …

Il te faut utiliser les drivers acx pour ta carte (a la place de ndiswrapper):

http://acx100.sourceforge.net/index.html

Edit : je sais pas si j’ai bien compris ton probleme. : )

c’est justement le problème : les madwifi reconnaissent bien ma carte wifi sous la dénomination wlan0 mais le système ne trouve strictement aucun réseau sans fil même en spécifiant essid et l’ap avec iwconfig. dhclient ne donne absolument rien…

Je suis donc effectivement obligé de passer par ndiswrapper qui supporte les drivers pour acx.

Le problème c’est que madwifi identifiant déjà une carte sans fil, ndiswrapper ne charge pas les driver et donc pas de connection tant que les deux sont actifs. Le problème est complexe et je ne sais pas si j’arrive à bien m’expliquer…

Donc si tu n’utilise aps les madwifi, il te suffit de les installer ?

Pour cela, utilises-tu les madwifi ancienne version ou les madwifi-ng ? (donne moi la release au cas ou)

Pour désinstaller les ng :


ifconfig ath0 down
ifconfig wifi0 down
rmmod ath_pci ath_rate_sample wlan_wep ath_rate_onoe wlan ath_hal 
find /lib/modules -name 'ath*'  -exec rm -v {} \; 
find /lib/modules -name 'wlan*' -exec rm -v {} \; 
depmod

quelle commande dois-je utiliser pour te donner la "release" ??

execute les commandes au dessus ca devrait marcher. Le numero de version est surement indiqué dans le nom du paketage qui a installé les drivers madwifi

Mais je ne comprends pas l’utilité de supprimer les modules, alors qu’on peut tout bonnement leur dire de ne pas se charger… :confused:

Alors, les commandes ci-dessus passent bien mais j’ai toujours le même problème…

La release des Restricted-Modules est la 2.6.15-26-k7. Finalement, je commence à me demander qu’est-ce qui me pose problème dans ces “restricted-module” qui ne me posait pas problème sur la 5.10…