Forum Clubic

Nat et livebox sagem

Bonjour :slight_smile:

Je souhaite mettre en place un serveur FTP sur mon LAN et joignable depuis internet.
Pour me faciliter l’accès j’ai créé un compte sur No-IP.com

Mon point d’accès est:
callisto-hecate.myftp.org…

sauf que ma livebox possède le firmware F@st3202 version logicielle 3202_26014A
Le journal de securité m’informe du message suivant:
No IP for NAT - connections may fail [répété 2 fois, la dernière fois sur May 31 00:03:38 2008]

Et meme si je donne l’adresse de mon serveur pour le passer en DMZ, rien a faire.
Firewall de livebox au mini
autorisations accpetées forcées par défaut… toutes les sécurités sur OFF, mon serveur FTP n’est pas joignable depuis internet.

Si quelqu’un est interessé par le challenge je le remercie pour son aide

Salut,

il n’y a pas a activé par mail ton compte dns?
As tu bien rentré ton login et mot de passe dans la livebox (pour le compte dns bien entendu).??

Salut Koala06 :slight_smile:

Merci de ton interet :slight_smile:

Concernant le DNS je ne passe pas par DynDNS proposé par la livebox mais par NO-IP.com qui est gratuit pour un usage avec Alias (A), contrairement à DynDNS qui fais payer meme pour un usage d’Alias.

NO-IP.com propose un logiciel client pour se connecter et activer l’Alias enregistré (gratuitement, car pour un usage privé, simple), ou le nom de domaine acheté sur leur site. C’est le Dynamic Update Client (DUC… coincoin :wink:

Le coincoin NO-IP fonctionne très bien car si tu fais un ping à l’adresse “callisto-hecate.myftp.org” tu auras une réponse en plus de l’adresse IP en cours => la partie WAN de ma livebox est donc joignable.
Bref cette partie fonctionne bien.

Par contre si tu envois une requetes FTP à cette meme adresse, en considérant la déclaration des serveurs sur la partie LAN de la livebox, cette derniere devrais renvoyer la requetes FTP au serveur déclaré dans son LAN, et c’est là que ca ne fonctionne pas.

Selon la conf du filtrage avancé, je me retrouve avec 2 types de résultats:

  • L’accès est refusé ; erreur 111
  • Délais de réponse dépassé

=> soit je me suis completement planté dans mon parefeu de la livebox, soit le logiciel possède une erreur que SAGEM aura la gentillesse de rectifier fissa.

ce qui me met la puce à l’oreille sur le logiciel SAGEM actuel de la livebox c’est que la déclaration de mon serveur en tant que machine DMZ ne résous pas le probleme d’accès alors qu’elle est censé etre accessible depuis internet sans restrictions… et puis avec la version precedente mon serveur etait joignable… :confused:

Autre détails je ne dispose pas encore d’une ligne extérieure pour tester l’accès depuis l’exterieur (soit un test propre) car j’effectue mes test depuis mon LAN en tapant sur l’adresse NO-IP… J’ai les neurones en pelotte :wink:

A très bientot l’ami :slight_smile:

Re-

Si tu essaies depuis ton Lan, c’est normal que cela fonctionne pas car la livebox ne gère pas le “Loopack” (il me semble que ca se dit comme ca lol), donc il est impossible de tester de chez toi.
Il faut que tu testes avec un collègue depuis l’extérieur.

bonjour
jé un serveur ftp TYPSoft à installé jé une @ no-ip é une livebox inventel (avec @ IP fixe), je veu savoir si jé besoin de configuré mon serveur en mode passif pour kon puisse sy conecté depui l’extérieur?

Yop :slight_smile:

Ok pour le loopback. J’avais deja pu constater qu’avec un tracert la livebox n’aimais pas trop.

Si tu veux bien m’aider à faire les essais ce sera sympas :wink:
Un login anonymous sera suffisant pour la connexion :wink:

Pour le mode passif, avec typsoft ca avait bien fonctionné pour moi avant le flashage de ma livebox par orange.

Actuellement j’utilise GuildFTPd qui est très bien et complet (license GNU) avec une gestion des utilisateurs plus poussée que Typsoft avec des options de chemins et de droits en cascades, vraiment très bien.

Bon ben je vais configurer le parefeu pour permettre à Koala de me confirmer si ca marche ou pas :wink:

A plus les potots :slight_smile:

ok coolboard, je veux bien tester… si t’as des paramètres a me donner, file les en MP :wink:

J’ai tenté une connexion avec l’adresse plus haut et en anonyme, ca donne pas grand chose… J’ai bien une redirection vers une ip publique mais ca bloque.

salut koala06 :slight_smile:

Merci d’avoir essayé.
C exactement le probleme que j’esai de resoudre, c’est a dire que la partie de redirection de No-IP.com fonctionne très bien, mais mon point d’entré de ma livebox ne laisse pas passer les requettes FTP vers le LAN.

J’ai bien tenté de forcer mon serveur en tant que machine DMZ, mais la livebox ne fais le NAT vers l’adresse que je lui indique.
Dns la configuration basique je renseigne bien la presence d’un serveur FTP avec le port 21 qui devrais etre ouvert, mais la encore rien ne se passe, et dans la configuration avancé je configure le parefeu au minimum, donc la livebox est censé accepter les requettes entrantes, toujours rien…
Dans le filtrage avancé qui est censé permettre de faire des tri selectifs en fonction du type de paquets, je renseigne les entrées en PPPoE et ETHoA qui gèrent l’accès coté WAN de la livebox, meme résultat… RIEN… Bouhouhouh !!!

Alors que la version logicielle d’avant flash, simplement en renseignant la presence d’un serveur FTP en mode basic avait autorisé le NAT…

Qu’en penses-tu ?

A plus :wink:

Re-

En fait pour qu’on serveur ftp fonctionne je pense qu’il faut ouvrir des ports passifs.
Sur celui que j’avais fais par exemple, j’avais ouvert les ports passifs de 50000 a 50100 ( livebox et redirigé vers l’ip du pc), mais aussi activer les ports passifs sur mon serveur, c’était la seule solution a l’époque que j’avais trouvé pour que cela fonctionne parfaitement.

En revanche, je ne sais pas si ta redirection fonctionne, car c’est toujours la même IP publique qu’hier.


Qu'as tu comme Ip publique (si tu veux envoyer en MP)?? Edité le 03/06/2008 à 18:47

salut :slight_smile:

Je vais etre absent pour un petit mment, merci pour ton idée des que je suis de retour je te fais part du resultat :wink:

a plus

salut :slight_smile:

Bon ca y est je suis de retour…

C’est vraiment le serpent qui se mord la queue avec cette livebox… j’ai bien essayé de configurer des ports passifs, mais j’ai l’impression que la livebox ne redirige pas correctement les requetes du WAN vers le LAN.

Je vais voir si quelqu’un chez SAGEM veux bien m’en dire plus :wink:

A la peche aux infos maintenant… :confused:

A pluche… :wink:

Ok, mais si tu veux fais moi un log et mdp, et j’essaie de me connecter, tu partages un dossier vide.

RESOLU

Salut Koala06 :slight_smile:

Désolé pour mon absence ces derniers jours…

!!! J’ai trouvé la solution !!! en fait c’etait tout con mais il fallais le savoir…

en mode basic il suffit d’aller dans le menu “SERVER LAN” et de configurer le nom du programme qui doit avoir les ports ouverts, l’adresse IP de la machine qui le supporte et la plage des ports que l’on souhaite.

il faut cliquer sur “Appliquer” et puis surtout IL FAUT REDEMARRER LA LIVEBOX -> un doigt sur le bouton reset on attends une petite minute et… C’EST PARTI MON KIKI :slight_smile:

Normalement tu dois pouvoir te connecter sur mon serveur avec le login que je t’es préparé et envoyé en MP :wink:

Au plaisir…

For all the foreign services, when we need apply any settings modification into the french Orange livebox by SAGEM, we need to turn off and on the livebox.

1 minute to wait the boot up and our servers into our LAN are working from the WAN (internet)

:wink:
Edité le 04/07/2008 à 11:38